summaryrefslogtreecommitdiff
path: root/app-crypt/libsecret/files/libsecret-0.20.4-meson-build-test-vala-unstable-with-DSECRET_WITH_UNS.patch
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-12-16 09:00:41 -0500
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-12-16 09:00:41 -0500
commit32c0b155790ab7e228d889f66a25aef3f33fb702 (patch)
tree9ac3dba8e46361a163a178637d8a601949562697 /app-crypt/libsecret/files/libsecret-0.20.4-meson-build-test-vala-unstable-with-DSECRET_WITH_UNS.patch
parent49a02664e7f96c83e06b1cec983f03bc5489fff1 (diff)
downloadgentoo-overlay-32c0b155790ab7e228d889f66a25aef3f33fb702.tar.xz
gentoo-overlay-32c0b155790ab7e228d889f66a25aef3f33fb702.zip
app-crypt/libsecret: sync
Diffstat (limited to 'app-crypt/libsecret/files/libsecret-0.20.4-meson-build-test-vala-unstable-with-DSECRET_WITH_UNS.patch')
-rw-r--r--app-crypt/libsecret/files/libsecret-0.20.4-meson-build-test-vala-unstable-with-DSECRET_WITH_UNS.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-crypt/libsecret/files/libsecret-0.20.4-meson-build-test-vala-unstable-with-DSECRET_WITH_UNS.patch b/app-crypt/libsecret/files/libsecret-0.20.4-meson-build-test-vala-unstable-with-DSECRET_WITH_UNS.patch
new file mode 100644
index 0000000..99e5f69
--- /dev/null
+++ b/app-crypt/libsecret/files/libsecret-0.20.4-meson-build-test-vala-unstable-with-DSECRET_WITH_UNS.patch
@@ -0,0 +1,44 @@
+From 92fe125ee1b9f36bd69308c173e9d6147a5fc1e1 Mon Sep 17 00:00:00 2001
+From: Matt Turner <mattst88@gmail.com>
+Date: Thu, 10 Dec 2020 23:19:55 -0500
+Subject: [PATCH] meson: build test-vala-unstable with -DSECRET_WITH_UNSTABLE
+
+Fixes: https://gitlab.gnome.org/GNOME/libsecret/-/issues/54
+---
+ libsecret/meson.build | 12 ++++++------
+ 1 file changed, 6 insertions(+), 6 deletions(-)
+
+diff --git a/libsecret/meson.build b/libsecret/meson.build
+index f57e363..55e9d95 100644
+--- a/libsecret/meson.build
++++ b/libsecret/meson.build
+@@ -310,12 +310,12 @@ if get_option('introspection')
+ add_languages('vala')
+ valac = meson.get_compiler('vala')
+
+- valatest_names = [
+- 'test-vala-lang',
+- 'test-vala-unstable',
+- ]
++ valatests = {
++ 'test-vala-lang': [],
++ 'test-vala-unstable': ['-DSECRET_WITH_UNSTABLE'],
++ }
+
+- foreach _valatest : valatest_names
++ foreach _valatest, extra_cflags : valatests
+ test_bin = executable(_valatest,
+ '@0@.vala'.format(_valatest),
+ dependencies: [
+@@ -327,7 +327,7 @@ if get_option('introspection')
+ ],
+ link_with: mock_service_lib,
+ include_directories: config_h_dir,
+- c_args: test_cflags,
++ c_args: test_cflags + extra_cflags,
+ )
+
+ test(_valatest, test_bin,
+--
+2.26.2
+