summaryrefslogtreecommitdiff
path: root/app-emulation/wine-gecko/wine-gecko-2.47.2.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-07-26 12:01:46 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-07-26 12:01:46 -0400
commitd318615233b34e42df5da47c588780928832d40a (patch)
tree5f47414bbd35a54145a5e4fac5c6cbec3f62a05d /app-emulation/wine-gecko/wine-gecko-2.47.2.ebuild
parent861b1e40e88f18e781ea75c258773efaf8494671 (diff)
downloadgentoo-overlay-d318615233b34e42df5da47c588780928832d40a.tar.xz
gentoo-overlay-d318615233b34e42df5da47c588780928832d40a.zip
app-emulation/wine-gecko: add shared
Diffstat (limited to 'app-emulation/wine-gecko/wine-gecko-2.47.2.ebuild')
-rw-r--r--app-emulation/wine-gecko/wine-gecko-2.47.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-emulation/wine-gecko/wine-gecko-2.47.2.ebuild b/app-emulation/wine-gecko/wine-gecko-2.47.2.ebuild
new file mode 100644
index 0000000..eaa43e8
--- /dev/null
+++ b/app-emulation/wine-gecko/wine-gecko-2.47.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A Mozilla Gecko based version of Internet Explorer for Wine"
+HOMEPAGE="https://winehq.org"
+SRC_URI="
+ !shared? (
+ abi_x86_32? ( https://dl.winehq.org/wine/${PN}/${PV}/${PN}-${PV}-x86.msi )
+ abi_x86_64? ( https://dl.winehq.org/wine/${PN}/${PV}/${PN}-${PV}-x86_64.msi )
+ )
+ shared? (
+ abi_x86_32? ( https://dl.winehq.org/wine/${PN}/${PV}/${PN}-${PV}-x86.tar.xz )
+ abi_x86_64? ( https://dl.winehq.org/wine/${PN}/${PV}/${PN}-${PV}-x86_64.tar.xz )
+ )
+"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT MPL-2.0"
+SLOT="${PV}"
+KEYWORDS="amd64 x86"
+IUSE="abi_x86_32 abi_x86_64 shared"
+
+DEPEND="!!app-emulation/wine:0"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/share/wine/gecko
+ if use shared; then
+ use abi_x86_32 && doins -r "${P}-x86"
+ use abi_x86_64 && doins -r "${P}-x86_64"
+ else
+ use abi_x86_32 && doins "${DISTDIR}/${PN}-${PV}-x86.msi"
+ use abi_x86_64 && doins "${DISTDIR}/${PN}-${PV}-x86_64.msi"
+ fi
+}