summaryrefslogtreecommitdiff
path: root/net-libs/neatvnc/neatvnc-0.2.0.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-09-02 09:11:41 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-09-02 09:22:59 -0400
commitda498b2728a65dfd6ec22282a34725bf4ee863d8 (patch)
tree4fea8d8c370d9c6f3ea8debba3029a53916c294f /net-libs/neatvnc/neatvnc-0.2.0.ebuild
parent4da75e5d0e0af24c9c8495c2a8c3500a27b73d10 (diff)
downloadgentoo-overlay-da498b2728a65dfd6ec22282a34725bf4ee863d8.tar.xz
gentoo-overlay-da498b2728a65dfd6ec22282a34725bf4ee863d8.zip
dev-libs/aml: 0.1.0 bump
Diffstat (limited to 'net-libs/neatvnc/neatvnc-0.2.0.ebuild')
-rw-r--r--net-libs/neatvnc/neatvnc-0.2.0.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/net-libs/neatvnc/neatvnc-0.2.0.ebuild b/net-libs/neatvnc/neatvnc-0.2.0.ebuild
new file mode 100644
index 0000000..458f18a
--- /dev/null
+++ b/net-libs/neatvnc/neatvnc-0.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A liberally licensed VNC server library with a clean interface"
+HOMEPAGE="https://github.com/any1/neatvnc"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/any1/neatvnc.git"
+else
+ SRC_URI="https://github.com/any1/neatvnc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="benchmarks examples +jpeg ssl"
+
+DEPEND="
+ jpeg? ( media-libs/libjpeg-turbo )
+ ssl? ( net-libs/gnutls:= )
+ dev-libs/aml
+ sys-libs/zlib
+ x11-libs/pixman
+"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use benchmarks)
+ $(meson_use examples)
+ $(meson_feature jpeg)
+ $(meson_feature ssl tls)
+ )
+
+ meson_src_configure
+}