summaryrefslogtreecommitdiff
path: root/net-misc/wayvnc/wayvnc-9999.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-09-02 09:11:41 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-09-02 09:22:59 -0400
commitda498b2728a65dfd6ec22282a34725bf4ee863d8 (patch)
tree4fea8d8c370d9c6f3ea8debba3029a53916c294f /net-misc/wayvnc/wayvnc-9999.ebuild
parent4da75e5d0e0af24c9c8495c2a8c3500a27b73d10 (diff)
downloadgentoo-overlay-da498b2728a65dfd6ec22282a34725bf4ee863d8.tar.xz
gentoo-overlay-da498b2728a65dfd6ec22282a34725bf4ee863d8.zip
dev-libs/aml: 0.1.0 bump
Diffstat (limited to 'net-misc/wayvnc/wayvnc-9999.ebuild')
-rw-r--r--net-misc/wayvnc/wayvnc-9999.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/net-misc/wayvnc/wayvnc-9999.ebuild b/net-misc/wayvnc/wayvnc-9999.ebuild
index a09e5dc..5b298a0 100644
--- a/net-misc/wayvnc/wayvnc-9999.ebuild
+++ b/net-misc/wayvnc/wayvnc-9999.ebuild
@@ -11,13 +11,13 @@ if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/any1/wayvnc.git"
else
- SRC_URI="https://github.com/any1/wayvnc/archive/v${PV}.tar.gz"
+ SRC_URI="https://github.com/any1/wayvnc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
fi
LICENSE="ISC"
SLOT="0"
KEYWORDS=""
-IUSE="examples"
+IUSE="gbm"
DEPEND="
dev-libs/aml
@@ -26,6 +26,15 @@ DEPEND="
virtual/opengl
x11-libs/libxkbcommon
x11-libs/pixman
+ gbm? ( media-libs/mesa )
"
RDEPEND="${DEPEND}"
BDEPEND="dev-libs/wayland"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_features gbm screencopy-dmabuf)
+ )
+
+ meson_src_configure
+}