summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-java/openjdk-bin/openjdk-bin-16.0.1_p9.ebuild107
-rw-r--r--dev-java/openjdk-bin/openjdk-bin-16.0.2_p7.ebuild5
2 files changed, 4 insertions, 108 deletions
diff --git a/dev-java/openjdk-bin/openjdk-bin-16.0.1_p9.ebuild b/dev-java/openjdk-bin/openjdk-bin-16.0.1_p9.ebuild
deleted file mode 100644
index 8682e0f..0000000
--- a/dev-java/openjdk-bin/openjdk-bin-16.0.1_p9.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit java-vm-2 toolchain-funcs
-
-abi_uri() {
- echo "${2-$1}? (
- https://github.com/AdoptOpenJDK/openjdk${SLOT}-binaries/releases/download/jdk-${MY_PV/+/%2B}/OpenJDK${SLOT}U-jdk_${1}_linux_hotspot_${MY_PV/+/_}.tar.gz
- )"
-}
-
-MY_PV=${PV/_p/+}
-SLOT=${MY_PV%%[.+]*}
-
-SRC_URI="
- $(abi_uri aarch64 arm64)
- $(abi_uri arm)
- $(abi_uri ppc64le ppc64)
- $(abi_uri s390x s390)
- $(abi_uri x64 amd64)
-"
-
-DESCRIPTION="Prebuilt Java JDK binaries provided by AdoptOpenJDK"
-HOMEPAGE="https://adoptopenjdk.net"
-LICENSE="GPL-2-with-classpath-exception"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~s390"
-IUSE="alsa cups doc +gentoo-vm headless-awt selinux source"
-
-RDEPEND="
- media-libs/fontconfig:1.0
- media-libs/freetype:2
- >=sys-apps/baselayout-java-0.1.0-r1
- >=sys-libs/glibc-2.2.5:*
- sys-libs/zlib
- alsa? ( media-libs/alsa-lib )
- cups? ( net-print/cups )
- selinux? ( sec-policy/selinux-java )
- !headless-awt? (
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXi
- x11-libs/libXrender
- x11-libs/libXtst
- )"
-
-RESTRICT="preserve-libs splitdebug"
-QA_PREBUILT="*"
-
-S="${WORKDIR}/jdk-${MY_PV}"
-
-pkg_pretend() {
- if [[ "$(tc-is-softfloat)" != "no" ]]; then
- die "These binaries require a hardfloat system."
- fi
-}
-
-src_install() {
- local dest="/opt/${P}"
- local ddest="${ED%/}/${dest#/}"
-
- # Oracle and IcedTea have libjsoundalsa.so depending on
- # libasound.so.2 but AdoptOpenJDK only has libjsound.so. Weird.
- if ! use alsa ; then
- rm -v lib/libjsound.* || die
- fi
-
- if use headless-awt ; then
- rm -v lib/lib*{[jx]awt,splashscreen}* || die
- fi
-
- if ! use source ; then
- rm -v lib/src.zip || die
- fi
-
- rm -v lib/security/cacerts || die
- dosym ../../../../etc/ssl/certs/java/cacerts \
- "${dest}"/lib/security/cacerts
-
- dodir "${dest}"
- cp -pPR * "${ddest}" || die
-
- # provide stable symlink
- dosym "${P}" "/opt/${PN}-${SLOT}"
-
- use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}.env.sh
- java-vm_set-pax-markings "${ddest}"
- java-vm_revdep-mask
- java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
-}
-
-pkg_postinst() {
- java-vm-2_pkg_postinst
-
- if use gentoo-vm ; then
- ewarn "WARNING! You have enabled the gentoo-vm USE flag, making this JDK"
- ewarn "recognised by the system. This will almost certainly break"
- ewarn "many java ebuilds as they are not ready for openjdk-11"
- else
- ewarn "The experimental gentoo-vm USE flag has not been enabled so this JDK"
- ewarn "will not be recognised by the system. For example, simply calling"
- ewarn "\"java\" will launch a different JVM. This is necessary until Gentoo"
- ewarn "fully supports Java 11. This JDK must therefore be invoked using its"
- ewarn "absolute location under ${EPREFIX}/opt/${P}."
- fi
-}
diff --git a/dev-java/openjdk-bin/openjdk-bin-16.0.2_p7.ebuild b/dev-java/openjdk-bin/openjdk-bin-16.0.2_p7.ebuild
index c2dbbfb..82df0fe 100644
--- a/dev-java/openjdk-bin/openjdk-bin-16.0.2_p7.ebuild
+++ b/dev-java/openjdk-bin/openjdk-bin-16.0.2_p7.ebuild
@@ -15,13 +15,16 @@ MY_PV=${PV/_p/+}
SLOT=${MY_PV%%[.+]*}
SRC_URI="
+ $(abi_uri aarch64 arm64)
+ $(abi_uri ppc64le ppc64)
+ $(abi_uri s390x s390)
$(abi_uri x64 amd64)
"
DESCRIPTION="Prebuilt Java JDK binaries provided by Eclipse Temurin"
HOMEPAGE="https://adoptopenjdk.net"
LICENSE="GPL-2-with-classpath-exception"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~s390"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~s390"
IUSE="alsa cups +gentoo-vm headless-awt selinux source"
RDEPEND="