summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-fs/ncdu/Manifest1
-rw-r--r--sys-fs/ncdu/metadata.xml4
-rw-r--r--sys-fs/ncdu/ncdu-2.0.1.ebuild29
3 files changed, 34 insertions, 0 deletions
diff --git a/sys-fs/ncdu/Manifest b/sys-fs/ncdu/Manifest
new file mode 100644
index 0000000..2b149da
--- /dev/null
+++ b/sys-fs/ncdu/Manifest
@@ -0,0 +1 @@
+DIST ncdu-2.0.1.tar.gz 53807 BLAKE2B 909aa59228afab83376ab8a9a02aac74db092a2ba8041fcbf81a9b958a9957880de18a0bfae88405c0a92a1b4445e64a0167ae12021fb868b9c3d94058dd0966 SHA512 853bb74fe7d896ef3d3ff02366f4e7f98e3833ef5f7fe0239a5e8225052592e210974e7b4a8feb4c41783c05bf2c0c0ac448ef1fcde7b7d0a7092386ebadbad4
diff --git a/sys-fs/ncdu/metadata.xml b/sys-fs/ncdu/metadata.xml
new file mode 100644
index 0000000..7c900b1
--- /dev/null
+++ b/sys-fs/ncdu/metadata.xml
@@ -0,0 +1,4 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+</pkgmetadata>
diff --git a/sys-fs/ncdu/ncdu-2.0.1.ebuild b/sys-fs/ncdu/ncdu-2.0.1.ebuild
new file mode 100644
index 0000000..de9aa89
--- /dev/null
+++ b/sys-fs/ncdu/ncdu-2.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+DESCRIPTION="NCurses Disk Usage"
+HOMEPAGE="https://dev.yorhel.nl/ncdu/"
+SRC_URI="https://dev.yorhel.nl/download/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="~dev-lang/zig-0.9.0"
+
+DEPEND="sys-libs/ncurses:=[unicode(+)]"
+
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ if [[ -z ${ZIG_FLAGS+x} && "$CFLAGS" != *-march=native* ]]; then
+ die 'ZIG_FLAGS is unset! note that zig defaults to native cpu. set ZIG_FLAGS="" or ZIG_FLAGS="-mcpu baseline"'
+ fi
+ emake PREFIX=${EPREFIX}/usr
+}
+
+src_install() {
+ emake PREFIX=${ED}/usr install
+}