summaryrefslogtreecommitdiff
path: root/app-crypt/openpgp-keys-runescape/openpgp-keys-runescape-0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/openpgp-keys-runescape/openpgp-keys-runescape-0.ebuild')
-rw-r--r--app-crypt/openpgp-keys-runescape/openpgp-keys-runescape-0.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/app-crypt/openpgp-keys-runescape/openpgp-keys-runescape-0.ebuild b/app-crypt/openpgp-keys-runescape/openpgp-keys-runescape-0.ebuild
new file mode 100644
index 0000000..bab89ef
--- /dev/null
+++ b/app-crypt/openpgp-keys-runescape/openpgp-keys-runescape-0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="OpenPGP keys used by Jagex to sign RuneScape packages for Ubuntu"
+HOMEPAGE="https://www.runescape.com/"
+SRC_URI="https://content.runescape.com/downloads/ubuntu/runescape.gpg.key"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~*"
+
+S=${WORKDIR}
+
+src_install() {
+ local files=( ${A} )
+ insinto /usr/share/openpgp-keys
+ doins ${DISTDIR}/runescape.gpg.key
+}