summaryrefslogtreecommitdiff
path: root/dev-cpp/highway/highway-0.15.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/highway/highway-0.15.0.ebuild')
-rw-r--r--dev-cpp/highway/highway-0.15.0.ebuild27
1 files changed, 0 insertions, 27 deletions
diff --git a/dev-cpp/highway/highway-0.15.0.ebuild b/dev-cpp/highway/highway-0.15.0.ebuild
deleted file mode 100644
index 6111907..0000000
--- a/dev-cpp/highway/highway-0.15.0.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake-multilib
-
-DESCRIPTION="Performance-portable, length-agnostic SIMD with runtime dispatch"
-HOMEPAGE="https://github.com/google/highway"
-SRC_URI="https://github.com/google/highway/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-DEPEND="test? ( dev-cpp/gtest[${MULTILIB_USEDEP}] )"
-RDEPEND=""
-BDEPEND=""
-
-multilib_src_configure() {
- local mycmakeargs=(
- -DBUILD_TESTING=$(usex test ON OFF)
- -DHWY_SYSTEM_GTEST=ON
- )
- cmake_src_configure
-}