summaryrefslogtreecommitdiff
path: root/dev-dotnet/dotnet-runtime-bin/dotnet-runtime-bin-6.0.21.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/dotnet-runtime-bin/dotnet-runtime-bin-6.0.21.ebuild')
-rw-r--r--dev-dotnet/dotnet-runtime-bin/dotnet-runtime-bin-6.0.21.ebuild37
1 files changed, 18 insertions, 19 deletions
diff --git a/dev-dotnet/dotnet-runtime-bin/dotnet-runtime-bin-6.0.21.ebuild b/dev-dotnet/dotnet-runtime-bin/dotnet-runtime-bin-6.0.21.ebuild
index 3d47925..4518487 100644
--- a/dev-dotnet/dotnet-runtime-bin/dotnet-runtime-bin-6.0.21.ebuild
+++ b/dev-dotnet/dotnet-runtime-bin/dotnet-runtime-bin-6.0.21.ebuild
@@ -1,7 +1,7 @@
# Copyright 2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=8
DESCRIPTION=".NET is a free, cross-platform, open-source developer platform"
HOMEPAGE="https://dotnet.microsoft.com/"
@@ -21,19 +21,16 @@ SRC_URI="
"
SLOT="$(ver_cut 1-2)"
-KEYWORDS="~amd64 ~arm ~arm64"
-IUSE="dotnet-symlink kerberos lttng"
+IUSE="kerberos lttng"
+KEYWORDS="-* ~amd64 ~arm ~arm64"
QA_PREBUILT="*"
RESTRICT+=" splitdebug"
RDEPEND="
- kerberos? ( app-crypt/mit-krb5:0/0 )
- lttng? ( dev-util/lttng-ust:0 )
sys-libs/zlib:0/1
- dotnet-symlink? (
- !dev-dotnet/dotnet-sdk[dotnet-symlink(+)]
- !dev-dotnet/dotnet-sdk-bin
- !dev-dotnet/dotnet-runtime[dotnet-symlink(+)]
- )
+ !dev-dotnet/dotnet-sdk-bin:${SLOT}
+"
+IDEPEND="
+ app-eselect/eselect-dotnet
"
S=${WORKDIR}
@@ -51,15 +48,17 @@ src_install() {
local dest="opt/${PN}-${SLOT}"
dodir "${dest%/*}"
- { mv "${S}" "${ED}/${dest}" && mkdir "${S}" && fperms 0755 "/${dest}"; } || die
+ mv "${S}" "${ED}/${dest}" || die
+ mkdir "${S}" || die
+ fperms 0755 "/${dest}"
+
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet-bin-${SLOT}"
+}
- if use dotnet-symlink; then
- dosym "../../${dest}/dotnet" "/usr/bin/dotnet"
- dosym "../../${dest}/dotnet" "/usr/bin/dotnet-${SLOT}"
- dosym "../../${dest}/dotnet" "/usr/bin/dotnet-bin-${SLOT}"
+pkg_postinst() {
+ eselect dotnet update ifunset
+}
- # set an env-variable for 3rd party tools
- echo "DOTNET_ROOT=/${dest}" > "${T}/90${PN}-${SLOT}" || die
- doenvd "${T}/90${PN}-${SLOT}"
- fi
+pkg_postrm() {
+ eselect dotnet update ifunset
}