summaryrefslogtreecommitdiff
path: root/dev-java/openj9-openjdk/openj9-openjdk-11.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/openj9-openjdk/openj9-openjdk-11.9999.ebuild')
-rw-r--r--dev-java/openj9-openjdk/openj9-openjdk-11.9999.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-java/openj9-openjdk/openj9-openjdk-11.9999.ebuild b/dev-java/openj9-openjdk/openj9-openjdk-11.9999.ebuild
index 3d7eacb..61efb07 100644
--- a/dev-java/openj9-openjdk/openj9-openjdk-11.9999.ebuild
+++ b/dev-java/openj9-openjdk/openj9-openjdk-11.9999.ebuild
@@ -33,6 +33,7 @@ IUSE="alsa cups ddr debug doc examples gentoo-vm headless-awt javafx +jbootstrap
COMMON_DEPEND="
media-libs/freetype:2=
media-libs/giflib:0/7
+ media-libs/harfbuzz:=
media-libs/libpng:0=
media-libs/lcms:2=
sys-libs/zlib
@@ -115,7 +116,7 @@ openjdk_check_requirements() {
pkg_pretend() {
openjdk_check_requirements
if [[ ${MERGE_TYPE} != binary ]]; then
- has ccache ${FEATURES} && die "FEATURES=ccache doesn't work with ${PN}"
+ has ccache ${FEATURES} && die "FEATURES=ccache doesn't work with ${PN}, bug #677876"
fi
}
@@ -221,7 +222,9 @@ src_configure() {
--with-extra-cxxflags="${CXXFLAGS}"
--with-extra-ldflags="${LDFLAGS}"
--with-stdc++lib=dynamic
+ --with-freetype=system
--with-giflib=system
+ --with-harfbuzz=system
--with-lcms=system
--with-libjpeg=system
--with-libpng=system
@@ -244,7 +247,7 @@ src_configure() {
)
if use javafx; then
- local zip="${EROOT%/}/usr/$(get_libdir)/openjfx-${SLOT}/javafx-exports.zip"
+ local zip="${EPREFIX%/}/usr/$(get_libdir)/openjfx-${SLOT}/javafx-exports.zip"
if [[ -r ${zip} ]]; then
myconf+=( --with-import-modules="${zip}" )
else