summaryrefslogtreecommitdiff
path: root/dev-libs/aml/aml-0.1.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/aml/aml-0.1.0.ebuild')
-rw-r--r--dev-libs/aml/aml-0.1.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/aml/aml-0.1.0.ebuild b/dev-libs/aml/aml-0.1.0.ebuild
new file mode 100644
index 0000000..ca406f5
--- /dev/null
+++ b/dev-libs/aml/aml-0.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="Another Main Loop"
+HOMEPAGE="https://github.com/any1/aml"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/any1/aml.git"
+else
+ SRC_URI="https://github.com/any1/aml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use examples)
+ )
+
+ meson_src_configure
+}