summaryrefslogtreecommitdiff
path: root/dev-util/pmbootstrap/pmbootstrap-1.35.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/pmbootstrap/pmbootstrap-1.35.0.ebuild')
-rw-r--r--dev-util/pmbootstrap/pmbootstrap-1.35.0.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-util/pmbootstrap/pmbootstrap-1.35.0.ebuild b/dev-util/pmbootstrap/pmbootstrap-1.35.0.ebuild
new file mode 100644
index 0000000..b3e63e9
--- /dev/null
+++ b/dev-util/pmbootstrap/pmbootstrap-1.35.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Sophisticated chroot/build/flash tool to develop and install postmarketOS"
+HOMEPAGE="https://gitlab.com/postmarketOS/pmbootstrap"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# https://gitlab.com/postmarketOS/pmbootstrap/-/issues/1951
+RESTRICT="test"
+
+distutils_enable_tests pytest