summaryrefslogtreecommitdiff
path: root/games-rpg/runescape-launcher/runescape-launcher-2.2.9.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'games-rpg/runescape-launcher/runescape-launcher-2.2.9.ebuild')
-rw-r--r--games-rpg/runescape-launcher/runescape-launcher-2.2.9.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/games-rpg/runescape-launcher/runescape-launcher-2.2.9.ebuild b/games-rpg/runescape-launcher/runescape-launcher-2.2.9.ebuild
new file mode 100644
index 0000000..a1b849d
--- /dev/null
+++ b/games-rpg/runescape-launcher/runescape-launcher-2.2.9.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit unpacker xdg
+
+DESCRIPTION="Official RuneScape NXT client launcher"
+HOMEPAGE="http://www.runescape.com"
+SRC_URI="https://content.runescape.com/downloads/ubuntu/pool/non-free/${PN:0:1}/${PN}/${PN}_${PV}_amd64.deb"
+
+LICENSE="RuneScape-EULA"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+IUSE="kde"
+
+DEPEND=""
+RDEPEND="
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ sys-libs/libcap
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXxf86vm
+ dev-libs/openssl
+ x11-libs/pango
+ media-libs/libsdl2"
+BDEPEND=""
+
+RESTRICT="bindist mirror strip"
+QA_PREBUILT="/usr/share/games/runescape-launcher/runescape"
+
+S="${WORKDIR}"
+
+src_compile() {
+ mv usr/share/doc . || die
+ gunzip doc/runescape-launcher/changelog.gz || die
+ if ! use kde; then
+ rm -r usr/share/kde4 || die
+ fi
+}
+
+src_install() {
+ doins -r usr
+ dodoc doc/runescape-launcher/*
+}