summaryrefslogtreecommitdiff
path: root/media-sound/pamixer/pamixer-1.4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/pamixer/pamixer-1.4.ebuild')
-rw-r--r--media-sound/pamixer/pamixer-1.4.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-sound/pamixer/pamixer-1.4.ebuild b/media-sound/pamixer/pamixer-1.4.ebuild
new file mode 100644
index 0000000..a9205dd
--- /dev/null
+++ b/media-sound/pamixer/pamixer-1.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Pulseaudio command line mixer."
+HOMEPAGE="https://github.com/cdemoulins/pamixer"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/cdemoulins/pamixer"
+else
+ SRC_URI="https://github.com/cdemoulins/pamixer/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+RDEPEND="
+ dev-libs/boost
+ media-sound/pulseaudio"
+
+DEPEND="${RDEPEND}"
+
+src_install() {
+ dobin ${PN}
+ dodoc README.rst
+}