summaryrefslogtreecommitdiff
path: root/net-misc/wayvnc/wayvnc-0.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/wayvnc/wayvnc-0.2.0.ebuild')
-rw-r--r--net-misc/wayvnc/wayvnc-0.2.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-misc/wayvnc/wayvnc-0.2.0.ebuild b/net-misc/wayvnc/wayvnc-0.2.0.ebuild
new file mode 100644
index 0000000..54bcd82
--- /dev/null
+++ b/net-misc/wayvnc/wayvnc-0.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A VNC server for wlroots based Wayland compositors"
+HOMEPAGE="https://github.com/any1/wayvnc"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/any1/wayvnc.git"
+else
+ SRC_URI="https://github.com/any1/wayvnc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gbm"
+
+DEPEND="
+ dev-libs/aml
+ dev-libs/wayland
+ net-libs/neatvnc
+ virtual/opengl
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+ gbm? ( media-libs/mesa )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-libs/wayland"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_features gbm screencopy-dmabuf)
+ )
+
+ meson_src_configure
+}