summaryrefslogtreecommitdiff
path: root/x11-apps/sx/sx-2.1.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'x11-apps/sx/sx-2.1.7.ebuild')
-rw-r--r--x11-apps/sx/sx-2.1.7.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/x11-apps/sx/sx-2.1.7.ebuild b/x11-apps/sx/sx-2.1.7.ebuild
new file mode 100644
index 0000000..c43076d
--- /dev/null
+++ b/x11-apps/sx/sx-2.1.7.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Start an xorg server"
+HOMEPAGE="https://github.com/Earnestly/sx"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Earnestly/sx.git"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/Earnestly/sx/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+}