From 56907dd589347d4d227da227906b38d6b37aeb87 Mon Sep 17 00:00:00 2001
From: "Alex Xu (Hello71)" <alex_y_xu@yahoo.ca>
Date: Mon, 24 Jan 2022 10:29:04 -0500
Subject: app-emulation/dxvk: upgrade to 1.9.4

---
 app-emulation/dxvk/Manifest          |   2 +-
 app-emulation/dxvk/dxvk-1.9.3.ebuild | 118 -----------------------------------
 app-emulation/dxvk/dxvk-1.9.4.ebuild | 118 +++++++++++++++++++++++++++++++++++
 3 files changed, 119 insertions(+), 119 deletions(-)
 delete mode 100644 app-emulation/dxvk/dxvk-1.9.3.ebuild
 create mode 100644 app-emulation/dxvk/dxvk-1.9.4.ebuild

(limited to 'app-emulation/dxvk')

diff --git a/app-emulation/dxvk/Manifest b/app-emulation/dxvk/Manifest
index d49e771..d5c2fca 100644
--- a/app-emulation/dxvk/Manifest
+++ b/app-emulation/dxvk/Manifest
@@ -1 +1 @@
-DIST dxvk-1.9.3.tar.gz 1166878 BLAKE2B 1cef00e9b50632d51340ce0fd9d2842db8370853066e51a7a960d3c18b70c44ab5f2a7949c6c20cee47f7cb0d70fbd276136cc8d4cec137f2c1c87e06396fa1e SHA512 8e9d9fe0c123675add5a998de149c06b6e03e6a06d370090dddc68657dabfc1e98a4dd559b0a6a169466fef01149c9d6a6e9b3d57550e3803bda2bfc1f451cd2
+DIST dxvk-1.9.4.tar.gz 1168455 BLAKE2B 3ac51dd8e0a7c9e3b8d00d6ea465f7f26e2157efe4865f9acd8ee484b872f764789a5dee5c732d7c22c1f98860db72f7499c5addca61127724410d263d724a82 SHA512 ab509620c9fea9405907ff1f53cb1fb6c60a4fddc00c6f7afccd0deaba2a64d3c0ad015bfb284792e7dc4a1f74f31699b8e7175efbabae130dbce5e362dc132e
diff --git a/app-emulation/dxvk/dxvk-1.9.3.ebuild b/app-emulation/dxvk/dxvk-1.9.3.ebuild
deleted file mode 100644
index acb6291..0000000
--- a/app-emulation/dxvk/dxvk-1.9.3.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MULTILIB_COMPAT=( abi_x86_{32,64} )
-inherit flag-o-matic meson multilib-minimal
-
-DESCRIPTION="Vulkan-based implementation of D3D9, D3D10 and D3D11 for Linux / Wine"
-HOMEPAGE="https://github.com/doitsujin/dxvk"
-if [[ "${PV}" == "9999" ]]; then
-	inherit git-r3
-	EGIT_REPO_URI="https://github.com/doitsujin/dxvk.git"
-else
-	SRC_URI="https://github.com/doitsujin/dxvk/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-fi
-
-LICENSE="ZLIB"
-SLOT="0"
-if [[ "${PV}" == "9999" ]]; then
-	KEYWORDS=""
-else
-	KEYWORDS="~amd64"
-fi
-IUSE="+d3d9 +d3d10 +d3d11 debug +dxgi test"
-
-DEPEND="
-	abi_x86_32? ( cross-i686-w64-mingw32/gcc )
-	abi_x86_64? ( cross-x86_64-w64-mingw32/gcc )
-	dev-util/vulkan-headers
-	dev-util/glslang
-"
-RDEPEND="
-	media-libs/vulkan-loader[${MULTILIB_USEDEP}]
-	|| (
-		>=app-emulation/wine-staging-4.5[${MULTILIB_USEDEP},vulkan]
-		>=app-emulation/wine-vanilla-4.5[${MULTILIB_USEDEP},vulkan]
-	)
-"
-
-PATCHES=(
-	"${FILESDIR}/dxvk-1.8_add-compiler-flags.patch"
-)
-
-RESTRICT="!test? ( test )"
-
-patch_build_flags() {
-	local bits="${MULTILIB_ABI_FLAG:8:2}"
-
-	# Fix installation directory.
-	sed -i "s|\"x${bits}\"|\"usr/$(get_libdir)/dxvk\"|" setup_dxvk.sh || die
-
-	# Add *FLAGS to cross-file.
-	sed -i \
-		-e "s!@CFLAGS@!$(_meson_env_array "${CFLAGS}")!" \
-		-e "s!@CXXFLAGS@!$(_meson_env_array "${CXXFLAGS}")!" \
-		-e "s!@LDFLAGS@!$(_meson_env_array "${LDFLAGS}")!" \
-		"build-win${bits}.txt" || die
-}
-
-src_prepare() {
-	default
-
-	sed -i "s|^basedir=.*$|basedir=\"${EPREFIX}\"|" setup_dxvk.sh || die
-
-	# Delete installation instructions for unused ABIs.
-	if ! use abi_x86_64; then
-		sed -i '/installFile "$win64_sys_path"/d' setup_dxvk.sh || die
-	fi
-	if ! use abi_x86_32; then
-		sed -i '/installFile "$win32_sys_path"/d' setup_dxvk.sh || die
-	fi
-
-	multilib_foreach_abi patch_build_flags
-
-	# Load configuration file from /etc/dxvk.conf.
-	sed -Ei 's|filePath = "^(\s+)dxvk.conf";$|\1filePath = "/etc/dxvk.conf";|' \
-		src/util/config/config.cpp || die
-}
-
-multilib_src_configure() {
-	local bits="${MULTILIB_ABI_FLAG:8:2}"
-
-	local emesonargs=(
-		--libdir="$(get_libdir)/dxvk"
-		--bindir="$(get_libdir)/dxvk"
-		--cross-file="${S}/build-win${bits}.txt"
-		--buildtype="release"
-		$(usex debug "" "--strip")
-		$(meson_use d3d9 "enable_d3d9")
-		$(meson_use d3d10 "enable_d3d10")
-		$(meson_use d3d11 "enable_d3d11")
-		$(meson_use dxgi "enable_dxgi")
-		$(meson_use test "enable_tests")
-	)
-	meson_src_configure
-}
-
-multilib_src_compile() {
-	EMESON_SOURCE="${S}"
-	meson_src_compile
-}
-
-multilib_src_install() {
-	meson_src_install
-}
-
-multilib_src_install_all() {
-	# The .a files are needed during the install phase.
-	find "${D}" -name '*.a' -delete -print
-
-	dobin setup_dxvk.sh
-
-	insinto etc
-	doins "dxvk.conf"
-
-	default
-}
diff --git a/app-emulation/dxvk/dxvk-1.9.4.ebuild b/app-emulation/dxvk/dxvk-1.9.4.ebuild
new file mode 100644
index 0000000..acb6291
--- /dev/null
+++ b/app-emulation/dxvk/dxvk-1.9.4.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MULTILIB_COMPAT=( abi_x86_{32,64} )
+inherit flag-o-matic meson multilib-minimal
+
+DESCRIPTION="Vulkan-based implementation of D3D9, D3D10 and D3D11 for Linux / Wine"
+HOMEPAGE="https://github.com/doitsujin/dxvk"
+if [[ "${PV}" == "9999" ]]; then
+	inherit git-r3
+	EGIT_REPO_URI="https://github.com/doitsujin/dxvk.git"
+else
+	SRC_URI="https://github.com/doitsujin/dxvk/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="ZLIB"
+SLOT="0"
+if [[ "${PV}" == "9999" ]]; then
+	KEYWORDS=""
+else
+	KEYWORDS="~amd64"
+fi
+IUSE="+d3d9 +d3d10 +d3d11 debug +dxgi test"
+
+DEPEND="
+	abi_x86_32? ( cross-i686-w64-mingw32/gcc )
+	abi_x86_64? ( cross-x86_64-w64-mingw32/gcc )
+	dev-util/vulkan-headers
+	dev-util/glslang
+"
+RDEPEND="
+	media-libs/vulkan-loader[${MULTILIB_USEDEP}]
+	|| (
+		>=app-emulation/wine-staging-4.5[${MULTILIB_USEDEP},vulkan]
+		>=app-emulation/wine-vanilla-4.5[${MULTILIB_USEDEP},vulkan]
+	)
+"
+
+PATCHES=(
+	"${FILESDIR}/dxvk-1.8_add-compiler-flags.patch"
+)
+
+RESTRICT="!test? ( test )"
+
+patch_build_flags() {
+	local bits="${MULTILIB_ABI_FLAG:8:2}"
+
+	# Fix installation directory.
+	sed -i "s|\"x${bits}\"|\"usr/$(get_libdir)/dxvk\"|" setup_dxvk.sh || die
+
+	# Add *FLAGS to cross-file.
+	sed -i \
+		-e "s!@CFLAGS@!$(_meson_env_array "${CFLAGS}")!" \
+		-e "s!@CXXFLAGS@!$(_meson_env_array "${CXXFLAGS}")!" \
+		-e "s!@LDFLAGS@!$(_meson_env_array "${LDFLAGS}")!" \
+		"build-win${bits}.txt" || die
+}
+
+src_prepare() {
+	default
+
+	sed -i "s|^basedir=.*$|basedir=\"${EPREFIX}\"|" setup_dxvk.sh || die
+
+	# Delete installation instructions for unused ABIs.
+	if ! use abi_x86_64; then
+		sed -i '/installFile "$win64_sys_path"/d' setup_dxvk.sh || die
+	fi
+	if ! use abi_x86_32; then
+		sed -i '/installFile "$win32_sys_path"/d' setup_dxvk.sh || die
+	fi
+
+	multilib_foreach_abi patch_build_flags
+
+	# Load configuration file from /etc/dxvk.conf.
+	sed -Ei 's|filePath = "^(\s+)dxvk.conf";$|\1filePath = "/etc/dxvk.conf";|' \
+		src/util/config/config.cpp || die
+}
+
+multilib_src_configure() {
+	local bits="${MULTILIB_ABI_FLAG:8:2}"
+
+	local emesonargs=(
+		--libdir="$(get_libdir)/dxvk"
+		--bindir="$(get_libdir)/dxvk"
+		--cross-file="${S}/build-win${bits}.txt"
+		--buildtype="release"
+		$(usex debug "" "--strip")
+		$(meson_use d3d9 "enable_d3d9")
+		$(meson_use d3d10 "enable_d3d10")
+		$(meson_use d3d11 "enable_d3d11")
+		$(meson_use dxgi "enable_dxgi")
+		$(meson_use test "enable_tests")
+	)
+	meson_src_configure
+}
+
+multilib_src_compile() {
+	EMESON_SOURCE="${S}"
+	meson_src_compile
+}
+
+multilib_src_install() {
+	meson_src_install
+}
+
+multilib_src_install_all() {
+	# The .a files are needed during the install phase.
+	find "${D}" -name '*.a' -delete -print
+
+	dobin setup_dxvk.sh
+
+	insinto etc
+	doins "dxvk.conf"
+
+	default
+}
-- 
cgit v1.2.3-70-g09d2