From 30feedf6dd65cf689c97a11f4f9720e8b572b523 Mon Sep 17 00:00:00 2001
From: "Alex Xu (Hello71)" <alex_y_xu@yahoo.ca>
Date: Thu, 7 Oct 2021 15:04:40 -0400
Subject: dev-cpp/highway: add multilib

---
 dev-cpp/highway/highway-0.14.2.ebuild | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

(limited to 'dev-cpp')

diff --git a/dev-cpp/highway/highway-0.14.2.ebuild b/dev-cpp/highway/highway-0.14.2.ebuild
index 7f21cc2..60d4459 100644
--- a/dev-cpp/highway/highway-0.14.2.ebuild
+++ b/dev-cpp/highway/highway-0.14.2.ebuild
@@ -1,9 +1,9 @@
 # Copyright 2021 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=7
+EAPI=8
 
-inherit cmake
+inherit cmake-multilib
 
 DESCRIPTION="Performance-portable, length-agnostic SIMD with runtime dispatch"
 HOMEPAGE="https://github.com/google/highway"
@@ -14,11 +14,11 @@ SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE="test"
 
-DEPEND="test? ( dev-cpp/gtest )"
+DEPEND="test? ( dev-cpp/gtest[${MULTILIB_USEDEP}] )"
 RDEPEND=""
 BDEPEND=""
 
-src_configure() {
+multilib_src_configure() {
 	local mycmakeargs=(
 		-DBUILD_TESTING=$(usex test ON OFF)
 		-DHWY_SYSTEM_GTEST=ON
-- 
cgit v1.2.3-70-g09d2