From f89c30e88fe18f25fcf348ff72d0f209440deb7d Mon Sep 17 00:00:00 2001
From: "Alex Xu (Hello71)" <alex_y_xu@yahoo.ca>
Date: Sat, 19 Aug 2023 20:49:22 -0400
Subject: dev-java/openj9-openjdk{,-bin,-jre-bin}: upgrade to 0.40.0

---
 dev-java/openj9-openjdk-jre-bin/Manifest           | 12 +--
 .../openj9-openjdk-jre-bin-11.0.19_p7.ebuild       | 86 ----------------------
 .../openj9-openjdk-jre-bin-11.0.20_p8.ebuild       | 86 ++++++++++++++++++++++
 .../openj9-openjdk-jre-bin-17.0.7_p7.ebuild        | 86 ----------------------
 .../openj9-openjdk-jre-bin-17.0.8_p7.ebuild        | 86 ++++++++++++++++++++++
 5 files changed, 178 insertions(+), 178 deletions(-)
 delete mode 100644 dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-11.0.19_p7.ebuild
 create mode 100644 dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-11.0.20_p8.ebuild
 delete mode 100644 dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-17.0.7_p7.ebuild
 create mode 100644 dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-17.0.8_p7.ebuild

(limited to 'dev-java/openj9-openjdk-jre-bin')

diff --git a/dev-java/openj9-openjdk-jre-bin/Manifest b/dev-java/openj9-openjdk-jre-bin/Manifest
index d966d8c..db9f1b4 100644
--- a/dev-java/openj9-openjdk-jre-bin/Manifest
+++ b/dev-java/openj9-openjdk-jre-bin/Manifest
@@ -1,6 +1,6 @@
-DIST ibm-semeru-open-jre_aarch64_linux_11.0.19_7_openj9-0.38.0.tar.gz 45593297 SHA256 7e7512bc0afbc620a4389410691340f8806eb6c113042bd5860f51e8d64f5afe
-DIST ibm-semeru-open-jre_aarch64_linux_17.0.7_7_openj9-0.38.0.tar.gz 45523591 SHA256 601dba428fe9d9b5a883aaccbdd37f88c1fb0da2e5b5de65b40cf0a4a0e5fccb
-DIST ibm-semeru-open-jre_ppc64le_linux_11.0.19_7_openj9-0.38.0.tar.gz 48518580 SHA256 f36e5aed0ac61ae433296d96bb5f424ab2c4edff2ab27fc086cca064bc88da84
-DIST ibm-semeru-open-jre_ppc64le_linux_17.0.7_7_openj9-0.38.0.tar.gz 48778755 SHA256 dee6b87258ceba918543956dddf97291cbc2735ffa0288d25239a07c7766d567
-DIST ibm-semeru-open-jre_x64_linux_11.0.19_7_openj9-0.38.0.tar.gz 47690487 SHA256 35c25a4fe4cb1ab1c5e6605bc8dc6db54beca6f3d7745da2742bd0e627682ee3
-DIST ibm-semeru-open-jre_x64_linux_17.0.7_7_openj9-0.38.0.tar.gz 47618570 SHA256 ffda41aa8390d14edbce1775d652f0e4e779df025ac1404c1970802697963aab
+DIST ibm-semeru-open-jre_aarch64_linux_11.0.20_8_openj9-0.40.0.tar.gz 45855654 SHA256 9e18c0e333f6d6c7962ccc0c2531c27921c4b76e108fded459e0659038c21f21
+DIST ibm-semeru-open-jre_aarch64_linux_17.0.8_7_openj9-0.40.0.tar.gz 45789622 SHA256 b8904df2fee0797e493e3482fddb873b25d1e05f27053a2d96a25310c2dce3d4
+DIST ibm-semeru-open-jre_ppc64le_linux_11.0.20_8_openj9-0.40.0.tar.gz 48605043 SHA256 2b767b490858900e773589e2c6395fef111c5d70696db371449491db617079d6
+DIST ibm-semeru-open-jre_ppc64le_linux_17.0.8_7_openj9-0.40.0.tar.gz 48853830 SHA256 0986b451944deac0832c2905f1497fddb3ab7c0f63cd9fad707072381c9948a1
+DIST ibm-semeru-open-jre_x64_linux_11.0.20_8_openj9-0.40.0.tar.gz 47781278 SHA256 7706a511bded7b3972cdb98c5c7942b8f2dcf9ab4c2a6e81d72fb8a754812bb2
+DIST ibm-semeru-open-jre_x64_linux_17.0.8_7_openj9-0.40.0.tar.gz 47708806 SHA256 461aab09409b3ac26ded0ca921171e141c6b1400a17d8026e924109518b365d4
diff --git a/dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-11.0.19_p7.ebuild b/dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-11.0.19_p7.ebuild
deleted file mode 100644
index 9d7175f..0000000
--- a/dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-11.0.19_p7.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit java-vm-2
-
-abi_uri() {
-	echo "${2-$1}? (
-		https://github.com/ibmruntimes/semeru${SLOT}-binaries/releases/download/jdk-${DL_PV/+/%2B}/ibm-semeru-open-jre_${1}_linux_${DL_PV/+/_}.tar.gz
-	)"
-}
-
-JDK_PV=${PV//_p/+}
-DL_PV=${JDK_PV}_openj9-0.38.0
-SLOT=$(ver_cut 1)
-
-SRC_URI="
-	$(abi_uri aarch64 arm64)
-	$(abi_uri ppc64le ppc64)
-	$(abi_uri x64 amd64)
-"
-
-DESCRIPTION="Prebuilt IBM Semeru JRE binaries provided by IBM"
-HOMEPAGE="https://developer.ibm.com/languages/java/semeru-runtimes/"
-LICENSE="GPL-2-with-classpath-exception"
-KEYWORDS="~amd64 ~arm64 ~ppc64"
-IUSE="alsa cups headless-awt selinux"
-
-RDEPEND="
-	media-libs/fontconfig:1.0
-	media-libs/freetype:2
-	>net-libs/libnet-1.1
-	>=sys-apps/baselayout-java-0.1.0-r1
-	>=sys-libs/glibc-2.2.5:*
-	sys-libs/zlib
-	alsa? ( media-libs/alsa-lib )
-	cups? ( net-print/cups )
-	selinux? ( sec-policy/selinux-java )
-	!headless-awt? (
-		x11-libs/libX11
-		x11-libs/libXext
-		x11-libs/libXi
-		x11-libs/libXrender
-		x11-libs/libXtst
-	)"
-
-RESTRICT="preserve-libs splitdebug"
-QA_PREBUILT="*"
-
-S="${WORKDIR}/jdk-${JDK_PV}-jre"
-
-src_install() {
-	local dest="/opt/${PN}-${SLOT}"
-	local ddest="${ED}/${dest#/}"
-
-	# Not sure why they bundle this as it's commonly available and they
-	# only do so on x86_64. It's needed by libfontmanager.so. IcedTea
-	# also has an explicit dependency while Oracle seemingly dlopens it.
-	rm -vf lib/libfreetype.so || die
-
-	# Oracle and IcedTea have libjsoundalsa.so depending on
-	# libasound.so.2 but AdoptOpenJDK only has libjsound.so. Weird.
-	if ! use alsa ; then
-		rm -v lib/libjsound.* || die
-	fi
-
-	if use headless-awt ; then
-		rm -v lib/lib*{[jx]awt,splashscreen}* || die
-	fi
-
-	rm -v lib/security/cacerts || die
-	dosym -r /etc/ssl/certs/java/cacerts "${dest}"/lib/security/cacerts
-
-	dodir "${dest}"
-	cp -pPR * "${ddest}" || die
-
-	java-vm_install-env "${FILESDIR}"/${PN}.env.sh
-	java-vm_set-pax-markings "${ddest}"
-	java-vm_revdep-mask
-	java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
-}
-
-pkg_postinst() {
-	java-vm-2_pkg_postinst
-}
diff --git a/dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-11.0.20_p8.ebuild b/dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-11.0.20_p8.ebuild
new file mode 100644
index 0000000..20b1d9b
--- /dev/null
+++ b/dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-11.0.20_p8.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit java-vm-2
+
+abi_uri() {
+	echo "${2-$1}? (
+		https://github.com/ibmruntimes/semeru${SLOT}-binaries/releases/download/jdk-${DL_PV/+/%2B}/ibm-semeru-open-jre_${1}_linux_${DL_PV/+/_}.tar.gz
+	)"
+}
+
+JDK_PV=${PV//_p/+}
+DL_PV=${JDK_PV}_openj9-0.40.0
+SLOT=$(ver_cut 1)
+
+SRC_URI="
+	$(abi_uri aarch64 arm64)
+	$(abi_uri ppc64le ppc64)
+	$(abi_uri x64 amd64)
+"
+
+DESCRIPTION="Prebuilt IBM Semeru JRE binaries provided by IBM"
+HOMEPAGE="https://developer.ibm.com/languages/java/semeru-runtimes/"
+LICENSE="GPL-2-with-classpath-exception"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+IUSE="alsa cups headless-awt selinux"
+
+RDEPEND="
+	media-libs/fontconfig:1.0
+	media-libs/freetype:2
+	>net-libs/libnet-1.1
+	>=sys-apps/baselayout-java-0.1.0-r1
+	>=sys-libs/glibc-2.2.5:*
+	sys-libs/zlib
+	alsa? ( media-libs/alsa-lib )
+	cups? ( net-print/cups )
+	selinux? ( sec-policy/selinux-java )
+	!headless-awt? (
+		x11-libs/libX11
+		x11-libs/libXext
+		x11-libs/libXi
+		x11-libs/libXrender
+		x11-libs/libXtst
+	)"
+
+RESTRICT="preserve-libs splitdebug"
+QA_PREBUILT="*"
+
+S="${WORKDIR}/jdk-${JDK_PV}-jre"
+
+src_install() {
+	local dest="/opt/${PN}-${SLOT}"
+	local ddest="${ED}/${dest#/}"
+
+	# Not sure why they bundle this as it's commonly available and they
+	# only do so on x86_64. It's needed by libfontmanager.so. IcedTea
+	# also has an explicit dependency while Oracle seemingly dlopens it.
+	rm -vf lib/libfreetype.so || die
+
+	# Oracle and IcedTea have libjsoundalsa.so depending on
+	# libasound.so.2 but AdoptOpenJDK only has libjsound.so. Weird.
+	if ! use alsa ; then
+		rm -v lib/libjsound.* || die
+	fi
+
+	if use headless-awt ; then
+		rm -v lib/lib*{[jx]awt,splashscreen}* || die
+	fi
+
+	rm -v lib/security/cacerts || die
+	dosym -r /etc/ssl/certs/java/cacerts "${dest}"/lib/security/cacerts
+
+	dodir "${dest}"
+	cp -pPR * "${ddest}" || die
+
+	java-vm_install-env "${FILESDIR}"/${PN}.env.sh
+	java-vm_set-pax-markings "${ddest}"
+	java-vm_revdep-mask
+	java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
+}
+
+pkg_postinst() {
+	java-vm-2_pkg_postinst
+}
diff --git a/dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-17.0.7_p7.ebuild b/dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-17.0.7_p7.ebuild
deleted file mode 100644
index 9d7175f..0000000
--- a/dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-17.0.7_p7.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit java-vm-2
-
-abi_uri() {
-	echo "${2-$1}? (
-		https://github.com/ibmruntimes/semeru${SLOT}-binaries/releases/download/jdk-${DL_PV/+/%2B}/ibm-semeru-open-jre_${1}_linux_${DL_PV/+/_}.tar.gz
-	)"
-}
-
-JDK_PV=${PV//_p/+}
-DL_PV=${JDK_PV}_openj9-0.38.0
-SLOT=$(ver_cut 1)
-
-SRC_URI="
-	$(abi_uri aarch64 arm64)
-	$(abi_uri ppc64le ppc64)
-	$(abi_uri x64 amd64)
-"
-
-DESCRIPTION="Prebuilt IBM Semeru JRE binaries provided by IBM"
-HOMEPAGE="https://developer.ibm.com/languages/java/semeru-runtimes/"
-LICENSE="GPL-2-with-classpath-exception"
-KEYWORDS="~amd64 ~arm64 ~ppc64"
-IUSE="alsa cups headless-awt selinux"
-
-RDEPEND="
-	media-libs/fontconfig:1.0
-	media-libs/freetype:2
-	>net-libs/libnet-1.1
-	>=sys-apps/baselayout-java-0.1.0-r1
-	>=sys-libs/glibc-2.2.5:*
-	sys-libs/zlib
-	alsa? ( media-libs/alsa-lib )
-	cups? ( net-print/cups )
-	selinux? ( sec-policy/selinux-java )
-	!headless-awt? (
-		x11-libs/libX11
-		x11-libs/libXext
-		x11-libs/libXi
-		x11-libs/libXrender
-		x11-libs/libXtst
-	)"
-
-RESTRICT="preserve-libs splitdebug"
-QA_PREBUILT="*"
-
-S="${WORKDIR}/jdk-${JDK_PV}-jre"
-
-src_install() {
-	local dest="/opt/${PN}-${SLOT}"
-	local ddest="${ED}/${dest#/}"
-
-	# Not sure why they bundle this as it's commonly available and they
-	# only do so on x86_64. It's needed by libfontmanager.so. IcedTea
-	# also has an explicit dependency while Oracle seemingly dlopens it.
-	rm -vf lib/libfreetype.so || die
-
-	# Oracle and IcedTea have libjsoundalsa.so depending on
-	# libasound.so.2 but AdoptOpenJDK only has libjsound.so. Weird.
-	if ! use alsa ; then
-		rm -v lib/libjsound.* || die
-	fi
-
-	if use headless-awt ; then
-		rm -v lib/lib*{[jx]awt,splashscreen}* || die
-	fi
-
-	rm -v lib/security/cacerts || die
-	dosym -r /etc/ssl/certs/java/cacerts "${dest}"/lib/security/cacerts
-
-	dodir "${dest}"
-	cp -pPR * "${ddest}" || die
-
-	java-vm_install-env "${FILESDIR}"/${PN}.env.sh
-	java-vm_set-pax-markings "${ddest}"
-	java-vm_revdep-mask
-	java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
-}
-
-pkg_postinst() {
-	java-vm-2_pkg_postinst
-}
diff --git a/dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-17.0.8_p7.ebuild b/dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-17.0.8_p7.ebuild
new file mode 100644
index 0000000..20b1d9b
--- /dev/null
+++ b/dev-java/openj9-openjdk-jre-bin/openj9-openjdk-jre-bin-17.0.8_p7.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit java-vm-2
+
+abi_uri() {
+	echo "${2-$1}? (
+		https://github.com/ibmruntimes/semeru${SLOT}-binaries/releases/download/jdk-${DL_PV/+/%2B}/ibm-semeru-open-jre_${1}_linux_${DL_PV/+/_}.tar.gz
+	)"
+}
+
+JDK_PV=${PV//_p/+}
+DL_PV=${JDK_PV}_openj9-0.40.0
+SLOT=$(ver_cut 1)
+
+SRC_URI="
+	$(abi_uri aarch64 arm64)
+	$(abi_uri ppc64le ppc64)
+	$(abi_uri x64 amd64)
+"
+
+DESCRIPTION="Prebuilt IBM Semeru JRE binaries provided by IBM"
+HOMEPAGE="https://developer.ibm.com/languages/java/semeru-runtimes/"
+LICENSE="GPL-2-with-classpath-exception"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+IUSE="alsa cups headless-awt selinux"
+
+RDEPEND="
+	media-libs/fontconfig:1.0
+	media-libs/freetype:2
+	>net-libs/libnet-1.1
+	>=sys-apps/baselayout-java-0.1.0-r1
+	>=sys-libs/glibc-2.2.5:*
+	sys-libs/zlib
+	alsa? ( media-libs/alsa-lib )
+	cups? ( net-print/cups )
+	selinux? ( sec-policy/selinux-java )
+	!headless-awt? (
+		x11-libs/libX11
+		x11-libs/libXext
+		x11-libs/libXi
+		x11-libs/libXrender
+		x11-libs/libXtst
+	)"
+
+RESTRICT="preserve-libs splitdebug"
+QA_PREBUILT="*"
+
+S="${WORKDIR}/jdk-${JDK_PV}-jre"
+
+src_install() {
+	local dest="/opt/${PN}-${SLOT}"
+	local ddest="${ED}/${dest#/}"
+
+	# Not sure why they bundle this as it's commonly available and they
+	# only do so on x86_64. It's needed by libfontmanager.so. IcedTea
+	# also has an explicit dependency while Oracle seemingly dlopens it.
+	rm -vf lib/libfreetype.so || die
+
+	# Oracle and IcedTea have libjsoundalsa.so depending on
+	# libasound.so.2 but AdoptOpenJDK only has libjsound.so. Weird.
+	if ! use alsa ; then
+		rm -v lib/libjsound.* || die
+	fi
+
+	if use headless-awt ; then
+		rm -v lib/lib*{[jx]awt,splashscreen}* || die
+	fi
+
+	rm -v lib/security/cacerts || die
+	dosym -r /etc/ssl/certs/java/cacerts "${dest}"/lib/security/cacerts
+
+	dodir "${dest}"
+	cp -pPR * "${ddest}" || die
+
+	java-vm_install-env "${FILESDIR}"/${PN}.env.sh
+	java-vm_set-pax-markings "${ddest}"
+	java-vm_revdep-mask
+	java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
+}
+
+pkg_postinst() {
+	java-vm-2_pkg_postinst
+}
-- 
cgit v1.2.3-70-g09d2