From 03ae4b4892e5461bd2c2fb1739b59afc94a8f083 Mon Sep 17 00:00:00 2001
From: "Alex Xu (Hello71)" <alex_y_xu@yahoo.ca>
Date: Sat, 24 Apr 2021 16:26:03 -0400
Subject: dev-java/*openjdk*: bump

---
 dev-java/openjdk-bin/Manifest                     |  10 +-
 dev-java/openjdk-bin/openjdk-bin-15.0.2_p7.ebuild | 112 ----------------------
 dev-java/openjdk-bin/openjdk-bin-16.0.1_p9.ebuild | 112 ++++++++++++++++++++++
 3 files changed, 117 insertions(+), 117 deletions(-)
 delete mode 100644 dev-java/openjdk-bin/openjdk-bin-15.0.2_p7.ebuild
 create mode 100644 dev-java/openjdk-bin/openjdk-bin-16.0.1_p9.ebuild

(limited to 'dev-java/openjdk-bin')

diff --git a/dev-java/openjdk-bin/Manifest b/dev-java/openjdk-bin/Manifest
index 371f99b..ddd22ed 100644
--- a/dev-java/openjdk-bin/Manifest
+++ b/dev-java/openjdk-bin/Manifest
@@ -1,5 +1,5 @@
-DIST OpenJDK15U-jdk_aarch64_linux_hotspot_15.0.2_7.tar.gz 203662871 SHA256 6e8b6b037148cf20a284b5b257ec7bfdf9cc31ccc87778d0dfd95a2fddf228d4
-DIST OpenJDK15U-jdk_arm_linux_hotspot_15.0.2_7.tar.gz 189527214 SHA256 ff39c0380224e419d940382c4d651cb1e6297a794854e0cc459c1fd4973b3368
-DIST OpenJDK15U-jdk_ppc64le_linux_hotspot_15.0.2_7.tar.gz 188162894 SHA256 486f2aad94c5580c0b27c9007beebadfccd4677c0bd9565a77ca5c34af5319f9
-DIST OpenJDK15U-jdk_s390x_linux_hotspot_15.0.2_7.tar.gz 179870692 SHA256 7dc35a8a4ba1ccf6cfe96fcf26e09ed936f1802ca668ca6bf708e2392c35ab6a
-DIST OpenJDK15U-jdk_x64_linux_hotspot_15.0.2_7.tar.gz 206039221 SHA256 94f20ca8ea97773571492e622563883b8869438a015d02df6028180dd9acc24d
+DIST OpenJDK16U-jdk_aarch64_linux_hotspot_16.0.1_9.tar.gz 203066417 SHA256 3447ec27a6dbd4f3a6180a0d4371bb09aa428c16eea9983e515a7400cc9f5c85
+DIST OpenJDK16U-jdk_arm_linux_hotspot_16.0.1_9.tar.gz 187587741 SHA256 20fc395d8ea2659e6407cd4ec233dc4399f61b7610f3a16495deb23c1e3b81df
+DIST OpenJDK16U-jdk_ppc64le_linux_hotspot_16.0.1_9.tar.gz 186081896 SHA256 8d8e35ca5a7e24f16384bf32b110562921c19b4cfe65969980937bf879462bc6
+DIST OpenJDK16U-jdk_s390x_linux_hotspot_16.0.1_9.tar.gz 178964996 SHA256 421cd44661cdbf0c2da79ab3104c81a1fa171b974038e55b1b3d4a042865588f
+DIST OpenJDK16U-jdk_x64_linux_hotspot_16.0.1_9.tar.gz 205449187 SHA256 7fdda042207efcedd30cd76d6295ed56b9c2e248cb3682c50898a560d4aa1c6f
diff --git a/dev-java/openjdk-bin/openjdk-bin-15.0.2_p7.ebuild b/dev-java/openjdk-bin/openjdk-bin-15.0.2_p7.ebuild
deleted file mode 100644
index 6a82f20..0000000
--- a/dev-java/openjdk-bin/openjdk-bin-15.0.2_p7.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit java-vm-2 toolchain-funcs
-
-abi_uri() {
-	echo "${2-$1}? (
-			https://github.com/AdoptOpenJDK/openjdk${SLOT}-binaries/releases/download/jdk-${MY_PV/+/%2B}/OpenJDK${SLOT}U-jdk_${1}_linux_hotspot_${MY_PV/+/_}.tar.gz
-		)"
-}
-
-MY_PV=${PV/_p/+}
-SLOT=${MY_PV%%[.+]*}
-
-SRC_URI="
-	$(abi_uri aarch64 arm64)
-	$(abi_uri arm)
-	$(abi_uri ppc64le ppc64)
-	$(abi_uri s390x s390)
-	$(abi_uri x64 amd64)
-"
-
-DESCRIPTION="Prebuilt Java JDK binaries provided by AdoptOpenJDK"
-HOMEPAGE="https://adoptopenjdk.net"
-LICENSE="GPL-2-with-classpath-exception"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~s390"
-IUSE="alsa cups doc +gentoo-vm headless-awt selinux source"
-
-RDEPEND="
-	media-libs/fontconfig:1.0
-	media-libs/freetype:2
-	>=sys-apps/baselayout-java-0.1.0-r1
-	>=sys-libs/glibc-2.2.5:*
-	sys-libs/zlib
-	alsa? ( media-libs/alsa-lib )
-	cups? ( net-print/cups )
-	selinux? ( sec-policy/selinux-java )
-	!headless-awt? (
-		x11-libs/libX11
-		x11-libs/libXext
-		x11-libs/libXi
-		x11-libs/libXrender
-		x11-libs/libXtst
-	)"
-
-RESTRICT="preserve-libs splitdebug"
-QA_PREBUILT="*"
-
-S="${WORKDIR}/jdk-${MY_PV}"
-
-pkg_pretend() {
-	if [[ "$(tc-is-softfloat)" != "no" ]]; then
-		die "These binaries require a hardfloat system."
-	fi
-}
-
-src_install() {
-	local dest="/opt/${P}"
-	local ddest="${ED%/}/${dest#/}"
-
-	# Not sure why they bundle this as it's commonly available and they
-	# only do so on x86_64. It's needed by libfontmanager.so. IcedTea
-	# also has an explicit dependency while Oracle seemingly dlopens it.
-	rm -vf lib/libfreetype.so || die
-
-	# Oracle and IcedTea have libjsoundalsa.so depending on
-	# libasound.so.2 but AdoptOpenJDK only has libjsound.so. Weird.
-	if ! use alsa ; then
-		rm -v lib/libjsound.* || die
-	fi
-
-	if use headless-awt ; then
-		rm -v lib/lib*{[jx]awt,splashscreen}* || die
-	fi
-
-	if ! use source ; then
-		rm -v lib/src.zip || die
-	fi
-
-	rm -v lib/security/cacerts || die
-	dosym ../../../../etc/ssl/certs/java/cacerts \
-		"${dest}"/lib/security/cacerts
-
-	dodir "${dest}"
-	cp -pPR * "${ddest}" || die
-
-	# provide stable symlink
-	dosym "${P}" "/opt/${PN}-${SLOT}"
-
-	use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}-${SLOT}.env.sh
-	java-vm_set-pax-markings "${ddest}"
-	java-vm_revdep-mask
-	java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
-}
-
-pkg_postinst() {
-	java-vm-2_pkg_postinst
-
-	if use gentoo-vm ; then
-		ewarn "WARNING! You have enabled the gentoo-vm USE flag, making this JDK"
-		ewarn "recognised by the system. This will almost certainly break"
-		ewarn "many java ebuilds as they are not ready for openjdk-11"
-	else
-		ewarn "The experimental gentoo-vm USE flag has not been enabled so this JDK"
-		ewarn "will not be recognised by the system. For example, simply calling"
-		ewarn "\"java\" will launch a different JVM. This is necessary until Gentoo"
-		ewarn "fully supports Java 11. This JDK must therefore be invoked using its"
-		ewarn "absolute location under ${EPREFIX}/opt/${P}."
-	fi
-}
diff --git a/dev-java/openjdk-bin/openjdk-bin-16.0.1_p9.ebuild b/dev-java/openjdk-bin/openjdk-bin-16.0.1_p9.ebuild
new file mode 100644
index 0000000..6a82f20
--- /dev/null
+++ b/dev-java/openjdk-bin/openjdk-bin-16.0.1_p9.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit java-vm-2 toolchain-funcs
+
+abi_uri() {
+	echo "${2-$1}? (
+			https://github.com/AdoptOpenJDK/openjdk${SLOT}-binaries/releases/download/jdk-${MY_PV/+/%2B}/OpenJDK${SLOT}U-jdk_${1}_linux_hotspot_${MY_PV/+/_}.tar.gz
+		)"
+}
+
+MY_PV=${PV/_p/+}
+SLOT=${MY_PV%%[.+]*}
+
+SRC_URI="
+	$(abi_uri aarch64 arm64)
+	$(abi_uri arm)
+	$(abi_uri ppc64le ppc64)
+	$(abi_uri s390x s390)
+	$(abi_uri x64 amd64)
+"
+
+DESCRIPTION="Prebuilt Java JDK binaries provided by AdoptOpenJDK"
+HOMEPAGE="https://adoptopenjdk.net"
+LICENSE="GPL-2-with-classpath-exception"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~s390"
+IUSE="alsa cups doc +gentoo-vm headless-awt selinux source"
+
+RDEPEND="
+	media-libs/fontconfig:1.0
+	media-libs/freetype:2
+	>=sys-apps/baselayout-java-0.1.0-r1
+	>=sys-libs/glibc-2.2.5:*
+	sys-libs/zlib
+	alsa? ( media-libs/alsa-lib )
+	cups? ( net-print/cups )
+	selinux? ( sec-policy/selinux-java )
+	!headless-awt? (
+		x11-libs/libX11
+		x11-libs/libXext
+		x11-libs/libXi
+		x11-libs/libXrender
+		x11-libs/libXtst
+	)"
+
+RESTRICT="preserve-libs splitdebug"
+QA_PREBUILT="*"
+
+S="${WORKDIR}/jdk-${MY_PV}"
+
+pkg_pretend() {
+	if [[ "$(tc-is-softfloat)" != "no" ]]; then
+		die "These binaries require a hardfloat system."
+	fi
+}
+
+src_install() {
+	local dest="/opt/${P}"
+	local ddest="${ED%/}/${dest#/}"
+
+	# Not sure why they bundle this as it's commonly available and they
+	# only do so on x86_64. It's needed by libfontmanager.so. IcedTea
+	# also has an explicit dependency while Oracle seemingly dlopens it.
+	rm -vf lib/libfreetype.so || die
+
+	# Oracle and IcedTea have libjsoundalsa.so depending on
+	# libasound.so.2 but AdoptOpenJDK only has libjsound.so. Weird.
+	if ! use alsa ; then
+		rm -v lib/libjsound.* || die
+	fi
+
+	if use headless-awt ; then
+		rm -v lib/lib*{[jx]awt,splashscreen}* || die
+	fi
+
+	if ! use source ; then
+		rm -v lib/src.zip || die
+	fi
+
+	rm -v lib/security/cacerts || die
+	dosym ../../../../etc/ssl/certs/java/cacerts \
+		"${dest}"/lib/security/cacerts
+
+	dodir "${dest}"
+	cp -pPR * "${ddest}" || die
+
+	# provide stable symlink
+	dosym "${P}" "/opt/${PN}-${SLOT}"
+
+	use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}-${SLOT}.env.sh
+	java-vm_set-pax-markings "${ddest}"
+	java-vm_revdep-mask
+	java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
+}
+
+pkg_postinst() {
+	java-vm-2_pkg_postinst
+
+	if use gentoo-vm ; then
+		ewarn "WARNING! You have enabled the gentoo-vm USE flag, making this JDK"
+		ewarn "recognised by the system. This will almost certainly break"
+		ewarn "many java ebuilds as they are not ready for openjdk-11"
+	else
+		ewarn "The experimental gentoo-vm USE flag has not been enabled so this JDK"
+		ewarn "will not be recognised by the system. For example, simply calling"
+		ewarn "\"java\" will launch a different JVM. This is necessary until Gentoo"
+		ewarn "fully supports Java 11. This JDK must therefore be invoked using its"
+		ewarn "absolute location under ${EPREFIX}/opt/${P}."
+	fi
+}
-- 
cgit v1.2.3-70-g09d2