From 947e0b5f512c56edc1b2b414bc86b6298d068cde Mon Sep 17 00:00:00 2001
From: "Alex Xu (Hello71)" <alex_y_xu@yahoo.ca>
Date: Sun, 25 Oct 2020 20:51:14 -0400
Subject: treewide: updates

---
 net-misc/wayvnc/Manifest            |  2 +-
 net-misc/wayvnc/metadata.xml        |  3 ++-
 net-misc/wayvnc/wayvnc-0.2.0.ebuild | 40 -----------------------------------
 net-misc/wayvnc/wayvnc-0.3.0.ebuild | 42 +++++++++++++++++++++++++++++++++++++
 4 files changed, 45 insertions(+), 42 deletions(-)
 delete mode 100644 net-misc/wayvnc/wayvnc-0.2.0.ebuild
 create mode 100644 net-misc/wayvnc/wayvnc-0.3.0.ebuild

(limited to 'net-misc/wayvnc')

diff --git a/net-misc/wayvnc/Manifest b/net-misc/wayvnc/Manifest
index a4bc175..95de4aa 100644
--- a/net-misc/wayvnc/Manifest
+++ b/net-misc/wayvnc/Manifest
@@ -1 +1 @@
-DIST wayvnc-0.2.0.tar.gz 43615 BLAKE2B 7c663193160c97f3c1ac8641a2a9ccad99a9a4ca1d538ab64fe07fc5af759fb8abfac0b5fa9426de0d5e4453c3b60410edd882ffbf2a5d536b1634c714612f6d SHA512 42798ba2bcb96cb718bfe41c48a1525764ac26ea073ba69e26d327d422a379e93e5b57ba03290ca26d3c49c610e68a8459186fcf39998e74af7150df210ad9be
+DIST wayvnc-0.3.0.tar.gz 49516 BLAKE2B 0db1a10454bf6a12a2f0e484dca3e5ffc68e7b4386e25b7eeffbcddb332e1efa9f6af389a7c10f0348bf2f53639959aba19ebdd1c90bef73c571e4cf69894f29 SHA512 a4a06a3532d11eac0b05953f166ffd058af0c31524233333dfb78321dd2f059c1a27bf0b68d8662b1e1108907161711435a31b0da005f851773de1af6351b065
diff --git a/net-misc/wayvnc/metadata.xml b/net-misc/wayvnc/metadata.xml
index cdb7671..0c7d53b 100644
--- a/net-misc/wayvnc/metadata.xml
+++ b/net-misc/wayvnc/metadata.xml
@@ -6,6 +6,7 @@
 		<name>Alex Xu (Hello71)</name>
 	</maintainer>
 	<use>
-		<flag name="gbm">Enable zero-copy screencast support.</flag>
+		<flag name="gbm">Enable zero-copy screencast support</flag>
+		<flag name="man">Build and install man pages</flag>
 	</use>
 </pkgmetadata>
diff --git a/net-misc/wayvnc/wayvnc-0.2.0.ebuild b/net-misc/wayvnc/wayvnc-0.2.0.ebuild
deleted file mode 100644
index db8baae..0000000
--- a/net-misc/wayvnc/wayvnc-0.2.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson
-
-DESCRIPTION="A VNC server for wlroots based Wayland compositors"
-HOMEPAGE="https://github.com/any1/wayvnc"
-if [[ ${PV} == 9999 ]]; then
-	inherit git-r3
-	EGIT_REPO_URI="https://github.com/any1/wayvnc.git"
-else
-	SRC_URI="https://github.com/any1/wayvnc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-fi
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="gbm"
-
-DEPEND="
-	dev-libs/aml
-	dev-libs/wayland
-	net-libs/neatvnc
-	virtual/opengl
-	x11-libs/libxkbcommon
-	x11-libs/pixman
-	gbm? ( media-libs/mesa )
-"
-RDEPEND="${DEPEND}"
-BDEPEND="dev-libs/wayland"
-
-src_configure() {
-	local emesonargs=(
-		$(meson_feature gbm screencopy-dmabuf)
-	)
-
-	meson_src_configure
-}
diff --git a/net-misc/wayvnc/wayvnc-0.3.0.ebuild b/net-misc/wayvnc/wayvnc-0.3.0.ebuild
new file mode 100644
index 0000000..4ae8304
--- /dev/null
+++ b/net-misc/wayvnc/wayvnc-0.3.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A VNC server for wlroots based Wayland compositors"
+HOMEPAGE="https://github.com/any1/wayvnc"
+if [[ ${PV} == 9999 ]]; then
+	inherit git-r3
+	EGIT_REPO_URI="https://github.com/any1/wayvnc.git"
+else
+	SRC_URI="https://github.com/any1/wayvnc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gbm +man"
+
+DEPEND="
+	dev-libs/aml
+	dev-libs/wayland
+	net-libs/neatvnc
+	virtual/opengl
+	x11-libs/libxkbcommon
+	x11-libs/pixman
+	gbm? ( media-libs/mesa )
+	man? ( app-text/scdoc )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-libs/wayland"
+
+src_configure() {
+	local emesonargs=(
+		$(meson_feature gbm screencopy-dmabuf)
+		$(meson_feature man man-pages)
+	)
+
+	meson_src_configure
+}
-- 
cgit v1.2.3-70-g09d2