summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-11-19 17:29:55 -0500
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-11-19 17:30:32 -0500
commit1b1a3afcb09fbd2f9ef019d17f92afef0cbe5040 (patch)
tree0c6991b8d9351f5c88d3bbcb19c9de46d0a50d0b
parent0c459e842eebc2fc15897e535fd40f1a1c08f9f8 (diff)
downloadgentoo-overlay-1b1a3afcb09fbd2f9ef019d17f92afef0cbe5040.tar.xz
gentoo-overlay-1b1a3afcb09fbd2f9ef019d17f92afef0cbe5040.zip
media-gfx/gimp: pull
-rw-r--r--media-gfx/gimp/Manifest1
-rw-r--r--media-gfx/gimp/files/gimp-2.10_fix_test-appdata.patch14
-rw-r--r--media-gfx/gimp/gimp-2.99.8.ebuild265
-rw-r--r--media-gfx/gimp/gimp-9999.ebuild266
-rw-r--r--media-gfx/gimp/metadata.xml16
5 files changed, 562 insertions, 0 deletions
diff --git a/media-gfx/gimp/Manifest b/media-gfx/gimp/Manifest
new file mode 100644
index 0000000..4d0a354
--- /dev/null
+++ b/media-gfx/gimp/Manifest
@@ -0,0 +1 @@
+DIST gimp-2.99.8.tar.bz2 30799403 BLAKE2B a67863f5e7d40beca80f931973759dc4523718ac2740cac4924dae8e1611491e59c43436ca670643be1878e1d9ff1575174a59c919b33103128a812e7eba6042 SHA512 c603d9a315c21c9da716cc1d8c0c784061e7d0eac4b3d28467aabc3c63c950da0a52649e498049e0b8475933ef93d721a2b8423811b47b00c9490485d316345e
diff --git a/media-gfx/gimp/files/gimp-2.10_fix_test-appdata.patch b/media-gfx/gimp/files/gimp-2.10_fix_test-appdata.patch
new file mode 100644
index 0000000..77b7b2f
--- /dev/null
+++ b/media-gfx/gimp/files/gimp-2.10_fix_test-appdata.patch
@@ -0,0 +1,14 @@
+diff -Nur a/desktop/test-appdata.sh.in b/desktop/test-appdata.sh.in
+--- a/desktop/test-appdata.sh.in 2019-04-07 14:38:14.000000000 +0300
++++ b/desktop/test-appdata.sh.in 2019-11-06 23:19:32.000000000 +0300
+@@ -2,8 +2,8 @@
+
+ # TODO: use validate-strict when the last errors for a strict validation
+ # are fixed.
+-appstream-util validate-relax ${GIMP_TESTING_ABS_TOP_BUILDDIR}/desktop/org.gimp.GIMP.appdata.xml && \
+-appstream-util validate-relax ${GIMP_TESTING_ABS_TOP_BUILDDIR}/desktop/gimp-data-extras.metainfo.xml && \
++appstream-util validate-relax --nonet ${GIMP_TESTING_ABS_TOP_BUILDDIR}/desktop/org.gimp.GIMP.appdata.xml && \
++appstream-util validate-relax --nonet ${GIMP_TESTING_ABS_TOP_BUILDDIR}/desktop/gimp-data-extras.metainfo.xml && \
+ if [ $(expr @GIMP_MICRO_VERSION@ % 2) = 0 ]; then
+ grep TODO ${GIMP_TESTING_ABS_TOP_BUILDDIR}/desktop/org.gimp.GIMP.appdata.xml
+ if [ $? = 0 ]; then
diff --git a/media-gfx/gimp/gimp-2.99.8.ebuild b/media-gfx/gimp/gimp-2.99.8.ebuild
new file mode 100644
index 0000000..93caacb
--- /dev/null
+++ b/media-gfx/gimp/gimp-2.99.8.ebuild
@@ -0,0 +1,265 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( luajit )
+PYTHON_COMPAT=( python3_{8..10} )
+GNOME2_EAUTORECONF=yes
+VALA_MIN_API_VERSION="0.44"
+VALA_USE_DEPEND=vapigen
+
+inherit gnome2 lua-single python-single-r1 toolchain-funcs vala virtualx
+
+DESCRIPTION="GNU Image Manipulation Program"
+HOMEPAGE="https://www.gimp.org/"
+SRC_URI="mirror://gimp/v2.99/${P}.tar.bz2"
+LICENSE="GPL-3 LGPL-3"
+SLOT="0/3"
+
+IUSE="aalib alsa aqua doc gnome heif javascript jpeg2k jpegxl lua mng openexr postscript python udev unwind vala vector-icons webp wmf xpm cpu_flags_ppc_altivec cpu_flags_x86_mmx cpu_flags_x86_sse"
+REQUIRED_USE="
+ lua? ( ${LUA_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RESTRICT="!test? ( test )"
+
+# media-libs/{babl,gegl} are required to be built with USE="introspection"
+# to fix the compilation checking of /usr/share/gir-1.0/{Babl-0.1gir,Gegl-0.4.gir}
+COMMON_DEPEND="
+ >=app-text/poppler-0.90.1[cairo]
+ >=app-text/poppler-data-0.4.9
+ >=dev-libs/atk-2.34.1
+ >=dev-libs/glib-2.68.0:2
+ >=dev-libs/json-glib-1.4.4
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ >=gnome-base/librsvg-2.40.21:2
+ >=media-gfx/mypaint-brushes-2.0.2:=
+ >=media-libs/babl-0.1.86[introspection,lcms,vala?]
+ >=media-libs/fontconfig-2.12.6
+ >=media-libs/freetype-2.10.2
+ >=media-libs/gegl-0.4.32:0.4[cairo,introspection,lcms,vala?]
+ >=media-libs/gexiv2-0.10.10
+ >=media-libs/harfbuzz-2.6.5:=
+ >=media-libs/lcms-2.9:2
+ >=media-libs/libmypaint-1.6.1:=
+ >=media-libs/libpng-1.6.37:0=
+ >=media-libs/tiff-4.1.0:0
+ net-libs/glib-networking[ssl]
+ sys-libs/zlib
+ virtual/jpeg
+ >=x11-libs/cairo-1.16.0
+ >=x11-libs/gdk-pixbuf-2.40.0:2[introspection]
+ >=x11-libs/gtk+-3.24.16:3[introspection]
+ x11-libs/libXcursor
+ >=x11-libs/pango-1.44.7
+ aalib? ( media-libs/aalib )
+ alsa? ( >=media-libs/alsa-lib-1.0.0 )
+ aqua? ( >=x11-libs/gtk-mac-integration-2.0.0 )
+ heif? ( >=media-libs/libheif-1.9.1:= )
+ javascript? ( dev-libs/gjs )
+ jpeg2k? ( >=media-libs/openjpeg-2.3.1:2= )
+ jpegxl? ( media-libs/libjxl:= )
+ lua? (
+ ${LUA_DEPS}
+ $(lua_gen_cond_dep '
+ dev-lua/lgi[${LUA_USEDEP}]
+ ')
+ )
+ mng? ( media-libs/libmng:= )
+ openexr? ( >=media-libs/openexr-2.3.0:= )
+ postscript? ( app-text/ghostscript-gpl )
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-3.0:3[${PYTHON_USEDEP}]
+ ')
+ )
+ udev? ( >=dev-libs/libgudev-167:= )
+ unwind? ( >=sys-libs/libunwind-1.1.0:= )
+ webp? ( >=media-libs/libwebp-0.6.0:= )
+ wmf? ( >=media-libs/libwmf-0.2.8 )
+ xpm? ( x11-libs/libXpm )
+"
+
+RDEPEND="
+ ${COMMON_DEPEND}
+ x11-themes/hicolor-icon-theme
+ gnome? ( gnome-base/gvfs )
+"
+
+DEPEND="
+ ${COMMON_DEPEND}
+ >=dev-lang/perl-5.30.3
+ >=dev-libs/appstream-glib-0.7.16
+ dev-util/gdbus-codegen
+ dev-util/gtk-update-icon-cache
+ >=dev-util/intltool-0.51.0
+ sys-apps/findutils
+ >=sys-devel/autoconf-2.54
+ >=sys-devel/automake-1.11
+ >=sys-devel/gettext-0.21
+ >=sys-devel/libtool-2.4.6
+ doc? (
+ app-text/yelp-tools
+ dev-libs/gobject-introspection[doctool]
+ >=dev-util/gtk-doc-1.32
+ dev-util/gtk-doc-am
+ )
+ vala? ( $(vala_depend) )
+"
+
+# TODO: there are probably more atoms in DEPEND which should be in BDEPEND now
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( "AUTHORS" "HACKING" "NEWS" "README" "README.i18n" )
+
+# Bugs 685210 (and duplicate 691070)
+PATCHES=(
+ "${FILESDIR}/${PN}-2.10_fix_test-appdata.patch"
+)
+
+pkg_setup() {
+ use lua && lua-single_pkg_setup
+
+ if use python; then
+ python-single-r1_pkg_setup
+ fi
+}
+
+src_prepare() {
+ sed -i -e 's/mypaint-brushes-1.0/mypaint-brushes-2.0/' configure.ac || die #737794
+
+ sed -i -e 's/== "xquartz"/= "xquartz"/' configure.ac || die #494864
+ sed 's:-DGIMP_DISABLE_DEPRECATED:-DGIMP_protect_DISABLE_DEPRECATED:g' -i configure.ac || die #615144
+
+ gnome2_src_prepare # calls eautoreconf
+
+ use vala && vala_src_prepare
+
+ sed 's:-DGIMP_protect_DISABLE_DEPRECATED:-DGIMP_DISABLE_DEPRECATED:g' -i configure || die #615144
+ fgrep -q GIMP_DISABLE_DEPRECATED configure || die #615144, self-test
+
+ export CC_FOR_BUILD="$(tc-getBUILD_CC)"
+}
+
+_adjust_sandbox() {
+ # Bugs #569738 and #591214
+ local nv
+ for nv in /dev/nvidia-uvm /dev/nvidiactl /dev/nvidia{0..9} ; do
+ # We do not check for existence as they may show up later
+ # https://bugs.gentoo.org/show_bug.cgi?id=569738#c21
+ addwrite "${nv}"
+ done
+
+ addwrite /dev/dri/ # bugs #574038 and #684886
+ addwrite /dev/ati/ # bug #589198
+ addwrite /proc/mtrr # bug #589198
+}
+
+src_configure() {
+ _adjust_sandbox
+
+ local myconf=(
+ GEGL="${EPREFIX}"/usr/bin/gegl-0.4
+ GDBUS_CODEGEN="${EPREFIX}"/usr/bin/gdbus-codegen
+
+ --enable-default-binary
+
+ --disable-check-update
+ --enable-mp
+ --with-appdata-test
+ --with-bug-report-url=https://bugs.gentoo.org/
+ --with-xmc
+ --without-libbacktrace
+ --without-webkit
+ --without-xvfb-run
+ $(use_enable cpu_flags_ppc_altivec altivec)
+ $(use_enable cpu_flags_x86_mmx mmx)
+ $(use_enable cpu_flags_x86_sse sse)
+ $(use_enable doc gtk_doc)
+ $(use_enable doc g-ir-doc)
+ $(use_enable vector-icons)
+ $(use_with aalib aa)
+ $(use_with alsa)
+ $(use_with !aqua x)
+ $(use_with heif libheif)
+ $(use_with javascript)
+ $(use_with jpeg2k jpeg2000)
+ $(use_with jpegxl)
+ $(use_with lua)
+ $(use_with mng libmng)
+ $(use_with openexr)
+ $(use_with postscript gs)
+ $(use_with python)
+ $(use_with udev gudev)
+ $(use_with unwind libunwind)
+ $(use_with vala)
+ $(use_with webp)
+ $(use_with wmf)
+ $(use_with xpm libxpm)
+ )
+
+ gnome2_src_configure "${myconf[@]}"
+}
+
+src_compile() {
+ export XDG_DATA_DIRS="${EPREFIX}"/usr/share # bug 587004
+ gnome2_src_compile
+}
+
+# for https://bugs.gentoo.org/664938
+_rename_plugins() {
+ einfo 'Renaming plug-ins to not collide with pre-2.10.6 file layout (bug #664938)...'
+ local prepend=gimp-org-
+ (
+ cd "${ED}"/usr/$(get_libdir)/gimp/2.99/plug-ins || exit 1
+ for plugin_slash in $(ls -d1 */); do
+ plugin=${plugin_slash%/}
+ if [[ -f ${plugin}/${plugin} ]]; then
+ # NOTE: Folder and file name need to match for Gimp to load that plug-in
+ # so "file-svg/file-svg" becomes "${prepend}file-svg/${prepend}file-svg"
+ mv ${plugin}/{,${prepend}}${plugin} || exit 1
+ mv {,${prepend}}${plugin} || exit 1
+ fi
+ done
+ )
+}
+
+src_test() {
+ virtx emake check
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use python; then
+ python_optimize
+ fi
+
+ # Workaround for bug #321111 to give GIMP the least
+ # precedence on PDF documents by default
+ mv "${ED}"/usr/share/applications/{,zzz-}gimp.desktop || die
+
+ find "${D}" -name '*.la' -type f -delete || die
+
+ # Prevent dead symlink gimp-console.1 from downstream man page compression (bug #433527)
+ mv "${ED}"/usr/share/man/man1/gimp-console{-*,}.1 || die
+
+ _rename_plugins || die
+
+ if use doc; then
+ mkdir "${ED}/usr/share/gtk-doc/html/gimp3_g-ir-docs" || die
+ cp -r "${S}/devel-docs/g-ir-docs/html/"{gjs,python} "${ED}/usr/share/gtk-doc/html/gimp3_g-ir-docs/" || die
+ fi
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+}
diff --git a/media-gfx/gimp/gimp-9999.ebuild b/media-gfx/gimp/gimp-9999.ebuild
new file mode 100644
index 0000000..b791c3f
--- /dev/null
+++ b/media-gfx/gimp/gimp-9999.ebuild
@@ -0,0 +1,266 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( luajit )
+PYTHON_COMPAT=( python3_{8..10} )
+GNOME2_EAUTORECONF=yes
+VALA_MIN_API_VERSION="0.44"
+VALA_USE_DEPEND=vapigen
+
+inherit git-r3 gnome2 lua-single python-single-r1 toolchain-funcs vala virtualx
+
+DESCRIPTION="GNU Image Manipulation Program"
+HOMEPAGE="https://www.gimp.org/"
+EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/gimp.git"
+SRC_URI=""
+LICENSE="GPL-3 LGPL-3"
+SLOT="0/3"
+
+IUSE="aalib alsa aqua doc gnome heif javascript jpeg2k jpegxl lua mng openexr postscript python udev unwind vala vector-icons webp wmf xpm cpu_flags_ppc_altivec cpu_flags_x86_mmx cpu_flags_x86_sse"
+REQUIRED_USE="
+ lua? ( ${LUA_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RESTRICT="!test? ( test )"
+
+# media-libs/{babl,gegl} are required to be built with USE="introspection"
+# to fix the compilation checking of /usr/share/gir-1.0/{Babl-0.1gir,Gegl-0.4.gir}
+COMMON_DEPEND="
+ >=app-text/poppler-0.90.1[cairo]
+ >=app-text/poppler-data-0.4.9
+ >=dev-libs/atk-2.34.1
+ >=dev-libs/glib-2.68.0:2
+ >=dev-libs/json-glib-1.4.4
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ >=gnome-base/librsvg-2.40.21:2
+ >=media-gfx/mypaint-brushes-2.0.2:=
+ >=media-libs/babl-0.1.86[introspection,lcms,vala?]
+ >=media-libs/fontconfig-2.12.6
+ >=media-libs/freetype-2.10.2
+ >=media-libs/gegl-0.4.32:0.4[cairo,introspection,lcms,vala?]
+ >=media-libs/gexiv2-0.10.10
+ >=media-libs/harfbuzz-2.6.5:=
+ >=media-libs/lcms-2.9:2
+ >=media-libs/libmypaint-1.6.1:=
+ >=media-libs/libpng-1.6.37:0=
+ >=media-libs/tiff-4.1.0:0
+ net-libs/glib-networking[ssl]
+ sys-libs/zlib
+ virtual/jpeg
+ >=x11-libs/cairo-1.16.0
+ >=x11-libs/gdk-pixbuf-2.40.0:2
+ >=x11-libs/gtk+-3.24.16:3
+ x11-libs/libXcursor
+ >=x11-libs/pango-1.44.7
+ aalib? ( media-libs/aalib )
+ alsa? ( >=media-libs/alsa-lib-1.0.0 )
+ aqua? ( >=x11-libs/gtk-mac-integration-2.0.0 )
+ heif? ( >=media-libs/libheif-1.9.1:= )
+ javascript? ( dev-libs/gjs )
+ jpeg2k? ( >=media-libs/openjpeg-2.3.1:2= )
+ jpegxl? ( media-libs/libjxl:= )
+ lua? (
+ ${LUA_DEPS}
+ $(lua_gen_cond_dep '
+ dev-lua/lgi[${LUA_USEDEP}]
+ ')
+ )
+ mng? ( media-libs/libmng:= )
+ openexr? ( >=media-libs/openexr-2.3.0:= )
+ postscript? ( app-text/ghostscript-gpl )
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-3.0:3[${PYTHON_USEDEP}]
+ ')
+ )
+ udev? ( >=dev-libs/libgudev-167:= )
+ unwind? ( >=sys-libs/libunwind-1.1.0:= )
+ webp? ( >=media-libs/libwebp-0.6.0:= )
+ wmf? ( >=media-libs/libwmf-0.2.8 )
+ xpm? ( x11-libs/libXpm )
+"
+
+RDEPEND="
+ ${COMMON_DEPEND}
+ x11-themes/hicolor-icon-theme
+ gnome? ( gnome-base/gvfs )
+"
+
+DEPEND="
+ ${COMMON_DEPEND}
+ >=dev-lang/perl-5.30.3
+ >=dev-libs/appstream-glib-0.7.16
+ dev-util/gdbus-codegen
+ dev-util/gtk-update-icon-cache
+ >=dev-util/intltool-0.51.0
+ sys-apps/findutils
+ >=sys-devel/autoconf-2.54
+ >=sys-devel/automake-1.11
+ >=sys-devel/gettext-0.21
+ >=sys-devel/libtool-2.4.6
+ doc? (
+ >=dev-util/gtk-doc-1.32
+ dev-util/gtk-doc-am
+ )
+ vala? ( $(vala_depend) )
+"
+
+# TODO: there are probably more atoms in DEPEND which should be in BDEPEND now
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( "AUTHORS" "HACKING" "NEWS" "README" "README.i18n" )
+
+# Bugs 685210 (and duplicate 691070)
+PATCHES=(
+ "${FILESDIR}/${PN}-2.10_fix_test-appdata.patch"
+)
+
+pkg_setup() {
+ use lua && lua-single_pkg_setup
+
+ if use python; then
+ python-single-r1_pkg_setup
+ fi
+}
+
+src_prepare() {
+ sed -i -e 's/mypaint-brushes-1.0/mypaint-brushes-2.0/' configure.ac || die #737794
+
+ sed -i -e 's/== "xquartz"/= "xquartz"/' configure.ac || die #494864
+ sed 's:-DGIMP_DISABLE_DEPRECATED:-DGIMP_protect_DISABLE_DEPRECATED:g' -i configure.ac || die #615144
+
+ # Fix checking of gtk-doc.make if USE="-doc" like autogen.sh
+ # USE="doc" is currently broken for gimp-9999 due to absence of appropriate *.m4 file
+ if ! use doc ; then
+ echo "EXTRA_DIST = missing-gtk-doc" > gtk-doc.make
+ sed -i -e "/CLEANFILES/s/^/#/g" \
+ "${S}"/devel-docs/{libgimp,libgimpbase,libgimpcolor,libgimpconfig,libgimpmath,libgimpmodule,libgimpthumb,libgimpwidgets}/Makefile.am || die
+ fi
+
+ gnome2_src_prepare # calls eautoreconf
+
+ use vala && vala_src_prepare
+
+ sed 's:-DGIMP_protect_DISABLE_DEPRECATED:-DGIMP_DISABLE_DEPRECATED:g' -i configure || die #615144
+ fgrep -q GIMP_DISABLE_DEPRECATED configure || die #615144, self-test
+
+ export CC_FOR_BUILD="$(tc-getBUILD_CC)"
+}
+
+_adjust_sandbox() {
+ # Bugs #569738 and #591214
+ local nv
+ for nv in /dev/nvidia-uvm /dev/nvidiactl /dev/nvidia{0..9} ; do
+ # We do not check for existence as they may show up later
+ # https://bugs.gentoo.org/show_bug.cgi?id=569738#c21
+ addwrite "${nv}"
+ done
+
+ addwrite /dev/dri/ # bugs #574038 and #684886
+ addwrite /dev/ati/ # bug #589198
+ addwrite /proc/mtrr # bug #589198
+}
+
+src_configure() {
+ _adjust_sandbox
+
+ local myconf=(
+ GEGL="${EPREFIX}"/usr/bin/gegl-0.4
+ GDBUS_CODEGEN="${EPREFIX}"/usr/bin/gdbus-codegen
+
+ --enable-default-binary
+
+ --disable-check-update
+ --enable-mp
+ --with-appdata-test
+ --with-bug-report-url=https://bugs.gentoo.org/
+ --with-xmc
+ --without-libbacktrace
+ --without-webkit
+ --without-xvfb-run
+ $(use_enable cpu_flags_ppc_altivec altivec)
+ $(use_enable cpu_flags_x86_mmx mmx)
+ $(use_enable cpu_flags_x86_sse sse)
+ $(use_enable doc gtk_doc)
+ $(use_enable vector-icons)
+ $(use_with aalib aa)
+ $(use_with alsa)
+ $(use_with !aqua x)
+ $(use_with heif libheif)
+ $(use_with javascript)
+ $(use_with jpeg2k jpeg2000)
+ $(use_with jpegxl)
+ $(use_with lua)
+ $(use_with mng libmng)
+ $(use_with openexr)
+ $(use_with postscript gs)
+ $(use_with python)
+ $(use_with udev gudev)
+ $(use_with unwind libunwind)
+ $(use_with vala)
+ $(use_with webp)
+ $(use_with wmf)
+ $(use_with xpm libxpm)
+ )
+
+ gnome2_src_configure "${myconf[@]}"
+}
+
+src_compile() {
+ export XDG_DATA_DIRS="${EPREFIX}"/usr/share # bug 587004
+ gnome2_src_compile
+}
+
+# for https://bugs.gentoo.org/664938
+_rename_plugins() {
+ einfo 'Renaming plug-ins to not collide with pre-2.10.6 file layout (bug #664938)...'
+ local prepend=gimp-org-
+ (
+ cd "${ED}"/usr/$(get_libdir)/gimp/2.99/plug-ins || exit 1
+ for plugin_slash in $(ls -d1 */); do
+ plugin=${plugin_slash%/}
+ if [[ -f ${plugin}/${plugin} ]]; then
+ # NOTE: Folder and file name need to match for Gimp to load that plug-in
+ # so "file-svg/file-svg" becomes "${prepend}file-svg/${prepend}file-svg"
+ mv ${plugin}/{,${prepend}}${plugin} || exit 1
+ mv {,${prepend}}${plugin} || exit 1
+ fi
+ done
+ )
+}
+
+src_test() {
+ virtx emake check
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use python; then
+ python_optimize
+ fi
+
+ # Workaround for bug #321111 to give GIMP the least
+ # precedence on PDF documents by default
+ mv "${ED}"/usr/share/applications/{,zzz-}gimp.desktop || die
+
+ find "${D}" -name '*.la' -type f -delete || die
+
+ # Prevent dead symlink gimp-console.1 from downstream man page compression (bug #433527)
+ mv "${ED}"/usr/share/man/man1/gimp-console{-*,}.1 || die
+
+ _rename_plugins || die
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+}
diff --git a/media-gfx/gimp/metadata.xml b/media-gfx/gimp/metadata.xml
new file mode 100644
index 0000000..a88c4f2
--- /dev/null
+++ b/media-gfx/gimp/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>torokhov-s-a@yandex.ru</email>
+ <name>Sergey Torokhov</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="heif">Enable support for ISO/IEC 23008-12:2017 HEIF files</flag>
+ <flag name="vector-icons">Enable support for vector icons (experimental)</flag>
+ </use>
+</pkgmetadata>