summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2022-08-12 17:57:05 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2022-08-12 17:57:05 -0400
commit28e745c4b9c45a0e0862336eb67d8b7c5a416da7 (patch)
tree7965949c897a38b676dd2a74b2f275178751d77c
parent40f9f4077e66e27f9c1dece0acdc8dc4282fafca (diff)
downloadgentoo-overlay-28e745c4b9c45a0e0862336eb67d8b7c5a416da7.tar.xz
gentoo-overlay-28e745c4b9c45a0e0862336eb67d8b7c5a416da7.zip
fix pkgcheck issues
-rw-r--r--dev-java/openj9-openjdk/metadata.xml1
-rw-r--r--dev-java/openj9-openjdk/openj9-openjdk-11.0.33.0.ebuild2
-rw-r--r--dev-java/openj9-openjdk/openj9-openjdk-17.0.33.0.ebuild2
-rw-r--r--eclass/virtualwl.eclass4
-rw-r--r--games-rpg/runescape-launcher-launcher/runescape-launcher-launcher-1.3-r1.ebuild2
-rw-r--r--mail-client/astroid/astroid-9999.ebuild2
-rw-r--r--x11-apps/sx/sx-2.1.7.ebuild1
-rw-r--r--x11-apps/sx/sx-9999.ebuild1
8 files changed, 7 insertions, 8 deletions
diff --git a/dev-java/openj9-openjdk/metadata.xml b/dev-java/openj9-openjdk/metadata.xml
index 8af5981..7148c44 100644
--- a/dev-java/openj9-openjdk/metadata.xml
+++ b/dev-java/openj9-openjdk/metadata.xml
@@ -11,6 +11,7 @@
<flag name="gentoo-vm">Allow this JDK to be recognised by Gentoo (package manager, eselect, java-config, EXPERIMENTAL!)</flag>
<flag name="javafx">Import OpenJFX modules at build time, via <pkg>dev-java/openjfx</pkg></flag>
<flag name="jbootstrap">Build OpenJDK twice, the second time using the result of the first</flag>
+ <flag name="jitserver">OpenJ9 JITServer support</flag>
<flag name="numa">Enable NUMA support using sys-process/numactl (NUMA kernel support is also required)</flag>
<flag name="systemtap">Enable SystemTAP/DTrace tracing</flag>
</use>
diff --git a/dev-java/openj9-openjdk/openj9-openjdk-11.0.33.0.ebuild b/dev-java/openj9-openjdk/openj9-openjdk-11.0.33.0.ebuild
index 0d76c28..bf3e716 100644
--- a/dev-java/openj9-openjdk/openj9-openjdk-11.0.33.0.ebuild
+++ b/dev-java/openj9-openjdk/openj9-openjdk-11.0.33.0.ebuild
@@ -19,7 +19,7 @@ if [[ ${OPENJ9_PV} == 9999 ]]; then
else
SRC_URI="
https://github.com/ibmruntimes/openj9-openjdk-jdk${SLOT}/archive/v${OPENJ9_PV}-release.tar.gz -> openj9-openjdk-jdk${SLOT}-${OPENJ9_P}.tar.gz
- https://github.com/eclipse/openj9/archive/${OPENJ9_P}.tar.gz -> ${OPENJ9_P}.tar.gz
+ https://github.com/eclipse/openj9/archive/${OPENJ9_P}.tar.gz
https://github.com/eclipse/openj9-omr/archive/${OPENJ9_P}.tar.gz -> openj9-omr-${OPENJ9_PV}.tar.gz
"
fi
diff --git a/dev-java/openj9-openjdk/openj9-openjdk-17.0.33.0.ebuild b/dev-java/openj9-openjdk/openj9-openjdk-17.0.33.0.ebuild
index 7ee9bac..8a7494e 100644
--- a/dev-java/openj9-openjdk/openj9-openjdk-17.0.33.0.ebuild
+++ b/dev-java/openj9-openjdk/openj9-openjdk-17.0.33.0.ebuild
@@ -19,7 +19,7 @@ if [[ ${OPENJ9_PV} == 9999 ]]; then
else
SRC_URI="
https://github.com/ibmruntimes/openj9-openjdk-jdk${SLOT}/archive/v${OPENJ9_PV}-release.tar.gz -> openj9-openjdk-jdk${SLOT}-${OPENJ9_P}.tar.gz
- https://github.com/eclipse/openj9/archive/${OPENJ9_P}.tar.gz -> ${OPENJ9_P}.tar.gz
+ https://github.com/eclipse/openj9/archive/${OPENJ9_P}.tar.gz
https://github.com/eclipse/openj9-omr/archive/${OPENJ9_P}.tar.gz -> openj9-omr-${OPENJ9_PV}.tar.gz
"
fi
diff --git a/eclass/virtualwl.eclass b/eclass/virtualwl.eclass
index c3391ce..9146425 100644
--- a/eclass/virtualwl.eclass
+++ b/eclass/virtualwl.eclass
@@ -17,7 +17,7 @@ esac
if [[ ! ${_VIRTUALWL_ECLASS} ]]; then
_VIRTUALWL_ECLASS=1
-# @ECLASS-VARIABLE: VIRTUALWL_REQUIRED
+# @ECLASS_VARIABLE: VIRTUALWL_REQUIRED
# @PRE_INHERIT
# @DESCRIPTION:
# Variable specifying the dependency on wayland.
@@ -28,7 +28,7 @@ _VIRTUALWL_ECLASS=1
# into "kde? ( )" and add kde into IUSE.
: ${VIRTUALWL_REQUIRED:=test}
-# @ECLASS-VARIABLE: VIRTUALWL_DEPEND
+# @ECLASS_VARIABLE: VIRTUALWL_DEPEND
# @OUTPUT_VARIABLE
# @DESCRIPTION:
# Standard dependencies string that is automatically added to BDEPEND
diff --git a/games-rpg/runescape-launcher-launcher/runescape-launcher-launcher-1.3-r1.ebuild b/games-rpg/runescape-launcher-launcher/runescape-launcher-launcher-1.3-r1.ebuild
index e62ae52..48b5a06 100644
--- a/games-rpg/runescape-launcher-launcher/runescape-launcher-launcher-1.3-r1.ebuild
+++ b/games-rpg/runescape-launcher-launcher/runescape-launcher-launcher-1.3-r1.ebuild
@@ -31,5 +31,5 @@ src_compile() {
}
src_install() {
- emake prefix="${EPREFIX}/usr" DESTDIR=${D} install
+ emake prefix="${EPREFIX}/usr" DESTDIR="${D}" install
}
diff --git a/mail-client/astroid/astroid-9999.ebuild b/mail-client/astroid/astroid-9999.ebuild
index dfc7f6f..a75b422 100644
--- a/mail-client/astroid/astroid-9999.ebuild
+++ b/mail-client/astroid/astroid-9999.ebuild
@@ -5,7 +5,7 @@ EAPI=7
: "${CMAKE_MAKEFILE_GENERATOR:=ninja}"
-inherit cmake git-r3 virtualx
+inherit cmake git-r3 optfeature virtualx
DESCRIPTION="lightweight graphical threads-with-tags style email client for notmuch"
HOMEPAGE="https://github.com/astroidmail/astroid"
diff --git a/x11-apps/sx/sx-2.1.7.ebuild b/x11-apps/sx/sx-2.1.7.ebuild
index abe083b..2349365 100644
--- a/x11-apps/sx/sx-2.1.7.ebuild
+++ b/x11-apps/sx/sx-2.1.7.ebuild
@@ -9,7 +9,6 @@ HOMEPAGE="https://github.com/Earnestly/sx"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/Earnestly/sx.git"
- KEYWORDS=""
else
SRC_URI="https://github.com/Earnestly/sx/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
diff --git a/x11-apps/sx/sx-9999.ebuild b/x11-apps/sx/sx-9999.ebuild
index 2c2e7a2..6d97a9e 100644
--- a/x11-apps/sx/sx-9999.ebuild
+++ b/x11-apps/sx/sx-9999.ebuild
@@ -9,7 +9,6 @@ HOMEPAGE="https://github.com/Earnestly/sx"
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/Earnestly/sx.git"
- KEYWORDS=""
else
SRC_URI="https://github.com/Earnestly/sx/archive/${PV}.tar.gz"
KEYWORDS="~amd64 ~x86"