summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-01-21 21:55:43 -0500
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-01-21 21:55:43 -0500
commit2c9a578b2dfef5df666a866897c30ff914a5c57a (patch)
treec9817d2890df51acb2d61667e054fca5504b0849
parent59cc78eb52efa6651e7be1c79340164ed987fcdd (diff)
downloadgentoo-overlay-2c9a578b2dfef5df666a866897c30ff914a5c57a.tar.xz
gentoo-overlay-2c9a578b2dfef5df666a866897c30ff914a5c57a.zip
net-misc/wayvnc: bump
-rw-r--r--net-misc/wayvnc/Manifest1
-rw-r--r--net-misc/wayvnc/wayvnc-0.4.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/net-misc/wayvnc/Manifest b/net-misc/wayvnc/Manifest
index 95de4aa..213b529 100644
--- a/net-misc/wayvnc/Manifest
+++ b/net-misc/wayvnc/Manifest
@@ -1 +1,2 @@
DIST wayvnc-0.3.0.tar.gz 49516 BLAKE2B 0db1a10454bf6a12a2f0e484dca3e5ffc68e7b4386e25b7eeffbcddb332e1efa9f6af389a7c10f0348bf2f53639959aba19ebdd1c90bef73c571e4cf69894f29 SHA512 a4a06a3532d11eac0b05953f166ffd058af0c31524233333dfb78321dd2f059c1a27bf0b68d8662b1e1108907161711435a31b0da005f851773de1af6351b065
+DIST wayvnc-0.4.0.tar.gz 52157 BLAKE2B 7c8456d5136ef361ca7dd72ffa7501514eeb7a61ae1777a02391fb7fceea6b020d68951300ab76254f2afd5e2610fe66ce0f461d18dc38522706691438f4620e SHA512 b8f1af24213077dc6126ae1f613b9cdeed8f365f9d1989a5b053563f0eb4bc49921e746e0f1026fe0e02bfeea23b912798678a5a337a052d977aa04496a75570
diff --git a/net-misc/wayvnc/wayvnc-0.4.0.ebuild b/net-misc/wayvnc/wayvnc-0.4.0.ebuild
new file mode 100644
index 0000000..16661e8
--- /dev/null
+++ b/net-misc/wayvnc/wayvnc-0.4.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A VNC server for wlroots based Wayland compositors"
+HOMEPAGE="https://github.com/any1/wayvnc"
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/any1/wayvnc.git"
+else
+ SRC_URI="https://github.com/any1/wayvnc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gbm +man systemtap"
+
+DEPEND="
+ dev-libs/aml
+ dev-libs/wayland
+ net-libs/neatvnc
+ virtual/opengl
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+ gbm? ( media-libs/mesa )
+ man? ( app-text/scdoc )
+ systemtap? ( dev-util/systemtap )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="dev-libs/wayland"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature gbm screencopy-dmabuf)
+ $(meson_feature man man-pages)
+ $(meson_feature systemtap)
+ )
+
+ meson_src_configure
+}