summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-10-07 15:04:40 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-10-07 15:04:40 -0400
commit30feedf6dd65cf689c97a11f4f9720e8b572b523 (patch)
tree79a1c99fdab264732ed79310fa8122cadf8dfe2e
parentcb6ecbdc34bc50a54f497cbb1a69b4e7bdfca4c8 (diff)
downloadgentoo-overlay-30feedf6dd65cf689c97a11f4f9720e8b572b523.tar.xz
gentoo-overlay-30feedf6dd65cf689c97a11f4f9720e8b572b523.zip
dev-cpp/highway: add multilib
-rw-r--r--dev-cpp/highway/highway-0.14.2.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-cpp/highway/highway-0.14.2.ebuild b/dev-cpp/highway/highway-0.14.2.ebuild
index 7f21cc2..60d4459 100644
--- a/dev-cpp/highway/highway-0.14.2.ebuild
+++ b/dev-cpp/highway/highway-0.14.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit cmake
+inherit cmake-multilib
DESCRIPTION="Performance-portable, length-agnostic SIMD with runtime dispatch"
HOMEPAGE="https://github.com/google/highway"
@@ -14,11 +14,11 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
-DEPEND="test? ( dev-cpp/gtest )"
+DEPEND="test? ( dev-cpp/gtest[${MULTILIB_USEDEP}] )"
RDEPEND=""
BDEPEND=""
-src_configure() {
+multilib_src_configure() {
local mycmakeargs=(
-DBUILD_TESTING=$(usex test ON OFF)
-DHWY_SYSTEM_GTEST=ON