summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-10-21 11:12:15 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-10-21 11:12:15 -0400
commit5181b03977c0d90f2be38e6bca3037a2928c13ab (patch)
treeb2df0f424bb8551f95ac823933dd049ef8c19cae
parentb41cad055fb9e4d39f23dfbe91babba8f36c4762 (diff)
downloadgentoo-overlay-5181b03977c0d90f2be38e6bca3037a2928c13ab.tar.xz
gentoo-overlay-5181b03977c0d90f2be38e6bca3037a2928c13ab.zip
dev-java/openj9-openjdk: fixes
-rw-r--r--dev-java/openj9-openjdk/openj9-openjdk-11.0.29.0.ebuild10
-rw-r--r--dev-java/openj9-openjdk/openj9-openjdk-17.0.29.0.ebuild10
2 files changed, 4 insertions, 16 deletions
diff --git a/dev-java/openj9-openjdk/openj9-openjdk-11.0.29.0.ebuild b/dev-java/openj9-openjdk/openj9-openjdk-11.0.29.0.ebuild
index f855f71..febcf59 100644
--- a/dev-java/openj9-openjdk/openj9-openjdk-11.0.29.0.ebuild
+++ b/dev-java/openj9-openjdk/openj9-openjdk-11.0.29.0.ebuild
@@ -79,7 +79,6 @@ DEPEND="
x11-libs/libXtst
javafx? ( dev-java/openjfx:${SLOT}= )
|| (
- virtual/jdk:${SLOT}
dev-java/openj9-openjdk-bin:${SLOT}
dev-java/openj9-openjdk:${SLOT}
dev-java/openjdk-bin:${SLOT}
@@ -89,11 +88,7 @@ DEPEND="
REQUIRED_USE="javafx? ( alsa !headless-awt )"
-if [[ ${OPENJ9_PV} == 9999 ]]; then
- S="${WORKDIR}/openj9-openjdk-jdk${SLOT}"
-else
- S="${WORKDIR}/openj9-openjdk-jdk${SLOT}-${OPENJ9_PV}-release"
-fi
+S="${WORKDIR}/openj9-openjdk-jdk${SLOT}-${OPENJ9_PV}-release"
# The space required to build varies wildly depending on USE flags,
# ranging from 3GB to 16GB. This function is certainly not exact but
@@ -112,7 +107,6 @@ pkg_pretend() {
openjdk_check_requirements
if [[ ${MERGE_TYPE} != binary ]]; then
has ccache ${FEATURES} && die "FEATURES=ccache doesn't work with ${PN}, bug #677876"
- [[ $(gcc-major-version) == 11 ]] && die "gcc 11 hangs when optimizing exploded image"
fi
}
@@ -212,6 +206,7 @@ src_configure() {
local myconf=(
--disable-ccache
+ --disable-warnings-as-errors{,-omr,-openj9}
--enable-full-docs=no
--with-boot-jdk="${JDK_HOME}"
--with-extra-cflags="${CFLAGS}"
@@ -237,7 +232,6 @@ src_configure() {
--enable-headless-only=$(usex headless-awt yes no)
$(tc-is-clang && echo "--with-toolchain-type=clang")
- --disable-warnings-as-errors{,-omr,-openj9}
--with-cmake
$(use_enable ddr)
)
diff --git a/dev-java/openj9-openjdk/openj9-openjdk-17.0.29.0.ebuild b/dev-java/openj9-openjdk/openj9-openjdk-17.0.29.0.ebuild
index 611a075..9a85f8b 100644
--- a/dev-java/openj9-openjdk/openj9-openjdk-17.0.29.0.ebuild
+++ b/dev-java/openj9-openjdk/openj9-openjdk-17.0.29.0.ebuild
@@ -79,7 +79,6 @@ DEPEND="
x11-libs/libXtst
javafx? ( dev-java/openjfx:${SLOT}= )
|| (
- virtual/jdk:${SLOT}
dev-java/openj9-openjdk-bin:${SLOT}
dev-java/openj9-openjdk:${SLOT}
dev-java/openjdk-bin:${SLOT}
@@ -89,11 +88,7 @@ DEPEND="
REQUIRED_USE="javafx? ( alsa !headless-awt )"
-if [[ ${OPENJ9_PV} == 9999 ]]; then
- S="${WORKDIR}/openj9-openjdk-jdk${SLOT}"
-else
- S="${WORKDIR}/openj9-openjdk-jdk${SLOT}-${OPENJ9_PV}-release"
-fi
+S="${WORKDIR}/openj9-openjdk-jdk${SLOT}-${OPENJ9_PV}-release"
# The space required to build varies wildly depending on USE flags,
# ranging from 3GB to 16GB. This function is certainly not exact but
@@ -112,7 +107,6 @@ pkg_pretend() {
openjdk_check_requirements
if [[ ${MERGE_TYPE} != binary ]]; then
has ccache ${FEATURES} && die "FEATURES=ccache doesn't work with ${PN}, bug #677876"
- [[ $(gcc-major-version) == 11 ]] && die "gcc 11 hangs when optimizing exploded image"
fi
}
@@ -212,6 +206,7 @@ src_configure() {
local myconf=(
--disable-ccache
+ --disable-warnings-as-errors{,-omr,-openj9}
--enable-full-docs=no
--with-boot-jdk="${JDK_HOME}"
--with-extra-cflags="${CFLAGS}"
@@ -237,7 +232,6 @@ src_configure() {
--enable-headless-only=$(usex headless-awt yes no)
$(tc-is-clang && echo "--with-toolchain-type=clang")
- --disable-warnings-as-errors{,-omr,-openj9}
--with-cmake
$(use_enable ddr)
)