summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-08-10 19:40:54 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-08-10 19:40:54 -0400
commit6621ebfddfa1d2a5667e7fc09efb676fe5dbc7e3 (patch)
tree83c2916464818685234efde06f2b32b45cb4c0e7
parent638f96ab4ca1c19d0bd32e538cbf77f6b11f40b1 (diff)
downloadgentoo-overlay-6621ebfddfa1d2a5667e7fc09efb676fe5dbc7e3.tar.xz
gentoo-overlay-6621ebfddfa1d2a5667e7fc09efb676fe5dbc7e3.zip
app-arch/7-zip: new package
-rw-r--r--app-arch/7-zip/7-zip-21.03_beta.ebuild53
-rw-r--r--app-arch/7-zip/Manifest1
-rw-r--r--virtual/7z/7z-0.ebuild11
3 files changed, 65 insertions, 0 deletions
diff --git a/app-arch/7-zip/7-zip-21.03_beta.ebuild b/app-arch/7-zip/7-zip-21.03_beta.ebuild
new file mode 100644
index 0000000..15ce7ee
--- /dev/null
+++ b/app-arch/7-zip/7-zip-21.03_beta.ebuild
@@ -0,0 +1,53 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+MY_PV=${PV%%_*}
+MY_PV=${MY_PV//./}
+
+DESCRIPTION="File archiver with a high compression ratio"
+HOMEPAGE="https://7-zip.org/"
+SRC_URI="https://7-zip.org/a/7z${MY_PV}-src.7z"
+
+LICENSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+BDEPEND="|| ( virtual/7z app-arch/libarchive app-arch/unar )"
+
+S=${WORKDIR}/7z${MY_PV}-src
+
+src_unpack() {
+ if command -v 7z >/dev/null 2>&1; then
+ 7z x ${DISTDIR}/7z${MY_PV}-src.7z -o$S || die
+ elif command -v bsdtar >/dev/null 2>&1; then
+ mkdir $S || die
+ bsdtar -C $S -xf ${DISTDIR}/7z${MY_PV}-src.7z || die
+ elif command -v unar >/dev/null 2>&1; then
+ unar -d $S ${DISTDIR}/7z${MY_PV}-src.7z || die
+ else
+ die "no 7z unpacker found"
+ fi
+}
+
+src_prepare() {
+ default
+ sed -i -e 's/-Werror//g' -e "s/-O2/$CFLAGS/" CPP/7zip/7zip_gcc.mak || die
+}
+
+src_compile() {
+ cd CPP/7zip/Bundles/Alone2
+ append-ldflags -Wl,-z,noexecstack
+ make -f ../../cmpl_gcc.mak
+}
+
+src_install() {
+ dobin CPP/7zip/Bundles/Alone2/b/g/7zz
+ dosym 7zz /usr/bin/7z
+ dodoc DOC/*
+}
diff --git a/app-arch/7-zip/Manifest b/app-arch/7-zip/Manifest
new file mode 100644
index 0000000..a855961
--- /dev/null
+++ b/app-arch/7-zip/Manifest
@@ -0,0 +1 @@
+DIST 7z2103-src.7z 1191375 BLAKE2B 002c20cbe0a47fbfce4c10f985972bf316d1e23c46e1047fbe98a9d4d27f1679d402cd6952c587fd6f78dd260896037896c328df9ae8a07865756c4693e93ad6 SHA512 6b2c00418333eb9a4f9d2ca23391dd644ed838b02832326a4c77065f762942d5daaa468f7330a8197b354a90aaf44f01d9412debb905f490351b54f63a3246df
diff --git a/virtual/7z/7z-0.ebuild b/virtual/7z/7z-0.ebuild
new file mode 100644
index 0000000..89a6b32
--- /dev/null
+++ b/virtual/7z/7z-0.ebuild
@@ -0,0 +1,11 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Virtual for /usr/bin/7z"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="|| ( app-arch/7-zip app-arch/p7zip )"