summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2022-02-28 17:57:21 -0500
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2022-02-28 17:57:21 -0500
commit8e2d45dcc43c36540a9841c4b6826ecc0d826fc5 (patch)
tree6782c9ac13163c355cc97ebf69a2e13c927a3616
parent62a029898127ecda9aed8c040d30cd81c9345318 (diff)
downloadgentoo-overlay-8e2d45dcc43c36540a9841c4b6826ecc0d826fc5.tar.xz
gentoo-overlay-8e2d45dcc43c36540a9841c4b6826ecc0d826fc5.zip
dev-dotnet/dotnet-runtime-bin: new package
-rw-r--r--dev-dotnet/dotnet-runtime-bin/Manifest6
-rw-r--r--dev-dotnet/dotnet-runtime-bin/dotnet-runtime-bin-3.1.22.ebuild60
-rw-r--r--dev-dotnet/dotnet-runtime-bin/dotnet-runtime-bin-6.0.2.ebuild60
3 files changed, 126 insertions, 0 deletions
diff --git a/dev-dotnet/dotnet-runtime-bin/Manifest b/dev-dotnet/dotnet-runtime-bin/Manifest
new file mode 100644
index 0000000..63f8893
--- /dev/null
+++ b/dev-dotnet/dotnet-runtime-bin/Manifest
@@ -0,0 +1,6 @@
+DIST dotnet-runtime-3.1.22-linux-arm.tar.gz 31839966 BLAKE2B 9c795546a050045514db22a65c620f44d2c072da423f52ba79afa8071b735a830658c3cc0c5c7e45f315fd8bc54feb3ff5424cdade4294f2b3e8efd08036c1e2 SHA512 2b189ab7fa7c2a42c155a270c59ec149b78194aa4c84c2e35b236e757ae73b7d0055bcade6d45e208f00e391fecb04fa5f71ef51a6a0851f29949517d33086fa
+DIST dotnet-runtime-3.1.22-linux-arm64.tar.gz 30278059 BLAKE2B e2a0bf1d87c2c279a6990a54be68e21491680ca6c3319fcc5620a526401ac31cbfd0ae5b000730631663f8ad4a43cb90447746dd00f9a039dbe901c0c63f74cf SHA512 ac7abb9273d1446ecacf536d2c59b01f23de81a21db035c98e53f63f64f8c3d252b613c24b7f9ea9e559f9c75385d93528ae0207aa7b734dba421c8871f312ed
+DIST dotnet-runtime-3.1.22-linux-x64.tar.gz 30440387 BLAKE2B 4f2adb7ab9af43c26d61f72fd36a91e03b3bbc66e4010a7cde8b3c84bb741ba53b7c18959582e694b0f94c83791cd6217dfb1b324693ee2d8dd427a28e287660 SHA512 4e32b45086fbd630622d20b0b2316d0c9bd66647b38ef1475c9bf8ef755bd60ec7eb8055a8de2bf89ed96e0460abc9e68f500189dd5437e21f2dfbd4fc71693e
+DIST dotnet-runtime-6.0.2-linux-arm.tar.gz 28617913 BLAKE2B 44cb8ab9496aaf54ab80a4e2265e16e3b4a2c1722c1cd2a830293b744c824ba4c26f451796e25d10f400a5188081e7cb298f0ec5c9b0e5338b0183d70db322a4 SHA512 0628b24971e05ac69c39a6526f6ef90ef65e72071a4be430e028958c33e484e7b95584a4a23716dd8eb70592b8b29266bfbd18c730f39aad8556ee87ca316aa7
+DIST dotnet-runtime-6.0.2-linux-arm64.tar.gz 28375985 BLAKE2B 2114f6113cfca865f6d624a7362f0e66478b0dbd3dbb634b3b36a0dba2893232f1e28eb3364b8b5e3dd4899e87ce2dec991b11d671e27f37b3c67a32f93775a2 SHA512 5cca54e18332b3297960f21a1b523382e2e7ad6fff477548ac0964451a7db5fadb2acda7cc39bceab184250bd9f81f84162aff4a2ec1d2c4ad278985ed157f4d
+DIST dotnet-runtime-6.0.2-linux-x64.tar.gz 30671545 BLAKE2B 9e17c45a1635196a10c64fa3401ec64a15c8221d2bbd818219ea797046b0f25f29a50390b0a3eb1165abbd8b2bc7e8c3fdd63f4633eaa64dadfc4372a4418d37 SHA512 fa42a686122655a2a7dedc2415bdd618ff06b0a57132d7d98ad79f25c40f3f9edb953ef1ac93fa1a1ff64cffb4c5276dd7586ba5d16c5a7960913e1c5dd646a4
diff --git a/dev-dotnet/dotnet-runtime-bin/dotnet-runtime-bin-3.1.22.ebuild b/dev-dotnet/dotnet-runtime-bin/dotnet-runtime-bin-3.1.22.ebuild
new file mode 100644
index 0000000..12d4b2a
--- /dev/null
+++ b/dev-dotnet/dotnet-runtime-bin/dotnet-runtime-bin-3.1.22.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION=".NET is a free, cross-platform, open-source developer platform"
+HOMEPAGE="https://dotnet.microsoft.com/"
+LICENSE="MIT"
+
+SRC_URI="
+amd64? ( https://dotnetcli.azureedge.net/dotnet/Runtime/${PV}/dotnet-runtime-${PV}-linux-x64.tar.gz )
+arm? ( https://dotnetcli.azureedge.net/dotnet/Runtime/${PV}/dotnet-runtime-${PV}-linux-arm.tar.gz )
+arm64? ( https://dotnetcli.azureedge.net/dotnet/Runtime/${PV}/dotnet-runtime-${PV}-linux-arm64.tar.gz )
+"
+
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="dotnet-symlink kerberos lttng"
+REQUIRED_USE="elibc_glibc"
+QA_PREBUILT="*"
+RESTRICT="splitdebug"
+RDEPEND="
+ kerberos? ( app-crypt/mit-krb5:0/0 )
+ lttng? ( dev-util/lttng-ust:0 )
+ sys-libs/zlib:0/1
+ dotnet-symlink? (
+ !dev-dotnet/dotnet-sdk[dotnet-symlink(+)]
+ !dev-dotnet/dotnet-sdk-bin[dotnet-symlink(+)]
+ !dev-dotnet/dotnet-runtime[dotnet-symlink(+)]
+ )
+"
+
+S=${WORKDIR}
+
+delete() {
+ local x
+ x=$(find . -name "$1" -print -delete) && [ -n "$x" ]
+}
+
+src_compile() {
+ use kerberos || delete System.Net.Security.Native.so || die
+ use lttng || delete libcoreclrtraceptprovider.so || die
+}
+
+src_install() {
+ local dest="opt/${PN}-${SLOT}"
+ dodir "${dest%/*}"
+
+ { mv "${S}" "${ED}/${dest}" && mkdir "${S}" && fperms 0755 "/${dest}"; } || die
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet-bin-${SLOT}"
+
+ if use dotnet-symlink; then
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet"
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet-${SLOT}"
+
+ # set an env-variable for 3rd party tools
+ echo "DOTNET_ROOT=/${dest}" > "${T}/90${PN}-${SLOT}" || die
+ doenvd "${T}/90${PN}-${SLOT}"
+ fi
+}
diff --git a/dev-dotnet/dotnet-runtime-bin/dotnet-runtime-bin-6.0.2.ebuild b/dev-dotnet/dotnet-runtime-bin/dotnet-runtime-bin-6.0.2.ebuild
new file mode 100644
index 0000000..fb09294
--- /dev/null
+++ b/dev-dotnet/dotnet-runtime-bin/dotnet-runtime-bin-6.0.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION=".NET is a free, cross-platform, open-source developer platform"
+HOMEPAGE="https://dotnet.microsoft.com/"
+LICENSE="MIT"
+
+SRC_URI="
+amd64? ( https://dotnetcli.azureedge.net/dotnet/Runtime/${PV}/dotnet-runtime-${PV}-linux-x64.tar.gz )
+arm? ( https://dotnetcli.azureedge.net/dotnet/Runtime/${PV}/dotnet-runtime-${PV}-linux-arm.tar.gz )
+arm64? ( https://dotnetcli.azureedge.net/dotnet/Runtime/${PV}/dotnet-runtime-${PV}-linux-arm64.tar.gz )
+"
+
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64"
+IUSE="+dotnet-symlink kerberos lttng"
+REQUIRED_USE="elibc_glibc"
+QA_PREBUILT="*"
+RESTRICT="splitdebug"
+RDEPEND="
+ kerberos? ( app-crypt/mit-krb5:0/0 )
+ lttng? ( dev-util/lttng-ust:0 )
+ sys-libs/zlib:0/1
+ dotnet-symlink? (
+ !dev-dotnet/dotnet-sdk[dotnet-symlink(+)]
+ !dev-dotnet/dotnet-sdk-bin[dotnet-symlink(+)]
+ !dev-dotnet/dotnet-runtime[dotnet-symlink(+)]
+ )
+"
+
+S=${WORKDIR}
+
+delete() {
+ local x
+ x=$(find . -name "$1" -print -delete) && [ -n "$x" ]
+}
+
+src_compile() {
+ use kerberos || delete libSystem.Net.Security.Native.so || die
+ use lttng || delete libcoreclrtraceptprovider.so || die
+}
+
+src_install() {
+ local dest="opt/${PN}-${SLOT}"
+ dodir "${dest%/*}"
+
+ { mv "${S}" "${ED}/${dest}" && mkdir "${S}" && fperms 0755 "/${dest}"; } || die
+
+ if use dotnet-symlink; then
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet"
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet-${SLOT}"
+ dosym "../../${dest}/dotnet" "/usr/bin/dotnet-bin-${SLOT}"
+
+ # set an env-variable for 3rd party tools
+ echo "DOTNET_ROOT=/${dest}" > "${T}/90${PN}-${SLOT}" || die
+ doenvd "${T}/90${PN}-${SLOT}"
+ fi
+}