summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-12-04 15:56:47 -0500
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-12-04 15:56:47 -0500
commit8e8c08cf183fac42502071bcdc40b3a6722a1e5b (patch)
treefba2c3a0092e2fdff6ca81cc3cf76199a7c3906c
parenta333270ed05f9591529eb6f04fc5c7e6f792e48b (diff)
downloadgentoo-overlay-8e8c08cf183fac42502071bcdc40b3a6722a1e5b.tar.xz
gentoo-overlay-8e8c08cf183fac42502071bcdc40b3a6722a1e5b.zip
dev-python/fs: add
bump to prerelease PR to fix fonttools tests on 3.9
-rw-r--r--dev-python/fs/Manifest1
-rw-r--r--dev-python/fs/fs-2.4.12_pre.ebuild47
-rw-r--r--dev-python/fs/metadata.xml18
3 files changed, 66 insertions, 0 deletions
diff --git a/dev-python/fs/Manifest b/dev-python/fs/Manifest
new file mode 100644
index 0000000..72a6052
--- /dev/null
+++ b/dev-python/fs/Manifest
@@ -0,0 +1 @@
+DIST fs-2.4.12_pre.tar.gz 165194 BLAKE2B 399f7a882943f2235d4f89122db4f7e4623a8a75150853fc42335f348b8d06718ff28b52c936584170c05c67ebfbd2bacf38ed57335e79d98ecd1587e6c121e0 SHA512 2d16bd3349f84fb3706bf588d1ef7dd3cc2d7c4185b22b29b2dcf2db4d33a6bffa6eaa336456c1395e21fb77a5c986c6938dcabc326227c0f835c17538edeadf
diff --git a/dev-python/fs/fs-2.4.12_pre.ebuild b/dev-python/fs/fs-2.4.12_pre.ebuild
new file mode 100644
index 0000000..1efebb3
--- /dev/null
+++ b/dev-python/fs/fs-2.4.12_pre.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1 optfeature vcs-snapshot
+
+MY_PN="pyfilesystem2"
+
+DESCRIPTION="Filesystem abstraction layer"
+HOMEPAGE="
+ https://pypi.org/project/fs/
+ https://docs.pyfilesystem.org
+ https://www.willmcgugan.com/tag/fs/
+"
+# Tests from the PyPI tarball are broken
+# https://github.com/PyFilesystem/pyfilesystem2/issues/364
+SRC_URI="https://github.com/PyFilesystem/pyfilesystem2/archive/25503697228919780b5bdea7c5ca865affdda541.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/appdirs-1.4.3[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pyftpdlib[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "S3 support" dev-python/boto
+ optfeature "SFTP support" dev-python/paramiko
+ optfeature "Browser support" dev-python/wxpython
+}
diff --git a/dev-python/fs/metadata.xml b/dev-python/fs/metadata.xml
new file mode 100644
index 0000000..6fb9cac
--- /dev/null
+++ b/dev-python/fs/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">fs</remote-id>
+ <remote-id type="github">PyFilesystem/pyfilesystem2</remote-id>
+ <doc>https://docs.pyfilesystem.org/</doc>
+ <maintainer status="unknown">
+ <email>will@willmcgugan.com</email>
+ <name>Will McGugan</name>
+ </maintainer>
+ </upstream>
+</pkgmetadata>