summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-01-25 07:33:24 -0500
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-01-25 07:33:24 -0500
commitb78f8cd5c801ce67a9d4650000329ac49ce8961f (patch)
tree379aaa10a2eb34349fc5909dc0d60121aadbc5ff
parentafb9284f1b14866d911748d0932347763cbf11de (diff)
downloadgentoo-overlay-b78f8cd5c801ce67a9d4650000329ac49ce8961f.tar.xz
gentoo-overlay-b78f8cd5c801ce67a9d4650000329ac49ce8961f.zip
*/*: fixes
-rw-r--r--dev-qt/qtgui/Manifest2
-rw-r--r--dev-qt/qtgui/qtgui-5.15.1-r1.ebuild183
-rw-r--r--dev-qt/qtgui/qtgui-5.15.2-r2.ebuild (renamed from dev-qt/qtgui/qtgui-5.15.2-r1.ebuild)10
-rw-r--r--net-misc/wayvnc/Manifest1
-rw-r--r--virtual/notification-daemon/metadata.xml4
-rw-r--r--virtual/notification-daemon/notification-daemon-1.ebuild30
-rw-r--r--x11-libs/cairo/Manifest1
-rw-r--r--x11-libs/cairo/cairo-1.16.0-r5.ebuild136
-rw-r--r--x11-libs/cairo/cairo-9999.ebuild133
-rw-r--r--x11-libs/cairo/files/cairo-1.12.18-disable-test-suite.patch15
-rw-r--r--x11-libs/cairo/files/cairo-1.16.0-binutils-2.34.patch20
-rw-r--r--x11-libs/cairo/files/cairo-1.16.0-ft-Use-FT_Done_MM_Var-instead-of-free-when-available.patch30
-rw-r--r--x11-libs/cairo/files/cairo-1.16.0-pdf-add-missing-flush.patch29
-rw-r--r--x11-libs/cairo/files/cairo-1.16.0-strings.patch19
-rw-r--r--x11-libs/cairo/files/cairo-respect-fontconfig.patch13
-rw-r--r--x11-libs/cairo/metadata.xml14
16 files changed, 8 insertions, 632 deletions
diff --git a/dev-qt/qtgui/Manifest b/dev-qt/qtgui/Manifest
index 5f276c2..c298c0a 100644
--- a/dev-qt/qtgui/Manifest
+++ b/dev-qt/qtgui/Manifest
@@ -1,2 +1,2 @@
-DIST qtbase-everywhere-src-5.15.1.tar.xz 50153132 BLAKE2B 5a8cbbf8d44c7affc8ee43db04bd024bb529e0707b1feee2c7ae439cdf1331b1cf3e89b84c6a6f5bab3ec34025fbd634a8f4d259bd64ece172f288500e5b59e6 SHA512 40b687c046b25a6717834ffe2616ee4f373d75214ec1c7e3a26502cd0cde9f0a872eaee99f06c54c7a3625ae85df5cdd3a3b54a160e8e37c7cfeb5800d026fe4
+DIST qtbase-5.15.2-gcc11.patch.xz 1208 BLAKE2B a2e5764b723adda991eca5b84cf8e15437a4832febd12e3c93cdc394931af666e17c01e229e9be7e0efc446a955cc26388c0f93cadfcabd93cc6b6f03bb41eb0 SHA512 da3a41ea5d9573a029946d26b26d51d6dce9c8b91db6d78ca71d8343d3ceb5010d21750dcb45abb663e227b5f068985ff4ed51da07efd17c64cc8dd5aef8f3e4
DIST qtbase-everywhere-src-5.15.2.tar.xz 50179672 BLAKE2B 0e4bdaab43cf59664bde89f87ea260c39acc2ef866d8629d41d9c326cab0ab68bcd943c86a472ae74bc9fb0b7ad50795ccb66275bb6b77d1fcf0a38b5662cb42 SHA512 a549bfaf867d746ff744ab224eb65ac1bdcdac7e8457dfa379941b2b225a90442fcfc1e1175b9afb1f169468f8130b7ab917c67be67156520a4bfb5c92d304f9
diff --git a/dev-qt/qtgui/qtgui-5.15.1-r1.ebuild b/dev-qt/qtgui/qtgui-5.15.1-r1.ebuild
deleted file mode 100644
index 4425456..0000000
--- a/dev-qt/qtgui/qtgui-5.15.1-r1.ebuild
+++ /dev/null
@@ -1,183 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-QT5_MODULE="qtbase"
-inherit qt5-build
-
-DESCRIPTION="The GUI module and platform plugins for the Qt5 framework"
-SLOT=5/$(ver_cut 1-3) # bug 707658
-
-if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~sparc x86"
-fi
-
-# TODO: linuxfb
-
-IUSE="accessibility dbus egl eglfs evdev +gif gles2-only ibus jpeg
- +libinput +png tslib tuio +udev vnc vulkan wayland +X"
-REQUIRED_USE="
- accessibility? ( dbus X )
- eglfs? ( egl )
- ibus? ( dbus )
- libinput? ( udev )
- X? ( gles2-only? ( egl ) )
-"
-
-RDEPEND="
- dev-libs/glib:2
- ~dev-qt/qtcore-${PV}:5=
- dev-util/gtk-update-icon-cache
- media-libs/fontconfig
- >=media-libs/freetype-2.6.1:2
- >=media-libs/harfbuzz-1.6.0:=
- sys-libs/zlib:=
- dbus? ( ~dev-qt/qtdbus-${PV} )
- egl? ( media-libs/mesa[egl] )
- eglfs? (
- media-libs/mesa[gbm]
- x11-libs/libdrm
- )
- evdev? ( sys-libs/mtdev )
- gles2-only? ( media-libs/mesa[gles2] )
- !gles2-only? ( virtual/opengl )
- jpeg? ( virtual/jpeg:0 )
- libinput? (
- dev-libs/libinput:=
- >=x11-libs/libxkbcommon-0.5.0
- )
- png? ( media-libs/libpng:0= )
- tslib? ( >=x11-libs/tslib-1.21 )
- tuio? ( ~dev-qt/qtnetwork-${PV} )
- udev? ( virtual/libudev:= )
- vnc? ( ~dev-qt/qtnetwork-${PV} )
- vulkan? ( dev-util/vulkan-headers )
- X? (
- x11-libs/libICE
- x11-libs/libSM
- x11-libs/libX11
- >=x11-libs/libxcb-1.12:=[xkb]
- >=x11-libs/libxkbcommon-0.5.0[X]
- x11-libs/xcb-util-image
- x11-libs/xcb-util-keysyms
- x11-libs/xcb-util-renderutil
- x11-libs/xcb-util-wm
- )
-"
-DEPEND="${RDEPEND}
- evdev? ( sys-kernel/linux-headers )
- udev? ( sys-kernel/linux-headers )
-"
-PDEPEND="
- ibus? ( app-i18n/ibus )
- wayland? ( ~dev-qt/qtwayland-${PV} )
-"
-
-QT5_TARGET_SUBDIRS=(
- src/tools/qvkgen
- src/gui
- src/openglextensions
- src/platformheaders
- src/platformsupport
- src/plugins/generic
- src/plugins/imageformats
- src/plugins/platforms
- src/plugins/platforminputcontexts
-)
-
-QT5_GENTOO_CONFIG=(
- accessibility:accessibility-atspi-bridge
- egl:egl:
- eglfs:eglfs:
- eglfs:eglfs_egldevice:
- eglfs:eglfs_gbm:
- evdev:evdev:
- evdev:mtdev:
- :fontconfig:
- :system-freetype:FREETYPE
- !:no-freetype:
- !gif:no-gif:
- gles2-only::OPENGL_ES
- gles2-only:opengles2:OPENGL_ES_2
- !:no-gui:
- :system-harfbuzz:
- !:no-harfbuzz:
- jpeg:system-jpeg:IMAGEFORMAT_JPEG
- !jpeg:no-jpeg:
- libinput
- libinput:xkbcommon:
- :opengl
- png:png:
- png:system-png:IMAGEFORMAT_PNG
- !png:no-png:
- tslib:tslib:
- udev:libudev:
- vulkan:vulkan:
- X:xcb:
- X:xcb-glx:
- X:xcb-plugin:
- X:xcb-render:
- X:xcb-sm:
- X:xcb-xlib:
- X:xcb-xinput:
-)
-
-QT5_GENTOO_PRIVATE_CONFIG=(
- :gui
-)
-
-PATCHES=(
- "${FILESDIR}/qt-5.12-gcc-avx2.patch" # bug 672946
- "${FILESDIR}/${PN}-5.14.1-cmake-macro-backward-compat.patch" # bug 703306
-)
-
-src_prepare() {
- # don't add -O3 to CXXFLAGS, bug 549140
- sed -i -e '/CONFIG\s*+=/s/optimize_full//' src/gui/gui.pro || die
-
- # egl_x11 is activated when both egl and X are enabled
- use egl && QT5_GENTOO_CONFIG+=(X:egl_x11:) || QT5_GENTOO_CONFIG+=(egl:egl_x11:)
-
- qt_use_disable_config dbus dbus \
- src/platformsupport/themes/genericunix/genericunix.pri
-
- qt_use_disable_config tuio tuiotouch src/plugins/generic/generic.pro
-
- qt_use_disable_mod ibus dbus \
- src/plugins/platforminputcontexts/platforminputcontexts.pro
-
- use vnc || sed -i -e '/SUBDIRS += vnc/d' \
- src/plugins/platforms/platforms.pro || die
-
- qt5-build_src_prepare
-}
-
-src_configure() {
- local myconf=(
- $(usex dbus -dbus-linked '')
- $(qt_use egl)
- $(qt_use eglfs)
- $(usex eglfs '-gbm -kms' '')
- $(qt_use evdev)
- $(qt_use evdev mtdev)
- -fontconfig
- -system-freetype
- $(usex gif '' -no-gif)
- -gui
- -system-harfbuzz
- $(qt_use jpeg libjpeg system)
- $(qt_use libinput)
- -opengl $(usex gles2-only es2 desktop)
- $(qt_use png libpng system)
- $(qt_use tslib)
- $(qt_use udev libudev)
- $(qt_use vulkan)
- $(qt_use X xcb)
- $(usex X '-xcb-xlib' '')
- )
- if use libinput || use X; then
- myconf+=( -xkbcommon )
- fi
- qt5-build_src_configure
-}
diff --git a/dev-qt/qtgui/qtgui-5.15.2-r1.ebuild b/dev-qt/qtgui/qtgui-5.15.2-r2.ebuild
index 4e04a48..720dcd1 100644
--- a/dev-qt/qtgui/qtgui-5.15.2-r1.ebuild
+++ b/dev-qt/qtgui/qtgui-5.15.2-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -7,17 +7,19 @@ QT5_MODULE="qtbase"
inherit qt5-build
DESCRIPTION="The GUI module and platform plugins for the Qt5 framework"
+SRC_URI+=" https://dev.gentoo.org/~asturm/distfiles/qtbase-${PV}-gcc11.patch.xz"
+
SLOT=5/$(ver_cut 1-3) # bug 707658
if [[ ${QT5_BUILD_TYPE} == release ]]; then
- KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+ KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 ~sparc x86"
fi
# TODO: linuxfb
-
IUSE="accessibility dbus egl eglfs evdev +gif gles2-only ibus jpeg
+libinput +png tslib tuio +udev vnc vulkan wayland +X"
REQUIRED_USE="
+ || ( eglfs X )
accessibility? ( dbus X )
eglfs? ( egl )
ibus? ( dbus )
@@ -133,6 +135,8 @@ QT5_GENTOO_PRIVATE_CONFIG=(
PATCHES=(
"${FILESDIR}/qt-5.12-gcc-avx2.patch" # bug 672946
"${FILESDIR}/${PN}-5.14.1-cmake-macro-backward-compat.patch" # bug 703306
+ "${FILESDIR}/${P}-bogus-xcb-util-dep.patch" # QTBUG-86287, QTBUG-88688
+ "${WORKDIR}"/qtbase-${PV}-gcc11.patch # bug 764038
)
src_prepare() {
diff --git a/net-misc/wayvnc/Manifest b/net-misc/wayvnc/Manifest
index 213b529..1bc4a3e 100644
--- a/net-misc/wayvnc/Manifest
+++ b/net-misc/wayvnc/Manifest
@@ -1,2 +1 @@
-DIST wayvnc-0.3.0.tar.gz 49516 BLAKE2B 0db1a10454bf6a12a2f0e484dca3e5ffc68e7b4386e25b7eeffbcddb332e1efa9f6af389a7c10f0348bf2f53639959aba19ebdd1c90bef73c571e4cf69894f29 SHA512 a4a06a3532d11eac0b05953f166ffd058af0c31524233333dfb78321dd2f059c1a27bf0b68d8662b1e1108907161711435a31b0da005f851773de1af6351b065
DIST wayvnc-0.4.0.tar.gz 52157 BLAKE2B 7c8456d5136ef361ca7dd72ffa7501514eeb7a61ae1777a02391fb7fceea6b020d68951300ab76254f2afd5e2610fe66ce0f461d18dc38522706691438f4620e SHA512 b8f1af24213077dc6126ae1f613b9cdeed8f365f9d1989a5b053563f0eb4bc49921e746e0f1026fe0e02bfeea23b912798678a5a337a052d977aa04496a75570
diff --git a/virtual/notification-daemon/metadata.xml b/virtual/notification-daemon/metadata.xml
deleted file mode 100644
index 097975e..0000000
--- a/virtual/notification-daemon/metadata.xml
+++ /dev/null
@@ -1,4 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-</pkgmetadata>
diff --git a/virtual/notification-daemon/notification-daemon-1.ebuild b/virtual/notification-daemon/notification-daemon-1.ebuild
deleted file mode 100644
index ed472a5..0000000
--- a/virtual/notification-daemon/notification-daemon-1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="Virtual for notification daemon dbus service"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
-IUSE="gnome kde wayland"
-
-RDEPEND="
- gnome? ( || ( x11-misc/notification-daemon
- gnome-base/gnome-shell ) )
- kde? ( kde-plasma/plasma-workspace )
- !gnome? ( !kde? ( || (
- wayland? (
- gui-apps/mako
- )
- x11-misc/notification-daemon
- gnome-extra/cinnamon
- xfce-extra/xfce4-notifyd
- x11-misc/notify-osd
- x11-misc/dunst
- >=x11-wm/awesome-3.4.4
- x11-wm/enlightenment[enlightenment_modules_notification]
- x11-wm/enlightenment[e_modules_notification]
- x11-misc/mate-notification-daemon
- lxqt-base/lxqt-notificationd
- net-misc/eventd[notification]
- ) ) )"
diff --git a/x11-libs/cairo/Manifest b/x11-libs/cairo/Manifest
deleted file mode 100644
index a9d5249..0000000
--- a/x11-libs/cairo/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST cairo-1.16.0.tar.xz 41997432 BLAKE2B aa37edf7fdf0c952484fd0adc9281724227db93958d6e4919216b30e9017fab670bc2340e3b975737080f1f67dec24025fe0e4680e275ab7703cfb9235eb1fe0 SHA512 9eb27c4cf01c0b8b56f2e15e651f6d4e52c99d0005875546405b64f1132aed12fbf84727273f493d84056a13105e065009d89e94a8bfaf2be2649e232b82377f
diff --git a/x11-libs/cairo/cairo-1.16.0-r5.ebuild b/x11-libs/cairo/cairo-1.16.0-r5.ebuild
deleted file mode 100644
index b951785..0000000
--- a/x11-libs/cairo/cairo-1.16.0-r5.ebuild
+++ /dev/null
@@ -1,136 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic autotools multilib-minimal
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://gitlab.freedesktop.org/cairo/cairo.git"
- SRC_URI=""
-else
- SRC_URI="https://www.cairographics.org/releases/${P}.tar.xz"
- KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-DESCRIPTION="A vector graphics library with cross-device output support"
-HOMEPAGE="https://www.cairographics.org/ https://gitlab.freedesktop.org/cairo/cairo"
-LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
-SLOT="0"
-IUSE="X aqua debug gles2-only +glib lzo opengl static-libs +svg utils valgrind"
-# gtk-doc regeneration doesn't seem to work with out-of-source builds
-#[[ ${PV} == *9999* ]] && IUSE="${IUSE} doc" # API docs are provided in tarball, no need to regenerate
-
-# Test causes a circular depend on gtk+... since gtk+ needs cairo but test needs gtk+ so we need to block it
-RESTRICT="test"
-
-BDEPEND="
- virtual/pkgconfig
- >=sys-devel/libtool-2"
-RDEPEND="
- >=media-libs/fontconfig-2.10.92[${MULTILIB_USEDEP}]
- >=media-libs/freetype-2.5.0.1:2[${MULTILIB_USEDEP}]
- >=media-libs/libpng-1.6.10:0=[${MULTILIB_USEDEP}]
- sys-libs/binutils-libs:0=[${MULTILIB_USEDEP}]
- >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
- >=x11-libs/pixman-0.32.4[${MULTILIB_USEDEP}]
- gles2-only? ( >=media-libs/mesa-9.1.6[gles2,${MULTILIB_USEDEP}] )
- glib? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
- lzo? ( >=dev-libs/lzo-2.06-r1[${MULTILIB_USEDEP}] )
- opengl? ( >=media-libs/mesa-9.1.6[egl,X(+),${MULTILIB_USEDEP}] )
- X? (
- >=x11-libs/libXrender-0.9.8[${MULTILIB_USEDEP}]
- >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
- >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
- >=x11-libs/libxcb-1.9.1[${MULTILIB_USEDEP}]
- )"
-DEPEND="${RDEPEND}
- X? ( x11-base/xorg-proto )"
-#[[ ${PV} == *9999* ]] && DEPEND="${DEPEND}
-# doc? (
-# >=dev-util/gtk-doc-1.6
-# ~app-text/docbook-xml-dtd-4.2
-# )"
-
-REQUIRED_USE="
- gles2-only? ( !opengl )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.12.18-disable-test-suite.patch
- "${FILESDIR}"/${PN}-respect-fontconfig.patch
- "${FILESDIR}"/${P}-pdf-add-missing-flush.patch
- "${FILESDIR}"/${P}-ft-Use-FT_Done_MM_Var-instead-of-free-when-available.patch
- "${FILESDIR}"/${P}-strings.patch
-)
-
-src_prepare() {
- default
-
- if has_version ">=sys-libs/binutils-libs-2.34"; then
- eapply "${FILESDIR}"/${PN}-1.16.0-binutils-2.34.patch
- fi
-
- # tests and perf tools require X, bug #483574
- if ! use X; then
- sed -e '/^SUBDIRS/ s#boilerplate test perf# #' -i Makefile.am || die
- fi
-
- # Slightly messed build system YAY
- if [[ ${PV} == *9999* ]]; then
- touch boilerplate/Makefile.am.features
- touch src/Makefile.am.features
- touch ChangeLog
- fi
-
- eautoreconf
-}
-
-multilib_src_configure() {
- local myopts
-
- [[ ${CHOST} == *-interix* ]] && append-flags -D_REENTRANT
-
- use elibc_FreeBSD && myopts+=" --disable-symbol-lookup"
-
- # [[ ${PV} == *9999* ]] && myopts+=" $(use_enable doc gtk-doc)"
-
- ECONF_SOURCE="${S}" \
- ac_cv_lib_lzo2_lzo2a_decompress=$(usex lzo) \
- econf \
- $(use_with X x) \
- $(use_enable X tee) \
- $(use_enable X xlib) \
- $(use_enable X xlib-xrender) \
- $(use_enable X xcb) \
- $(use_enable X xcb-shm) \
- $(use_enable aqua quartz) \
- $(use_enable aqua quartz-image) \
- $(use_enable debug test-surfaces) \
- $(use_enable gles2-only glesv2) \
- $(use_enable glib gobject) \
- $(use_enable opengl gl) \
- $(use_enable static-libs static) \
- $(use_enable svg) \
- $(use_enable utils trace) \
- $(use_enable valgrind) \
- --enable-ft \
- --enable-interpreter \
- --enable-pdf \
- --enable-png \
- --enable-ps \
- --enable-script \
- --disable-drm \
- --disable-directfb \
- --disable-gallium \
- --disable-qt \
- --disable-vg \
- --disable-xlib-xcb \
- ${myopts}
-}
-
-multilib_src_install_all() {
- find "${D}" -name '*.la' -delete || die
- einstalldocs
-}
diff --git a/x11-libs/cairo/cairo-9999.ebuild b/x11-libs/cairo/cairo-9999.ebuild
deleted file mode 100644
index 6a8c6b7..0000000
--- a/x11-libs/cairo/cairo-9999.ebuild
+++ /dev/null
@@ -1,133 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic autotools multilib-minimal
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://gitlab.freedesktop.org/cairo/cairo.git"
- SRC_URI=""
-else
- SRC_URI="https://www.cairographics.org/releases/${P}.tar.xz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-fi
-
-DESCRIPTION="A vector graphics library with cross-device output support"
-HOMEPAGE="https://www.cairographics.org/ https://gitlab.freedesktop.org/cairo/cairo"
-LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
-SLOT="0"
-IUSE="X aqua debug gles2-only +glib lzo opengl static-libs +svg utils valgrind"
-# gtk-doc regeneration doesn't seem to work with out-of-source builds
-#[[ ${PV} == *9999* ]] && IUSE="${IUSE} doc" # API docs are provided in tarball, no need to regenerate
-
-# Test causes a circular depend on gtk+... since gtk+ needs cairo but test needs gtk+ so we need to block it
-RESTRICT="test"
-
-BDEPEND="
- virtual/pkgconfig
- >=sys-devel/libtool-2"
-RDEPEND="
- >=media-libs/fontconfig-2.10.92[${MULTILIB_USEDEP}]
- >=media-libs/freetype-2.5.0.1:2[${MULTILIB_USEDEP}]
- >=media-libs/libpng-1.6.10:0=[${MULTILIB_USEDEP}]
- sys-libs/binutils-libs:0=[${MULTILIB_USEDEP}]
- >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
- >=x11-libs/pixman-0.32.4[${MULTILIB_USEDEP}]
- gles2-only? ( >=media-libs/mesa-9.1.6[gles2,${MULTILIB_USEDEP}] )
- glib? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
- lzo? ( >=dev-libs/lzo-2.06-r1[${MULTILIB_USEDEP}] )
- opengl? ( >=media-libs/mesa-9.1.6[egl,X(+),${MULTILIB_USEDEP}] )
- X? (
- >=x11-libs/libXrender-0.9.8[${MULTILIB_USEDEP}]
- >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
- >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
- >=x11-libs/libxcb-1.9.1[${MULTILIB_USEDEP}]
- )"
-DEPEND="${RDEPEND}
- X? ( x11-base/xorg-proto )"
-#[[ ${PV} == *9999* ]] && DEPEND="${DEPEND}
-# doc? (
-# >=dev-util/gtk-doc-1.6
-# ~app-text/docbook-xml-dtd-4.2
-# )"
-
-REQUIRED_USE="
- gles2-only? ( !opengl )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.12.18-disable-test-suite.patch
- "${FILESDIR}"/${PN}-respect-fontconfig.patch
-)
-
-src_prepare() {
- default
-
- if has_version ">=sys-libs/binutils-libs-2.34"; then
- eapply "${FILESDIR}"/${PN}-1.16.0-binutils-2.34.patch
- fi
-
- # tests and perf tools require X, bug #483574
- if ! use X; then
- sed -e '/^SUBDIRS/ s#boilerplate test perf# #' -i Makefile.am || die
- fi
-
- # Slightly messed build system YAY
- if [[ ${PV} == *9999* ]]; then
- touch boilerplate/Makefile.am.features
- touch src/Makefile.am.features
- touch ChangeLog
- fi
-
- eautoreconf
-}
-
-multilib_src_configure() {
- local myopts
-
- [[ ${CHOST} == *-interix* ]] && append-flags -D_REENTRANT
-
- use elibc_FreeBSD && myopts+=" --disable-symbol-lookup"
-
- # [[ ${PV} == *9999* ]] && myopts+=" $(use_enable doc gtk-doc)"
-
- ECONF_SOURCE="${S}" \
- ac_cv_lib_lzo2_lzo2a_decompress=$(usex lzo) \
- econf \
- $(use_with X x) \
- $(use_enable X tee) \
- $(use_enable X xlib) \
- $(use_enable X xlib-xrender) \
- $(use_enable X xcb) \
- $(use_enable X xcb-shm) \
- $(use_enable aqua quartz) \
- $(use_enable aqua quartz-image) \
- $(use_enable debug test-surfaces) \
- $(use_enable gles2-only glesv2) \
- $(use_enable glib gobject) \
- $(use_enable opengl gl) \
- $(use_enable static-libs static) \
- $(use_enable svg) \
- $(use_enable utils trace) \
- $(use_enable valgrind) \
- --enable-ft \
- --enable-interpreter \
- --enable-pdf \
- --enable-png \
- --enable-ps \
- --enable-script \
- --disable-drm \
- --disable-directfb \
- --disable-gallium \
- --disable-qt \
- --disable-vg \
- --disable-xlib-xcb \
- ${myopts}
-}
-
-multilib_src_install_all() {
- find "${D}" -name '*.la' -delete || die
- einstalldocs
-}
diff --git a/x11-libs/cairo/files/cairo-1.12.18-disable-test-suite.patch b/x11-libs/cairo/files/cairo-1.12.18-disable-test-suite.patch
deleted file mode 100644
index 6822121..0000000
--- a/x11-libs/cairo/files/cairo-1.12.18-disable-test-suite.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/Makefile.am b/Makefile.am
-index 03fa352..7e11d24 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -18,10 +18,6 @@ ACLOCAL_AMFLAGS = -I build ${ACLOCAL_FLAGS}
-
- DIST_SUBDIRS = src doc util boilerplate test perf
- SUBDIRS = src doc util
--# libpng is required for our test programs
--if CAIRO_HAS_PNG_FUNCTIONS
--SUBDIRS += boilerplate test perf
--endif
-
- configure: cairo-version.h
-
diff --git a/x11-libs/cairo/files/cairo-1.16.0-binutils-2.34.patch b/x11-libs/cairo/files/cairo-1.16.0-binutils-2.34.patch
deleted file mode 100644
index 03daac0..0000000
--- a/x11-libs/cairo/files/cairo-1.16.0-binutils-2.34.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/util/cairo-trace/lookup-symbol.c
-+++ b/util/cairo-trace/lookup-symbol.c
-@@ -145,14 +145,14 @@ find_address_in_section (bfd *abfd,
- if (symbol->found)
- return;
-
-- if ((bfd_get_section_flags (symtab->bfd, section) & SEC_ALLOC) == 0)
-+ if ((bfd_section_flags (section) & SEC_ALLOC) == 0)
- return;
-
-- vma = bfd_get_section_vma (symtab->bfd, section);
-+ vma = bfd_section_vma (section);
- if (symbol->pc < vma)
- return;
-
-- size = bfd_section_size (symtab->bfd, section);
-+ size = bfd_section_size (section);
- if (symbol->pc >= vma + size)
- return;
-
diff --git a/x11-libs/cairo/files/cairo-1.16.0-ft-Use-FT_Done_MM_Var-instead-of-free-when-available.patch b/x11-libs/cairo/files/cairo-1.16.0-ft-Use-FT_Done_MM_Var-instead-of-free-when-available.patch
deleted file mode 100644
index 3709c5a..0000000
--- a/x11-libs/cairo/files/cairo-1.16.0-ft-Use-FT_Done_MM_Var-instead-of-free-when-available.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 90e85c2493fdfa3551f202ff10282463f1e36645 Mon Sep 17 00:00:00 2001
-From: Carlos Garcia Campos <cgarcia@igalia.com>
-Date: Mon, 19 Nov 2018 12:33:07 +0100
-Subject: [PATCH] ft: Use FT_Done_MM_Var instead of free when available in
- cairo_ft_apply_variations
-
-Fixes a crash when using freetype >= 2.9
----
- src/cairo-ft-font.c | 4 ++++
- 1 file changed, 4 insertions(+)
-
-diff --git a/src/cairo-ft-font.c b/src/cairo-ft-font.c
-index 325dd61b4..981973f78 100644
---- a/src/cairo-ft-font.c
-+++ b/src/cairo-ft-font.c
-@@ -2393,7 +2393,11 @@ skip:
- done:
- free (coords);
- free (current_coords);
-+#if HAVE_FT_DONE_MM_VAR
-+ FT_Done_MM_Var (face->glyph->library, ft_mm_var);
-+#else
- free (ft_mm_var);
-+#endif
- }
- }
-
---
-2.19.2
-
diff --git a/x11-libs/cairo/files/cairo-1.16.0-pdf-add-missing-flush.patch b/x11-libs/cairo/files/cairo-1.16.0-pdf-add-missing-flush.patch
deleted file mode 100644
index 19345f1..0000000
--- a/x11-libs/cairo/files/cairo-1.16.0-pdf-add-missing-flush.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 4c8813f0eaacc32c27126ad2296951a626300b89 Mon Sep 17 00:00:00 2001
-From: Adrian Johnson <ajohnson@redneon.com>
-Date: Thu, 25 Oct 2018 18:46:17 +1030
-Subject: [PATCH] pdf: add missing flush
-
-Issue #342
----
- src/cairo-pdf-surface.c | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/src/cairo-pdf-surface.c b/src/cairo-pdf-surface.c
-index 7eb61aa1e..939b2d2d7 100644
---- a/src/cairo-pdf-surface.c
-+++ b/src/cairo-pdf-surface.c
-@@ -7711,6 +7711,11 @@ _cairo_pdf_surface_mask (void *abstract_surface,
- * and most common, case to handle. */
- if (_cairo_pattern_is_constant_alpha (mask, &extents.bounded, &alpha) &&
- _can_paint_pattern (source)) {
-+
-+ status = _cairo_pdf_operators_flush (&surface->pdf_operators);
-+ if (unlikely (status))
-+ goto cleanup;
-+
- _cairo_output_stream_printf (surface->output, "q\n");
- status = _cairo_pdf_surface_paint_pattern (surface,
- op,
---
-2.19.2
-
diff --git a/x11-libs/cairo/files/cairo-1.16.0-strings.patch b/x11-libs/cairo/files/cairo-1.16.0-strings.patch
deleted file mode 100644
index ee72f9d..0000000
--- a/x11-libs/cairo/files/cairo-1.16.0-strings.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-https://bugs.gentoo.org/726200
---- a/build/aclocal.float.m4
-+++ b/build/aclocal.float.m4
-@@ -31,10 +31,13 @@ int main() { return 0; }
-
- ]])], [
-
--if strings -a conftest$ac_exeext | grep noonsees >/dev/null ; then
-+# allow users to override default 'strings' with 'llvm-strings'
-+# or ${CHOST}-strings.
-+AC_CHECK_TOOL(STRINGS, strings)
-+if $STRINGS -a conftest$ac_exeext | grep noonsees >/dev/null ; then
- ax_cv_c_float_words_bigendian=yes
- fi
--if strings -a conftest$ac_exeext | grep seesnoon >/dev/null ; then
-+if $STRINGS -a conftest$ac_exeext | grep seesnoon >/dev/null ; then
- if test "$ax_cv_c_float_words_bigendian" = unknown; then
- ax_cv_c_float_words_bigendian=no
- else
diff --git a/x11-libs/cairo/files/cairo-respect-fontconfig.patch b/x11-libs/cairo/files/cairo-respect-fontconfig.patch
deleted file mode 100644
index b0a1b29..0000000
--- a/x11-libs/cairo/files/cairo-respect-fontconfig.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- cairo-1.7.6-orig/src/cairo-ft-font.c 2008-09-29 21:43:13.000000000 +0100
-+++ cairo-1.7.6/src/cairo-ft-font.c 2008-09-29 21:52:19.000000000 +0100
-@@ -1705,7 +1705,9 @@
- options->base.subpixel_order = other->base.subpixel_order;
- }
-
-- if (options->base.hint_style == CAIRO_HINT_STYLE_DEFAULT)
-+ options->base.hint_style = CAIRO_HINT_STYLE_DEFAULT;
-+
-+ if (other->base.hint_style != CAIRO_HINT_STYLE_DEFAULT)
- options->base.hint_style = other->base.hint_style;
-
- if (other->base.hint_style == CAIRO_HINT_STYLE_NONE)
diff --git a/x11-libs/cairo/metadata.xml b/x11-libs/cairo/metadata.xml
deleted file mode 100644
index 0ac435d..0000000
--- a/x11-libs/cairo/metadata.xml
+++ /dev/null
@@ -1,14 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <use>
- <flag name="opengl" restrict="&gt;=x11-libs/cairo-1.10.0">Build the OpenGL backend</flag>
- <flag name="gles2-only">Build the OpenGL ES 2 backend</flag>
- <flag name="glib">Compile with GLib Object System support</flag>
- <flag name="utils">Build support for Cairo script and trace utilities</flag>
- <flag name="valgrind">Built-in support to mark memory regions</flag>
- </use>
- <upstream>
- <remote-id type="cpe">cpe:/a:cairographics:cairo</remote-id>
- </upstream>
-</pkgmetadata>