summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-12-15 13:53:31 -0500
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-12-15 13:53:31 -0500
commitc930da71ed9275339c135b430a3fb9e2163c4184 (patch)
tree7187a69b79d5107c57ffc817e79ab671f0fcae7f
parentbaa2aa3ab02c370f269cb3d02987eabbb323b1a4 (diff)
downloadgentoo-overlay-c930da71ed9275339c135b430a3fb9e2163c4184.tar.xz
gentoo-overlay-c930da71ed9275339c135b430a3fb9e2163c4184.zip
gui-apps/swaybg: import
-rw-r--r--gui-apps/swaybg/Manifest1
-rw-r--r--gui-apps/swaybg/metadata.xml20
-rw-r--r--gui-apps/swaybg/swaybg-1.1.ebuild47
-rw-r--r--gui-apps/swaybg/swaybg-9999.ebuild47
4 files changed, 115 insertions, 0 deletions
diff --git a/gui-apps/swaybg/Manifest b/gui-apps/swaybg/Manifest
new file mode 100644
index 0000000..8e9df1e
--- /dev/null
+++ b/gui-apps/swaybg/Manifest
@@ -0,0 +1 @@
+DIST swaybg-1.1.tar.gz 16095 BLAKE2B de4cbf348a981a4ccf1bb6beafe6ff952a8864b2d972201ca42c9828016d76eddaa19d6c4a18607e42e1677355960749af86052b2edd7bc3873f68523dbabede SHA512 2b262402c4d93908facde82b07a3df1ee698b802b7e9c07e6eff0325cb9ddf712c544574c5aeb481f69dfb1857a88bf8e654bfe0dd3b2178fd3a44109e104692
diff --git a/gui-apps/swaybg/metadata.xml b/gui-apps/swaybg/metadata.xml
new file mode 100644
index 0000000..3d404ea
--- /dev/null
+++ b/gui-apps/swaybg/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription lang="en">
+ Sway's wallpaper utility, compatible with any Wayland compositor
+ which implements the wlr-layer-shell, xdg-output and xdg-shell protocols.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">swaywm/swaybg</remote-id>
+ <maintainer status="active">
+ <email>sir@cmpwn.com</email>
+ <name>Drew DeVault</name>
+ </maintainer>
+ <bugs-to>https://github.com/swaywm/swaybg/issues</bugs-to>
+ <changelog>https://github.com/swaywm/swaybg/releases</changelog>
+ </upstream>
+ <use>
+ <flag name="gdk-pixbuf">Support image types other than PNG</flag>
+ </use>
+</pkgmetadata>
diff --git a/gui-apps/swaybg/swaybg-1.1.ebuild b/gui-apps/swaybg/swaybg-1.1.ebuild
new file mode 100644
index 0000000..34c485e
--- /dev/null
+++ b/gui-apps/swaybg/swaybg-1.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A wallpaper utility for Wayland"
+HOMEPAGE="https://github.com/swaywm/swaybg"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+else
+ SRC_URI="https://github.com/swaywm/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="gdk-pixbuf +man"
+
+DEPEND="
+ dev-libs/wayland
+ >=dev-libs/wayland-protocols-1.14
+ x11-libs/cairo
+ gdk-pixbuf? ( x11-libs/gdk-pixbuf )
+"
+RDEPEND="
+ ${DEPEND}
+ !<gui-wm/sway-1.1_alpha1
+"
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+ man? ( app-text/scdoc )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=$(usex man enabled disabled)
+ -Dgdk-pixbuf=$(usex gdk-pixbuf enabled disabled)
+ -Dwerror=false
+ )
+
+ meson_src_configure
+}
diff --git a/gui-apps/swaybg/swaybg-9999.ebuild b/gui-apps/swaybg/swaybg-9999.ebuild
new file mode 100644
index 0000000..c75b4ee
--- /dev/null
+++ b/gui-apps/swaybg/swaybg-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="A wallpaper utility for Wayland"
+HOMEPAGE="https://github.com/swaywm/swaybg"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/swaywm/${PN}.git"
+else
+ SRC_URI="https://github.com/swaywm/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="gdk-pixbuf +man"
+
+DEPEND="
+ dev-libs/wayland
+ >=dev-libs/wayland-protocols-1.14
+ x11-libs/cairo
+ gdk-pixbuf? ( x11-libs/gdk-pixbuf )
+"
+RDEPEND="
+ ${DEPEND}
+ !<gui-wm/sway-1.1_alpha1
+"
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+ man? ( app-text/scdoc )
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dman-pages=$(usex man enabled disabled)
+ -Dgdk-pixbuf=$(usex gdk-pixbuf enabled disabled)
+ -Dwerror=false
+ )
+
+ meson_src_configure
+}