summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-04-03 21:09:19 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-04-03 21:09:19 -0400
commitc9ce43617c821f90c6f1bc0e1ab5fe0aa4d3b0d6 (patch)
tree75c7d4ac470f2c8744dd9ec1fe77b0c90d6eeee8
parentda1ab50ce917ab4b45f13b877f334680b724576d (diff)
downloadgentoo-overlay-c9ce43617c821f90c6f1bc0e1ab5fe0aa4d3b0d6.tar.xz
gentoo-overlay-c9ce43617c821f90c6f1bc0e1ab5fe0aa4d3b0d6.zip
dev-lang/mono: drop
-rw-r--r--dev-lang/mono/Manifest1
-rw-r--r--dev-lang/mono/files/mono-5.12-try-catch.patch31
-rw-r--r--dev-lang/mono/metadata.xml8
-rw-r--r--dev-lang/mono/mono-6.12.0.122.ebuild105
4 files changed, 0 insertions, 145 deletions
diff --git a/dev-lang/mono/Manifest b/dev-lang/mono/Manifest
deleted file mode 100644
index 95ccf27..0000000
--- a/dev-lang/mono/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST mono-6.12.0.122.tar.xz 292266176 BLAKE2B 07043c5fbca33edf64ebca0392b47af9b9ab502be772efb5afbe5ec9e8683b7f4e96a305ee906dff617842bdba2819c2abc130d7aff23b12779f403bbd88f3bd SHA512 0fbd4147498cc81e384933147eb6aa5c559d17a794a308af7ffa43dce51e0faefde24fc75e987ed804dcb161b52756944bc3611100fc0a4adcc260ca97ddaecd
diff --git a/dev-lang/mono/files/mono-5.12-try-catch.patch b/dev-lang/mono/files/mono-5.12-try-catch.patch
deleted file mode 100644
index 051c72b..0000000
--- a/dev-lang/mono/files/mono-5.12-try-catch.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff -ur mono-5.9.0.398/mcs/class/System.Windows.Forms/System.Windows.Forms/XplatUIX11.cs mono-patched-5.9.0.398/mcs/class/System.Windows.Forms/System.Windows.Forms/XplatUIX11.cs
---- mono-5.9.0.398/mcs/class/System.Windows.Forms/System.Windows.Forms/XplatUIX11.cs 2017-11-17 18:12:57.000000000 +0300
-+++ mono-patched-5.9.0.398/mcs/class/System.Windows.Forms/System.Windows.Forms/XplatUIX11.cs 2017-12-06 06:24:45.067519852 +0300
-@@ -2810,14 +2810,21 @@
-
- internal override object ClipboardRetrieve(IntPtr handle, int type, XplatUI.ClipboardToObject converter)
- {
-- XConvertSelection(DisplayHandle, handle, (IntPtr)type, (IntPtr)type, FosterParent, IntPtr.Zero);
-+ try
-+ {
-+ XConvertSelection(DisplayHandle, handle, (IntPtr)type, (IntPtr)type, FosterParent, IntPtr.Zero);
-
-- Clipboard.Retrieving = true;
-- while (Clipboard.Retrieving) {
-- UpdateMessageQueue(null, false);
-- }
-+ Clipboard.Retrieving = true;
-+ while (Clipboard.Retrieving) {
-+ UpdateMessageQueue(null, false);
-+ }
-
-- return Clipboard.Item;
-+ return Clipboard.Item;
-+ }
-+ catch (Exception ex)
-+ {
-+ return null;
-+ }
- }
-
- internal override void ClipboardStore (IntPtr handle, object obj, int type, XplatUI.ObjectToClipboard converter, bool copy)
diff --git a/dev-lang/mono/metadata.xml b/dev-lang/mono/metadata.xml
deleted file mode 100644
index 3a97117..0000000
--- a/dev-lang/mono/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-<use>
- <flag name="pax_kernel">Enable if the user plans to run the package under a pax enabled hardened kernel</flag>
- <flag name="xen">Make mono generate code that is considerably faster on xen VMs but slightly slower on for normal systems.</flag>
-</use>
-</pkgmetadata>
diff --git a/dev-lang/mono/mono-6.12.0.122.ebuild b/dev-lang/mono/mono-6.12.0.122.ebuild
deleted file mode 100644
index 817de94..0000000
--- a/dev-lang/mono/mono-6.12.0.122.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux"
-
-SLOT="0"
-
-IUSE="nls minimal pax_kernel xen doc"
-
-inherit autotools eutils linux-info mono-env flag-o-matic pax-utils multilib-minimal
-
-DESCRIPTION="Mono runtime and class libraries, a C# compiler/interpreter"
-HOMEPAGE="https://mono-project.com"
-LICENSE="MIT LGPL-2.1 GPL-2 BSD-4 NPL-1.1 Ms-PL GPL-2-with-linking-exception IDPL"
-
-SRC_URI="https://download.mono-project.com/sources/mono/${P}.tar.xz"
-
-#Note: mono works incorrect with older versions of libgdiplus
-#details on dotnet overlay issue: https://github.com/gentoo/dotnet/issues/429
-COMMONDEPEND="
- !minimal? ( >=dev-dotnet/libgdiplus-6.0.2 )
- ia64? ( sys-libs/libunwind )
- nls? ( sys-devel/gettext )
-"
-RDEPEND="${COMMONDEPEND}"
-DEPEND="${COMMONDEPEND}
- sys-devel/bc
- virtual/yacc
- pax_kernel? ( sys-apps/elfix )
- dev-util/cmake
-"
-
-PATCHES=(
- "${FILESDIR}"/mono-5.12-try-catch.patch
-)
-
-pkg_pretend() {
- linux-info_pkg_setup
- if use kernel_linux; then
- if linux_config_exists; then
- linux_chkconfig_builtin SYSVIPC || die "SYSVIPC not enabled in the kernel"
- else
- # https://github.com/gentoo/gentoo/blob/f200e625bda8de696a28338318c9005b69e34710/eclass/linux-info.eclass#L686
- ewarn "kernel config not found"
- ewarn "If CONFIG_SYSVIPC is not set in your kernel .config, mono will hang while compiling."
- ewarn "See https://bugs.gentoo.org/261869 for more info."
- fi
- fi
-}
-
-pkg_setup() {
- mono-env_pkg_setup
-}
-
-src_prepare() {
- # we need to sed in the paxctl-ng -mr in the runtime/mono-wrapper.in so it don't
- # get killed in the build proces when MPROTECT is enable. #286280
- # RANDMMAP kill the build proces to #347365
- # use paxmark.sh to get PT/XT logic #532244
- if use pax_kernel ; then
- ewarn "We are disabling MPROTECT on the mono binary."
-
- # issue 9 : https://github.com/Heather/gentoo-dotnet/issues/9
- sed '/exec "/ i\paxmark.sh -mr "$r/@mono_runtime@"' -i "${S}"/runtime/mono-wrapper.in || die "Failed to sed mono-wrapper.in"
- fi
-
- # mono build system can fail otherwise
- strip-flags
-
- default
-
- # PATCHES contains configure.ac patch
- eautoreconf
- multilib_copy_sources
-}
-
-multilib_src_configure() {
- local myeconfargs=(
- $(use_with xen xen_opt)
- --without-ikvm-native
- --disable-dtrace
- --enable-system-aot
- $(use_with doc mcs-docs)
- $(use_enable nls)
- )
-
- econf "${myeconfargs[@]}"
-}
-
-multilib_src_test() {
- cd mcs/tests || die
- emake check
-}
-
-multilib_src_install() {
- default_src_install
-
- # Remove files not respecting LDFLAGS and that we are not supposed to provide, see Fedora
- # mono.spec and http://www.mail-archive.com/mono-devel-list@lists.ximian.com/msg24870.html
- # for reference.
- rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mscorlib.dll.so || die
- rm -f "${ED}"/usr/lib/mono/{2.0,4.5}/mcs.exe.so || die
-}