summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2022-06-28 16:41:30 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2022-06-28 16:41:30 -0400
commitd0b9aad2a6b79361c341dffaaee5f076447d0659 (patch)
tree258e882a688d2d6f81e88c8433010a4605ec2d95
parentd1b7e7f478f6f55858fa1061eb7d43d0517babb6 (diff)
downloadgentoo-overlay-d0b9aad2a6b79361c341dffaaee5f076447d0659.tar.xz
gentoo-overlay-d0b9aad2a6b79361c341dffaaee5f076447d0659.zip
dev-libs/openssl: sync
-rw-r--r--dev-libs/openssl/openssl-3.0.4-r1.ebuild (renamed from dev-libs/openssl/openssl-3.0.3-r1.ebuild)30
1 files changed, 19 insertions, 11 deletions
diff --git a/dev-libs/openssl/openssl-3.0.3-r1.ebuild b/dev-libs/openssl/openssl-3.0.4-r1.ebuild
index 86e51bf..1f1b08a 100644
--- a/dev-libs/openssl/openssl-3.0.3-r1.ebuild
+++ b/dev-libs/openssl/openssl-3.0.4-r1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI=7
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/openssl.org.asc
inherit edo flag-o-matic linux-info toolchain-funcs multilib-minimal multiprocessing verify-sig
DESCRIPTION="Robust, full-featured Open Source Toolkit for the Transport Layer Security (TLS)"
@@ -17,7 +18,6 @@ if [[ ${PV} == 9999 ]] ; then
else
SRC_URI="mirror://openssl/source/${MY_P}.tar.gz
verify-sig? ( mirror://openssl/source/${MY_P}.tar.gz.asc )"
- VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/openssl.org.asc
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x86-linux"
fi
@@ -46,15 +46,12 @@ DEPEND="${COMMON_DEPEND}"
RDEPEND="${COMMON_DEPEND}"
PDEPEND="app-misc/ca-certificates"
+REQUIRED_USE="test? ( rfc3779 )"
+
MULTILIB_WRAPPED_HEADERS=(
/usr/include/openssl/configuration.h
)
-PATCHES=(
- # General patches which are suitable to always apply
- # If they're Gentoo specific, add to USE=-vanilla logic in src_prepare!
-)
-
pkg_setup() {
if use ktls ; then
if kernel_is -lt 4 18 ; then
@@ -81,6 +78,16 @@ pkg_setup() {
fi
}
+src_unpack() {
+ # Can delete this once test fix patch is dropped
+ if use verify-sig ; then
+ # Needed for downloaded patch (which is unsigned, which is fine)
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.gz{,.asc}
+ fi
+
+ default
+}
+
src_prepare() {
# Allow openssl to be cross-compiled
cp "${FILESDIR}"/gentoo.config-1.0.2 gentoo.config || die
@@ -205,9 +212,7 @@ multilib_src_configure() {
threads
)
- CFLAGS= LDFLAGS= edo \
- ./${config} \
- "${myeconfargs[@]}"
+ CFLAGS= LDFLAGS= edo ./${config} "${myeconfargs[@]}"
# Clean out hardcoded flags that openssl uses
local DEFAULT_CFLAGS=$(grep ^CFLAGS= Makefile | LC_ALL=C sed \
@@ -275,7 +280,9 @@ multilib_src_install_all() {
cd "${ED}"/usr/share/man || die
local m d s
for m in $(find . -type f | xargs grep -L '#include') ; do
- d=${m%/*} ; d=${d#./} ; m=${m##*/}
+ d=${m%/*}
+ d=${d#./}
+ m=${m##*/}
[[ ${m} == openssl.1* ]] && continue
@@ -291,6 +298,7 @@ multilib_src_install_all() {
# We assume that any broken links are due to the above renaming
for s in $(find -L ${d} -type l) ; do
s=${s##*/}
+
rm -f ${d}/${s}
# We don't want to "|| die" here