summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2022-02-18 08:28:27 -0500
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2022-02-18 08:28:27 -0500
commitd276da1229de7a663adc26dfeec47f085c88a7b2 (patch)
treee955f2fff437f78386e28fce40043d31e8d50ef1
parent4546d7cfd9fba1e01641452b4137cfd2183d6fec (diff)
downloadgentoo-overlay-d276da1229de7a663adc26dfeec47f085c88a7b2.tar.xz
gentoo-overlay-d276da1229de7a663adc26dfeec47f085c88a7b2.zip
dev-cpp/highway: upgrade to 0.16.0
revbump libjxl for <highway-0.16.0 dep
-rw-r--r--dev-cpp/highway/Manifest1
-rw-r--r--dev-cpp/highway/highway-0.16.0.ebuild27
-rw-r--r--media-libs/libjxl/libjxl-0.6.1-r2.ebuild (renamed from media-libs/libjxl/libjxl-0.6.1-r1.ebuild)2
3 files changed, 29 insertions, 1 deletions
diff --git a/dev-cpp/highway/Manifest b/dev-cpp/highway/Manifest
index 0015a5f..a6b6bcb 100644
--- a/dev-cpp/highway/Manifest
+++ b/dev-cpp/highway/Manifest
@@ -1 +1,2 @@
DIST highway-0.15.0.tar.gz 1598512 BLAKE2B f0ee61b5f19591d88d6fd3950072c9302b13e589ac9e8759444c0bcde2c804438313b1b37c2e3d9c40296898c8fc938a2ae57eba3e17d73a9388c21f20b97b59 SHA512 ed07e855721f87ea67d762b30e001643a76bd16d70372415023c8e6f1a43c58759a14a638e8eb20566863d8358d994153bf7a660fcf604e808adfea5f938a013
+DIST highway-0.16.0.tar.gz 1639388 BLAKE2B 660b0079b25a12a2e982b4ba16147b923d167989a7dc1c0cb65ebe5219577f2f02c8774a554fd3fe9e1c10ef7b1cf5db747500bd8acf454e26952722f7b5ac9e SHA512 c08e66f43d9d0b307737b016cfa6c3d3a1df9bd528de435d193388104f34c264866c5ff0da633fc0a6f8c50f21df1ac653e9dd3f6fbfaf227d636411ac14cd47
diff --git a/dev-cpp/highway/highway-0.16.0.ebuild b/dev-cpp/highway/highway-0.16.0.ebuild
new file mode 100644
index 0000000..6111907
--- /dev/null
+++ b/dev-cpp/highway/highway-0.16.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="Performance-portable, length-agnostic SIMD with runtime dispatch"
+HOMEPAGE="https://github.com/google/highway"
+SRC_URI="https://github.com/google/highway/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="test? ( dev-cpp/gtest[${MULTILIB_USEDEP}] )"
+RDEPEND=""
+BDEPEND=""
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test ON OFF)
+ -DHWY_SYSTEM_GTEST=ON
+ )
+ cmake_src_configure
+}
diff --git a/media-libs/libjxl/libjxl-0.6.1-r1.ebuild b/media-libs/libjxl/libjxl-0.6.1-r2.ebuild
index a348b83..8870574 100644
--- a/media-libs/libjxl/libjxl-0.6.1-r1.ebuild
+++ b/media-libs/libjxl/libjxl-0.6.1-r2.ebuild
@@ -31,7 +31,7 @@ fi
IUSE="apng doc gdk-pixbuf gif gimp java +jpeg +man openexr static-libs test +tools viewers"
RDEPEND="app-arch/brotli[${MULTILIB_USEDEP}]
- dev-cpp/highway[${MULTILIB_USEDEP}]
+ <dev-cpp/highway-0.16.0[${MULTILIB_USEDEP}]
apng? (
media-libs/libpng[${MULTILIB_USEDEP}]
sys-libs/zlib[${MULTILIB_USEDEP}]