summaryrefslogtreecommitdiff
path: root/app-arch/7-zip/7-zip-21.07.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2022-03-01 08:25:44 -0500
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2022-03-01 08:25:44 -0500
commit7955f319b8cbf65cb070217e0ff2d553cf5495aa (patch)
treec27d06294970eec6b23cc3a35046c771c16494e9 /app-arch/7-zip/7-zip-21.07.ebuild
parent03fc96c1ae59cd4da18997f6a40d2a66f324e1dd (diff)
downloadgentoo-overlay-7955f319b8cbf65cb070217e0ff2d553cf5495aa.tar.xz
gentoo-overlay-7955f319b8cbf65cb070217e0ff2d553cf5495aa.zip
app-arch/7-zip: add USE=-rar
Diffstat (limited to 'app-arch/7-zip/7-zip-21.07.ebuild')
-rw-r--r--app-arch/7-zip/7-zip-21.07.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/app-arch/7-zip/7-zip-21.07.ebuild b/app-arch/7-zip/7-zip-21.07.ebuild
deleted file mode 100644
index 86d7287..0000000
--- a/app-arch/7-zip/7-zip-21.07.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit flag-o-matic
-
-MY_PV=${PV%%_*}
-MY_PV=${MY_PV//./}
-
-DESCRIPTION="File archiver with a high compression ratio"
-HOMEPAGE="https://7-zip.org/"
-SRC_URI="https://7-zip.org/a/7z${MY_PV}-src.tar.xz"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+asm"
-
-BDEPEND="
- asm? ( dev-lang/jwasm )
-"
-RDEPEND="!app-arch/p7zip"
-
-S=${WORKDIR}
-
-PATCHES=( ${FILESDIR}/7-zip-flags.patch )
-
-src_compile() {
- cd CPP/7zip/Bundles/Alone2 || die
- local myemakeargs=(
- CC="$(tc-getCC) ${CFLAGS} ${LDFLAGS}"
- CXX="$(tc-getCXX) ${CXXFLAGS} ${LDFLAGS}"
- )
- if use asm; then
- myemakeargs+=(USE_ASM=1 USE_JWASM=1)
- if use amd64; then
- myemakeargs+=(IS_X64=1)
- elif use arm64; then
- myemakeargs+=(IS_ARM64=1)
- elif use x86; then
- myemakeargs+=(IS_X86=1)
- else
- einfo "asm is not supported on this arch, ignoring"
- fi
- fi
- mkdir -p b/g || die
- emake -f ../../cmpl_gcc.mak "${myemakeargs[@]}"
-}
-
-src_install() {
- dobin CPP/7zip/Bundles/Alone2/b/g/7zz
- dosym 7zz /usr/bin/7z
- dodoc DOC/*
-}