summaryrefslogtreecommitdiff
path: root/app-emulation/dxvk-bin/dxvk-bin-1.7.1.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-08-13 18:05:57 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-08-13 18:05:57 -0400
commit81a76006466c47cc4ce67f035152ad7a64760c2f (patch)
tree8f763ae4bcf7785f444fc46b697307eb3eb74301 /app-emulation/dxvk-bin/dxvk-bin-1.7.1.ebuild
parent2a5e0a44edefef0872bce75b531e84788177ee9d (diff)
downloadgentoo-overlay-81a76006466c47cc4ce67f035152ad7a64760c2f.tar.xz
gentoo-overlay-81a76006466c47cc4ce67f035152ad7a64760c2f.zip
app-emulation/dxvk-bin: bump
Diffstat (limited to 'app-emulation/dxvk-bin/dxvk-bin-1.7.1.ebuild')
-rw-r--r--app-emulation/dxvk-bin/dxvk-bin-1.7.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-emulation/dxvk-bin/dxvk-bin-1.7.1.ebuild b/app-emulation/dxvk-bin/dxvk-bin-1.7.1.ebuild
new file mode 100644
index 0000000..bc0b42a
--- /dev/null
+++ b/app-emulation/dxvk-bin/dxvk-bin-1.7.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Vulkan-based D3D11 and D3D10 implementation for Linux / Wine"
+HOMEPAGE="https://github.com/doitsujin/dxvk"
+SRC_URI="https://github.com/doitsujin/dxvk/releases/download/v${PV}/dxvk-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+# x86 is fine except for the stupid vulkan package.use.mask...
+KEYWORDS="-* ~amd64"
+IUSE="+abi_x86_32 +abi_x86_64"
+
+RDEPEND="
+ !app-emulation/dxvk
+ || (
+ app-emulation/wine-vanilla[abi_x86_32?,abi_x86_64?,vulkan]
+ app-emulation/wine-staging[abi_x86_32?,abi_x86_64?,vulkan]
+ )
+"
+
+REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )"
+
+S=${WORKDIR}/dxvk-${PV}
+
+src_compile() {
+ sed -i -e 's#"x32"#"../'$(ABI=x86 get_libdir)/dxvk'"#' setup_dxvk.sh || die
+ sed -i -e 's#"x64"#"../'$(ABI=amd64 get_libdir)/dxvk'"#' setup_dxvk.sh || die
+}
+
+src_install() {
+ dobin setup_dxvk.sh
+ dodir usr/$(ABI=x86 get_libdir)
+ dodir usr/$(ABI=amd64 get_libdir)
+ mv x32 "${ED}"/usr/$(ABI=x86 get_libdir)/dxvk || die
+ mv x64 "${ED}"/usr/$(ABI=amd64 get_libdir)/dxvk || die
+}