summaryrefslogtreecommitdiff
path: root/app-emulation/wine-mono/wine-mono-6.0.0.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-03-02 16:56:03 -0500
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-03-02 16:56:03 -0500
commit35208c65b60efc87f12abae5cecbce071b269222 (patch)
treecc1c4a129edb394379cbe197ba3ac6f75ce6c2be /app-emulation/wine-mono/wine-mono-6.0.0.ebuild
parent62e51292e050754753733e16e6453bf0a9ebc448 (diff)
downloadgentoo-overlay-35208c65b60efc87f12abae5cecbce071b269222.tar.xz
gentoo-overlay-35208c65b60efc87f12abae5cecbce071b269222.zip
app-emulation/wine-mono: bump
Diffstat (limited to 'app-emulation/wine-mono/wine-mono-6.0.0.ebuild')
-rw-r--r--app-emulation/wine-mono/wine-mono-6.0.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-emulation/wine-mono/wine-mono-6.0.0.ebuild b/app-emulation/wine-mono/wine-mono-6.0.0.ebuild
new file mode 100644
index 0000000..d0b0688
--- /dev/null
+++ b/app-emulation/wine-mono/wine-mono-6.0.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Wine Mono is a replacement for the .NET runtime and class libraries in Wine"
+HOMEPAGE="https://www.winehq.org/"
+SRC_URI="
+ !shared? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86.msi )
+ shared? ( https://dl.winehq.org/wine/${PN}/${PV}/${P}-x86.tar.xz )
+"
+
+LICENSE="BSD-2 GPL-2 LGPL-2.1 MIT MPL-1.1"
+SLOT="${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="shared"
+
+DEPEND="!!app-emulation/wine:0"
+
+S="${WORKDIR}"
+
+src_install() {
+ insinto /usr/share/wine/mono
+ if use shared; then
+ doins -r "${P}"
+ else
+ doins "${DISTDIR}/${P}-x86.msi"
+ fi
+}