summaryrefslogtreecommitdiff
path: root/app-text/zathura/zathura-0.4.9-r1.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2023-01-11 05:15:28 -0500
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2023-01-11 05:15:28 -0500
commitbf5898b98b1863a740d6ca56efa5bcd3e72f79ef (patch)
treebbcf757fa3db3c465ebbcfdee3ec618b6051e539 /app-text/zathura/zathura-0.4.9-r1.ebuild
parentcc033b055b5cc8c658de195bd9a41ed3fe1fdfe9 (diff)
downloadgentoo-overlay-bf5898b98b1863a740d6ca56efa5bcd3e72f79ef.tar.xz
gentoo-overlay-bf5898b98b1863a740d6ca56efa5bcd3e72f79ef.zip
app-text/zathura: sync
Diffstat (limited to 'app-text/zathura/zathura-0.4.9-r1.ebuild')
-rw-r--r--app-text/zathura/zathura-0.4.9-r1.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/app-text/zathura/zathura-0.4.9-r1.ebuild b/app-text/zathura/zathura-0.4.9-r1.ebuild
deleted file mode 100644
index fdb219d..0000000
--- a/app-text/zathura/zathura-0.4.9-r1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit meson virtualx xdg
-
-DESCRIPTION="A highly customizable and functional document viewer"
-HOMEPAGE="https://pwmt.org/projects/zathura/"
-
-if [[ ${PV} == *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://git.pwmt.org/pwmt/${PN}.git"
- EGIT_BRANCH="develop"
-else
- SRC_URI="https://github.com/pwmt/zathura/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm ~riscv ~x86 ~amd64-linux ~x86-linux"
-fi
-
-LICENSE="ZLIB"
-SLOT="0"
-IUSE="doc +magic seccomp sqlite synctex test"
-
-RESTRICT="!test? ( test )"
-
-DEPEND=">=dev-libs/girara-0.3.7
- >=dev-libs/glib-2.50:2
- >=sys-devel/gettext-0.19.8
- x11-libs/cairo
- >=x11-libs/gtk+-3.22:3
- magic? ( sys-apps/file )
- seccomp? ( sys-libs/libseccomp )
- sqlite? ( >=dev-db/sqlite-3.5.9:3 )
- synctex? ( app-text/texlive-core )"
-
-RDEPEND="${DEPEND}"
-
-BDEPEND="doc? ( dev-python/docutils )
- test? ( dev-libs/appstream-glib
- dev-libs/check )
- virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}/zathura-docutils.patch"
-)
-
-src_configure() {
- local emesonargs=(
- -Dconvert-icon=disabled
- -Dmagic=$(usex magic enabled disabled)
- -Dmanpages=$(usex doc enabled disabled)
- -Dseccomp=$(usex seccomp enabled disabled)
- -Dsqlite=$(usex sqlite enabled disabled)
- -Dsynctex=$(usex synctex enabled disabled)
- )
- meson_src_configure
-}
-
-src_test() {
- virtx meson_src_test
-}