summaryrefslogtreecommitdiff
path: root/app-text
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-10-02 10:48:08 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-10-02 10:48:08 -0400
commitfc689d647458f9f3c74192d09bf4df287d88c8fa (patch)
tree8e2d5e40774f37739a55f42e411c1ac8378654b8 /app-text
parentdd1a217a351b81c9febfc7f1f1d4e97bdf4770aa (diff)
downloadgentoo-overlay-fc689d647458f9f3c74192d09bf4df287d88c8fa.tar.xz
gentoo-overlay-fc689d647458f9f3c74192d09bf4df287d88c8fa.zip
app-text/zathura: import
Diffstat (limited to 'app-text')
-rw-r--r--app-text/zathura/Manifest1
-rw-r--r--app-text/zathura/files/zathura-docutils.patch119
-rw-r--r--app-text/zathura/metadata.xml24
-rw-r--r--app-text/zathura/zathura-0.4.7.ebuild61
-rw-r--r--app-text/zathura/zathura-9999.ebuild61
5 files changed, 266 insertions, 0 deletions
diff --git a/app-text/zathura/Manifest b/app-text/zathura/Manifest
new file mode 100644
index 0000000..63b3ba7
--- /dev/null
+++ b/app-text/zathura/Manifest
@@ -0,0 +1 @@
+DIST zathura-0.4.7.tar.gz 199857 BLAKE2B c4fd99049ed81c7965cc474f0c543ebd1aef55ff63312c21a33ce9161afb78da1c9f0a13ff86d5d69b2ce6b17965632de282a9c8bd60b0a8297d96528b5f2c5f SHA512 adfe69cbef6088a6fa7d49686194a0a3dc13757535974476742c733076dc5bb5ad95ed447d50cd1efdfb23fe2fb1f64452d5d8aeb27a80c3101f2ab5c68f9b60
diff --git a/app-text/zathura/files/zathura-docutils.patch b/app-text/zathura/files/zathura-docutils.patch
new file mode 100644
index 0000000..7d313f6
--- /dev/null
+++ b/app-text/zathura/files/zathura-docutils.patch
@@ -0,0 +1,119 @@
+diff --git a/doc/man/conf.py b/doc/man/conf.py
+deleted file mode 100644
+index 2aad25f..0000000
+--- a/doc/man/conf.py
++++ /dev/null
+@@ -1,36 +0,0 @@
+-# -*- coding: utf-8 -*-
+-#
+-# SPDX-License-Identifier: Zlib
+-
+-import os.path
+-import glob
+-import time
+-
+-dirname = os.path.dirname(__file__)
+-files = glob.glob(os.path.join(dirname, '*.rst'))
+-
+-maxdate = 0
+-for path in files:
+- s = os.stat(path)
+- maxdate = max(maxdate, s.st_mtime)
+-
+-# -- General configuration ------------------------------------------------
+-
+-source_suffix = '.rst'
+-master_doc = 'zathura.1'
+-templates_path = ['_templates']
+-today = time.strftime('%Y-%m-%d', time.gmtime(maxdate))
+-
+-# -- Project configuration ------------------------------------------------
+-
+-project = 'zathura'
+-copyright = '2009-2018, pwmt.org'
+-version = '0.2.7'
+-release = '0.2.7'
+-
+-# -- Options for manual page output ---------------------------------------
+-
+-man_pages = [
+- ('zathura.1', 'zathura', 'a document viewer', ['pwmt.org'], 1),
+- ('zathurarc.5', 'zathurarc', 'zathura configuration file', ['pwmt.org'], 5)
+-]
+diff --git a/doc/man/zathura.1.rst b/doc/man/zathura.1.rst
+index 089dbf7..19cc44c 100644
+--- a/doc/man/zathura.1.rst
++++ b/doc/man/zathura.1.rst
+@@ -1,5 +1,14 @@
+-Manpage
+ =======
++zathura
++=======
++
++-----------------
++a document viewer
++-----------------
++
++:Author: pwmt.org
++:Copyright: 2009-2018, pwmt.org
++:Manual section: 1
+
+ Synopsis
+ --------
+diff --git a/doc/man/zathurarc.5.rst b/doc/man/zathurarc.5.rst
+index bf519ae..1ec6462 100644
+--- a/doc/man/zathurarc.5.rst
++++ b/doc/man/zathurarc.5.rst
+@@ -2,6 +2,14 @@
+ zathurarc
+ *********
+
++--------------------------
++zathura configuration file
++--------------------------
++
++:Author: pwmt.org
++:Copyright: 2009-2018, pwmt.org
++:Manual section: 5
++
+ SYNOPSIS
+ ========
+
+diff --git a/doc/meson.build b/doc/meson.build
+index b67c8ab..a02116b 100644
+--- a/doc/meson.build
++++ b/doc/meson.build
+@@ -1,24 +1,10 @@
+-sphinx = find_program('sphinx-build', required: get_option('manpages'))
+-if sphinx.found()
+- custom_target('man pages',
+- command: [
+- sphinx,
+- '-b', 'man',
+- '-D', 'version=' + version,
+- '-D', 'release=' + version,
+- join_paths(meson.current_source_dir(), 'man'),
+- meson.current_build_dir()],
+- output: ['zathura.1', 'zathurarc.5'],
+- input: [
+- 'man/conf.py',
+- 'man/zathurarc.5.rst',
+- 'man/zathura.1.rst'
+- ],
+- build_by_default: true,
+- install: true,
+- install_dir: [
+- join_paths(get_option('mandir'), 'man1'),
+- join_paths(get_option('mandir'), 'man5')
+- ]
+- )
++rst2man = find_program('rst2man', 'rst2man.py', required: get_option('manpages'))
++
++if rst2man.found()
++ custom_target('zathura.1', input: [ 'man/zathura.1.rst' ], output: [ 'zathura.1' ],
++ command: [rst2man, '@INPUT@', '@OUTPUT@'], install: true,
++ install_dir: join_paths(get_option('mandir'), 'man1'))
++ custom_target('zathurarc.5', input: [ 'man/zathurarc.5.rst' ], output: [ 'zathurarc.5' ],
++ command: [rst2man, '@INPUT@', '@OUTPUT@'], install: true,
++ install_dir: join_paths(get_option('mandir'), 'man5'))
+ endif
diff --git a/app-text/zathura/metadata.xml b/app-text/zathura/metadata.xml
new file mode 100644
index 0000000..f7b9cf8
--- /dev/null
+++ b/app-text/zathura/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>slashbeast@gentoo.org</email>
+ <name>Piotr Karbowski</name>
+ </maintainer>
+ <use>
+ <flag name="synctex">Use libsynctex to get latex codeline from pdf</flag>
+ </use>
+ <upstream>
+ <maintainer status="active">
+ <email>mlq@pwmt.org</email>
+ <name>Moritz Lipp</name>
+ </maintainer>
+ <maintainer status="active">
+ <email>sebastian+dev@ramacher.at</email>
+ <name>Sebastian Ramacher</name>
+ </maintainer>
+ <changelog>http://pwmt.org/projects/zathura/download/</changelog>
+ <doc lang="en">http://pwmt.org/projects/zathura/</doc>
+ <bugs-to>http://bugs.pwmt.org/</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/app-text/zathura/zathura-0.4.7.ebuild b/app-text/zathura/zathura-0.4.7.ebuild
new file mode 100644
index 0000000..c1bd16f
--- /dev/null
+++ b/app-text/zathura/zathura-0.4.7.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson virtualx xdg
+
+DESCRIPTION="A highly customizable and functional document viewer"
+HOMEPAGE="https://pwmt.org/projects/zathura/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/${PN}.git"
+ EGIT_BRANCH="develop"
+else
+ SRC_URI="https://github.com/pwmt/zathura/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="ZLIB"
+SLOT="0"
+IUSE="doc +magic seccomp sqlite synctex test"
+
+RESTRICT="!test? ( test )"
+
+DEPEND=">=dev-libs/girara-0.3.3
+ >=dev-libs/glib-2.50:2
+ >=sys-devel/gettext-0.19.8
+ x11-libs/cairo
+ >=x11-libs/gtk+-3.22:3
+ magic? ( sys-apps/file )
+ seccomp? ( sys-libs/libseccomp )
+ sqlite? ( >=dev-db/sqlite-3.5.9:3 )
+ synctex? ( app-text/texlive-core )"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="doc? ( dev-python/docutils )
+ test? ( dev-libs/appstream-glib
+ dev-libs/check )
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/zathura-docutils.patch"
+)
+
+src_configure() {
+ local emesonargs=(
+ -Dconvert-icon=disabled
+ -Dmagic=$(usex magic enabled disabled)
+ -Dmanpages=$(usex doc enabled disabled)
+ -Dseccomp=$(usex seccomp enabled disabled)
+ -Dsqlite=$(usex sqlite enabled disabled)
+ -Dsynctex=$(usex synctex enabled disabled)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}
diff --git a/app-text/zathura/zathura-9999.ebuild b/app-text/zathura/zathura-9999.ebuild
new file mode 100644
index 0000000..00aa622
--- /dev/null
+++ b/app-text/zathura/zathura-9999.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson virtualx
+
+DESCRIPTION="A highly customizable and functional document viewer"
+HOMEPAGE="https://pwmt.org/projects/zathura/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/${PN}.git"
+ EGIT_BRANCH="develop"
+else
+ SRC_URI="https://github.com/pwmt/zathura/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="ZLIB"
+SLOT="0"
+IUSE="doc +magic seccomp sqlite synctex test"
+
+RESTRICT="!test? ( test )"
+
+DEPEND=">=dev-libs/girara-0.3.3
+ >=dev-libs/glib-2.50:2
+ >=sys-devel/gettext-0.19.8
+ x11-libs/cairo
+ >=x11-libs/gtk+-3.22:3
+ magic? ( sys-apps/file )
+ seccomp? ( sys-libs/libseccomp )
+ sqlite? ( >=dev-db/sqlite-3.5.9:3 )
+ synctex? ( app-text/texlive-core )"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="doc? ( dev-python/docutils )
+ test? ( dev-libs/appstream-glib
+ dev-libs/check )
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/zathura-docutils.patch"
+)
+
+src_configure() {
+ local emesonargs=(
+ -Dconvert-icon=disabled
+ -Dmagic=$(usex magic enabled disabled)
+ -Dmanpages=$(usex doc enabled disabled)
+ -Dseccomp=$(usex seccomp enabled disabled)
+ -Dsqlite=$(usex sqlite enabled disabled)
+ -Dsynctex=$(usex synctex enabled disabled)
+ )
+ meson_src_configure
+}
+
+src_test() {
+ virtx meson_src_test
+}