summaryrefslogtreecommitdiff
path: root/dev-cpp/highway/highway-0.14.2.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-10-05 20:52:50 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-10-05 20:52:50 -0400
commitc588b99ea34d3b5f6e9932f7fc6fecf0b58f8b44 (patch)
treec0ec9551946ae12c4ac23d90fc981e13cc08f711 /dev-cpp/highway/highway-0.14.2.ebuild
parent81cad988488b776625b1a7c0c3f4ee726ec73d77 (diff)
downloadgentoo-overlay-c588b99ea34d3b5f6e9932f7fc6fecf0b58f8b44.tar.xz
gentoo-overlay-c588b99ea34d3b5f6e9932f7fc6fecf0b58f8b44.zip
Move dev-libs/highway to dev-cpp/highway
match guru
Diffstat (limited to 'dev-cpp/highway/highway-0.14.2.ebuild')
-rw-r--r--dev-cpp/highway/highway-0.14.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-cpp/highway/highway-0.14.2.ebuild b/dev-cpp/highway/highway-0.14.2.ebuild
new file mode 100644
index 0000000..7f21cc2
--- /dev/null
+++ b/dev-cpp/highway/highway-0.14.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Performance-portable, length-agnostic SIMD with runtime dispatch"
+HOMEPAGE="https://github.com/google/highway"
+SRC_URI="https://github.com/google/highway/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-cpp/gtest )"
+RDEPEND=""
+BDEPEND=""
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test ON OFF)
+ -DHWY_SYSTEM_GTEST=ON
+ )
+ cmake_src_configure
+}