summaryrefslogtreecommitdiff
path: root/dev-cpp/highway/highway-0.15.0.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-11-11 09:07:27 -0500
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-11-11 09:07:27 -0500
commit8ec41042025a5424613320ead6c7a4c6bea61ffa (patch)
tree8b4b66cc2ab02d84e6b6f2f376635d1291ef700f /dev-cpp/highway/highway-0.15.0.ebuild
parent699783a3c5c0600715bc13641902d1364fcd3f9f (diff)
downloadgentoo-overlay-8ec41042025a5424613320ead6c7a4c6bea61ffa.tar.xz
gentoo-overlay-8ec41042025a5424613320ead6c7a4c6bea61ffa.zip
dev-cpp/highway: update to 0.15.0
Diffstat (limited to 'dev-cpp/highway/highway-0.15.0.ebuild')
-rw-r--r--dev-cpp/highway/highway-0.15.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-cpp/highway/highway-0.15.0.ebuild b/dev-cpp/highway/highway-0.15.0.ebuild
new file mode 100644
index 0000000..60d4459
--- /dev/null
+++ b/dev-cpp/highway/highway-0.15.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="Performance-portable, length-agnostic SIMD with runtime dispatch"
+HOMEPAGE="https://github.com/google/highway"
+SRC_URI="https://github.com/google/highway/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-cpp/gtest[${MULTILIB_USEDEP}] )"
+RDEPEND=""
+BDEPEND=""
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test ON OFF)
+ -DHWY_SYSTEM_GTEST=ON
+ )
+ cmake_src_configure
+}