summaryrefslogtreecommitdiff
path: root/dev-dotnet/dotnet-runtime-bin/dotnet-runtime-bin-3.1.22.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2022-06-07 15:06:01 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2022-06-07 15:06:01 -0400
commit364a0e5e79fb1b5da1c0c58d6c16a393340072b6 (patch)
tree5774994492245e46d37125e1bbb840d727360bb1 /dev-dotnet/dotnet-runtime-bin/dotnet-runtime-bin-3.1.22.ebuild
parent1a8b821290c566746541dafa02dd8322f07a4664 (diff)
downloadgentoo-overlay-364a0e5e79fb1b5da1c0c58d6c16a393340072b6.tar.xz
gentoo-overlay-364a0e5e79fb1b5da1c0c58d6c16a393340072b6.zip
dev-dotnet/dotnet-runtime-bin: upgrade to 3.1.25, 6.0.5
Diffstat (limited to 'dev-dotnet/dotnet-runtime-bin/dotnet-runtime-bin-3.1.22.ebuild')
-rw-r--r--dev-dotnet/dotnet-runtime-bin/dotnet-runtime-bin-3.1.22.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/dev-dotnet/dotnet-runtime-bin/dotnet-runtime-bin-3.1.22.ebuild b/dev-dotnet/dotnet-runtime-bin/dotnet-runtime-bin-3.1.22.ebuild
deleted file mode 100644
index 12d4b2a..0000000
--- a/dev-dotnet/dotnet-runtime-bin/dotnet-runtime-bin-3.1.22.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-DESCRIPTION=".NET is a free, cross-platform, open-source developer platform"
-HOMEPAGE="https://dotnet.microsoft.com/"
-LICENSE="MIT"
-
-SRC_URI="
-amd64? ( https://dotnetcli.azureedge.net/dotnet/Runtime/${PV}/dotnet-runtime-${PV}-linux-x64.tar.gz )
-arm? ( https://dotnetcli.azureedge.net/dotnet/Runtime/${PV}/dotnet-runtime-${PV}-linux-arm.tar.gz )
-arm64? ( https://dotnetcli.azureedge.net/dotnet/Runtime/${PV}/dotnet-runtime-${PV}-linux-arm64.tar.gz )
-"
-
-SLOT="$(ver_cut 1-2)"
-KEYWORDS="~amd64 ~arm ~arm64"
-IUSE="dotnet-symlink kerberos lttng"
-REQUIRED_USE="elibc_glibc"
-QA_PREBUILT="*"
-RESTRICT="splitdebug"
-RDEPEND="
- kerberos? ( app-crypt/mit-krb5:0/0 )
- lttng? ( dev-util/lttng-ust:0 )
- sys-libs/zlib:0/1
- dotnet-symlink? (
- !dev-dotnet/dotnet-sdk[dotnet-symlink(+)]
- !dev-dotnet/dotnet-sdk-bin[dotnet-symlink(+)]
- !dev-dotnet/dotnet-runtime[dotnet-symlink(+)]
- )
-"
-
-S=${WORKDIR}
-
-delete() {
- local x
- x=$(find . -name "$1" -print -delete) && [ -n "$x" ]
-}
-
-src_compile() {
- use kerberos || delete System.Net.Security.Native.so || die
- use lttng || delete libcoreclrtraceptprovider.so || die
-}
-
-src_install() {
- local dest="opt/${PN}-${SLOT}"
- dodir "${dest%/*}"
-
- { mv "${S}" "${ED}/${dest}" && mkdir "${S}" && fperms 0755 "/${dest}"; } || die
- dosym "../../${dest}/dotnet" "/usr/bin/dotnet-bin-${SLOT}"
-
- if use dotnet-symlink; then
- dosym "../../${dest}/dotnet" "/usr/bin/dotnet"
- dosym "../../${dest}/dotnet" "/usr/bin/dotnet-${SLOT}"
-
- # set an env-variable for 3rd party tools
- echo "DOTNET_ROOT=/${dest}" > "${T}/90${PN}-${SLOT}" || die
- doenvd "${T}/90${PN}-${SLOT}"
- fi
-}