summaryrefslogtreecommitdiff
path: root/dev-java/openjdk-bin
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-07-28 09:41:37 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-07-28 09:41:37 -0400
commitd241ee7943383a8ad8aacd70d5e301a6acf22c38 (patch)
tree5aaddca6d5744a9e3565da0846cbda2e1a34be3b /dev-java/openjdk-bin
downloadgentoo-overlay-d241ee7943383a8ad8aacd70d5e301a6acf22c38.tar.xz
gentoo-overlay-d241ee7943383a8ad8aacd70d5e301a6acf22c38.zip
Initial commit
Diffstat (limited to 'dev-java/openjdk-bin')
-rw-r--r--dev-java/openjdk-bin/Manifest4
-rw-r--r--dev-java/openjdk-bin/files/openjdk-bin-14.env.sh16
-rw-r--r--dev-java/openjdk-bin/metadata.xml15
-rw-r--r--dev-java/openjdk-bin/openjdk-bin-14.0.2_p12.ebuild115
4 files changed, 150 insertions, 0 deletions
diff --git a/dev-java/openjdk-bin/Manifest b/dev-java/openjdk-bin/Manifest
new file mode 100644
index 0000000..35c8b2d
--- /dev/null
+++ b/dev-java/openjdk-bin/Manifest
@@ -0,0 +1,4 @@
+DIST OpenJDK14U-jdk_aarch64_linux_hotspot_14.0.2_12.tar.gz 208174601 BLAKE2B b721417687095109ff6eebdf366df5fb6f3f36393bd9681aa8246213363459c54ef2e7a2ff9b1555ce84572eb29c9c1bb671cd7705fe85f3b2822942138a7957 SHA512 dde5b262092abce8da1aff63cda75c9e47cd9d11597d3ccf8595f8c24a2299da9a161bf827e47480ce74daa60625a30502f894497b03217c7724f6ff19603b95
+DIST OpenJDK14U-jdk_arm_linux_hotspot_14.0.2_12.tar.gz 196776784 BLAKE2B 36d43f63ea0a1b30a62fffe72c542110cc9f3f0824a09c03a2c481b8d43d8459554e6585bf5a80f6e35f1d01e423038f40a0352812c167c9892242bd3cca7af1 SHA512 52a38a7a95e7ed7a385ecef33c6667ddec4e2b49652c1ca482c314fc528edb0c4322326f3839da22454058f950058433ad1465bc75da7e516d6b159ead45e55d
+DIST OpenJDK14U-jdk_ppc64le_linux_hotspot_14.0.2_12.tar.gz 192668722 BLAKE2B e883354d400169b2252c35f1af63ce90413b0bfff686ef5e0222a5f22cb7443627035ee52b93cb63cebc66f4f4d670eacfbee896ee2431c26cfd9822435f58a3 SHA512 4115be505b0a2ebde43385bea53b119edae2ece62db87ca0c256040e4c2051163f5c307867edd145d617fc4776988777322034830328c8977bffa281620bfa8e
+DIST OpenJDK14U-jdk_x64_linux_hotspot_14.0.2_12.tar.gz 210764986 BLAKE2B 6a9613aa109197dd0e9b23097238da49dbb649cb5c5eac032534be80b4bbcd972548a84b4fb31e8a0dd3011268733d23d5c6b6660da7282d94a6a19cc128f0e4 SHA512 2701f7e08bc1f03f13bbea2b3567c12d96b23a27e5a7420addd696397f1fbee7e84283df64976c647218f1b321cda8ae0ca3b2eda057f5ebe335a17aae71917a
diff --git a/dev-java/openjdk-bin/files/openjdk-bin-14.env.sh b/dev-java/openjdk-bin/files/openjdk-bin-14.env.sh
new file mode 100644
index 0000000..9e9c5ec
--- /dev/null
+++ b/dev-java/openjdk-bin/files/openjdk-bin-14.env.sh
@@ -0,0 +1,16 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+VERSION="AdoptOpenJDK ${PV}"
+JAVA_HOME="${EPREFIX}/opt/${P}"
+JDK_HOME="${EPREFIX}/opt/${P}"
+JAVAC="\${JAVA_HOME}/bin/javac"
+PATH="\${JAVA_HOME}/bin"
+ROOTPATH="\${JAVA_HOME}/bin"
+LDPATH="\${JAVA_HOME}/lib/:\${JAVA_HOME}/lib/server/"
+MANPATH=""
+PROVIDES_TYPE="JDK JRE"
+PROVIDES_VERSION="${SLOT}"
+BOOTCLASSPATH=""
+GENERATION="2"
+ENV_VARS="JAVA_HOME JDK_HOME JAVAC PATH ROOTPATH LDPATH MANPATH"
diff --git a/dev-java/openjdk-bin/metadata.xml b/dev-java/openjdk-bin/metadata.xml
new file mode 100644
index 0000000..439b4e1
--- /dev/null
+++ b/dev-java/openjdk-bin/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ Java™ is the world's leading programming language and platform.
+ The code for Java is open source and available at OpenJDK™.
+ AdoptOpenJDK provides prebuilt OpenJDK binaries from a fully open source set of build scripts and infrastructure.
+ </longdescription>
+ <use>
+ <flag name="headless-awt">Don't install the X backend for AWT, needed by some GUIs (used to be X flag)</flag>
+ <flag name="gentoo-vm">Allow this JDK to be recognised by Gentoo (package manager, eselect, java-config, EXPERIMENTAL!)</flag>
+ <flag name="source">Install JVM sources</flag>
+ <flag name="webstart">Provide javaws command through symlink to icedtea-web</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-java/openjdk-bin/openjdk-bin-14.0.2_p12.ebuild b/dev-java/openjdk-bin/openjdk-bin-14.0.2_p12.ebuild
new file mode 100644
index 0000000..4ccc008
--- /dev/null
+++ b/dev-java/openjdk-bin/openjdk-bin-14.0.2_p12.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit java-vm-2 toolchain-funcs
+
+abi_uri() {
+ echo "${2-$1}? (
+ https://github.com/AdoptOpenJDK/openjdk${SLOT}-binaries/releases/download/jdk-${MY_PV}/OpenJDK${SLOT}U-jdk_${1}_linux_hotspot_${MY_PV//+/_}.tar.gz
+ )"
+}
+
+MY_PV=${PV/_p/+}
+SLOT=${MY_PV%%[.+]*}
+
+SRC_URI="
+ $(abi_uri arm)
+ $(abi_uri aarch64 arm64)
+ $(abi_uri ppc64le ppc64)
+ $(abi_uri x64 amd64)
+"
+
+DESCRIPTION="Prebuilt Java JDK binaries provided by AdoptOpenJDK"
+HOMEPAGE="https://adoptopenjdk.net"
+LICENSE="GPL-2-with-classpath-exception"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64"
+IUSE="alsa cups doc +gentoo-vm headless-awt nsplugin selinux source webstart"
+
+RDEPEND="
+ media-libs/fontconfig:1.0
+ media-libs/freetype:2
+ >=sys-apps/baselayout-java-0.1.0-r1
+ >=sys-libs/glibc-2.2.5:*
+ sys-libs/zlib
+ alsa? ( media-libs/alsa-lib )
+ cups? ( net-print/cups )
+ doc? ( dev-java/java-sdk-docs:${SLOT} )
+ selinux? ( sec-policy/selinux-java )
+ !headless-awt? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXtst
+ )"
+
+PDEPEND="webstart? ( >=dev-java/icedtea-web-1.6.1:0 )
+ nsplugin? ( >=dev-java/icedtea-web-1.6.1:0[nsplugin] )"
+
+RESTRICT="preserve-libs splitdebug"
+QA_PREBUILT="*"
+
+S="${WORKDIR}/jdk-${MY_PV}"
+
+pkg_pretend() {
+ if [[ "$(tc-is-softfloat)" != "no" ]]; then
+ die "These binaries require a hardfloat system."
+ fi
+}
+
+src_install() {
+ local dest="/opt/${P}"
+ local ddest="${ED%/}/${dest#/}"
+
+ # Not sure why they bundle this as it's commonly available and they
+ # only do so on x86_64. It's needed by libfontmanager.so. IcedTea
+ # also has an explicit dependency while Oracle seemingly dlopens it.
+ rm -vf lib/libfreetype.so || die
+
+ # Oracle and IcedTea have libjsoundalsa.so depending on
+ # libasound.so.2 but AdoptOpenJDK only has libjsound.so. Weird.
+ if ! use alsa ; then
+ rm -v lib/libjsound.* || die
+ fi
+
+ if use headless-awt ; then
+ rm -v lib/lib*{[jx]awt,splashscreen}* || die
+ fi
+
+ if ! use source ; then
+ rm -v lib/src.zip || die
+ fi
+
+ rm -v lib/security/cacerts || die
+ dosym ../../../../etc/ssl/certs/java/cacerts \
+ "${dest}"/lib/security/cacerts
+
+ dodir "${dest}"
+ cp -pPR * "${ddest}" || die
+
+ # provide stable symlink
+ dosym "${P}" "/opt/${PN}-${SLOT}"
+
+ use gentoo-vm && java-vm_install-env "${FILESDIR}"/${PN}-${SLOT}.env.sh
+ java-vm_set-pax-markings "${ddest}"
+ java-vm_revdep-mask
+ java-vm_sandbox-predict /dev/random /proc/self/coredump_filter
+}
+
+pkg_postinst() {
+ java-vm-2_pkg_postinst
+
+ if use gentoo-vm ; then
+ ewarn "WARNING! You have enabled the gentoo-vm USE flag, making this JDK"
+ ewarn "recognised by the system. This will almost certainly break"
+ ewarn "many java ebuilds as they are not ready for openjdk-11"
+ else
+ ewarn "The experimental gentoo-vm USE flag has not been enabled so this JDK"
+ ewarn "will not be recognised by the system. For example, simply calling"
+ ewarn "\"java\" will launch a different JVM. This is necessary until Gentoo"
+ ewarn "fully supports Java 11. This JDK must therefore be invoked using its"
+ ewarn "absolute location under ${EPREFIX}/opt/${P}."
+ fi
+}