summaryrefslogtreecommitdiff
path: root/dev-java
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2022-06-07 14:22:47 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2022-06-07 14:22:47 -0400
commit27b7dc1860616ae9acc46c05af0a242c80553aa0 (patch)
treead9be136cf02b09e3706cf4f5812a95a5d11d3f8 /dev-java
parenteaea74c6564fa56927330cf4c70158f2c7acc325 (diff)
downloadgentoo-overlay-27b7dc1860616ae9acc46c05af0a242c80553aa0.tar.xz
gentoo-overlay-27b7dc1860616ae9acc46c05af0a242c80553aa0.zip
dev-java/openj9-openjdk-bin: sync openjdk-bin::gentoo
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/openj9-openjdk-bin/openj9-openjdk-bin-11.0.15.10.0.32.0.ebuild81
-rw-r--r--dev-java/openj9-openjdk-bin/openj9-openjdk-bin-17.0.3.7.0.32.0.ebuild81
2 files changed, 98 insertions, 64 deletions
diff --git a/dev-java/openj9-openjdk-bin/openj9-openjdk-bin-11.0.15.10.0.32.0.ebuild b/dev-java/openj9-openjdk-bin/openj9-openjdk-bin-11.0.15.10.0.32.0.ebuild
index 32b852c..a7783d8 100644
--- a/dev-java/openj9-openjdk-bin/openj9-openjdk-bin-11.0.15.10.0.32.0.ebuild
+++ b/dev-java/openj9-openjdk-bin/openj9-openjdk-bin-11.0.15.10.0.32.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit eapi7-ver java-vm-2 toolchain-funcs
+inherit java-vm-2 toolchain-funcs
abi_uri() {
echo "${2-$1}? (
@@ -32,20 +32,24 @@ KEYWORDS="~amd64 ~arm64 ~ppc64 ~s390"
IUSE="alsa cups debug +gentoo-vm headless-awt selinux source"
RDEPEND="
- media-libs/fontconfig:1.0
- media-libs/freetype:2
>=sys-apps/baselayout-java-0.1.0-r1
- >=sys-libs/glibc-2.2.5:*
- sys-libs/zlib
- alsa? ( media-libs/alsa-lib )
- cups? ( net-print/cups )
- selinux? ( sec-policy/selinux-java )
- !headless-awt? (
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXi
- x11-libs/libXrender
- x11-libs/libXtst
+ kernel_linux? (
+ media-libs/fontconfig:1.0
+ media-libs/freetype:2
+ media-libs/harfbuzz
+ elibc_glibc? ( >=sys-libs/glibc-2.2.5:* )
+ elibc_musl? ( sys-libs/musl )
+ sys-libs/zlib
+ alsa? ( media-libs/alsa-lib )
+ cups? ( net-print/cups )
+ selinux? ( sec-policy/selinux-java )
+ !headless-awt? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXtst
+ )
)"
RESTRICT="preserve-libs splitdebug"
@@ -59,25 +63,39 @@ pkg_pretend() {
fi
}
-do_rm() {
- rm -v $1 || die
- if use debug ; then
- rm -v "${S}-debug-image"/$1 || die
+src_unpack() {
+ default
+ if [[ ${A} == *_mac_* ]] ; then
+ mv -v "${S}/Contents/Home/"* "${S}" || die
+ rm -Rf "${S}/Contents" # drop macOS executable
fi
}
src_install() {
local dest="/opt/${P}"
- local ddest="${ED%/}/${dest#/}"
-
- # Oracle and IcedTea have libjsoundalsa.so depending on
- # libasound.so.2 but AdoptOpenJDK only has libjsound.so. Weird.
- if ! use alsa ; then
- do_rm 'lib/libjsound.*'
- fi
-
- if use headless-awt ; then
- do_rm 'lib/lib*{[jx]awt,splashscreen}*'
+ local ddest="${ED}/${dest#/}"
+
+ # on macOS if they would exist they would be called .dylib, but most
+ # importantly, there are no different providers, so everything
+ # that's shipped works.
+ if [[ ${A} != *_mac_* ]] ; then
+ # Not sure why they bundle this as it's commonly available and they
+ # only do so on x86_64. It's needed by libfontmanager.so. IcedTea
+ # also has an explicit dependency while Oracle seemingly dlopens it.
+ rm -vf lib/libfreetype.so || die
+
+ # prefer system copy # https://bugs.gentoo.org/776676
+ rm -vf lib/libharfbuzz.so || die
+
+ # Oracle and IcedTea have libjsoundalsa.so depending on
+ # libasound.so.2 but AdoptOpenJDK only has libjsound.so. Weird.
+ if ! use alsa ; then
+ rm -v lib/libjsound.* || die
+ fi
+
+ if use headless-awt ; then
+ rm -v lib/lib*{[jx]awt,splashscreen}* || die
+ fi
fi
if ! use source ; then
@@ -85,8 +103,7 @@ src_install() {
fi
rm -v lib/security/cacerts || die
- dosym ../../../../etc/ssl/certs/java/cacerts \
- "${dest}"/lib/security/cacerts
+ dosym -r /etc/ssl/certs/java/cacerts "${dest}"/lib/security/cacerts
dodir "${dest}"
cp -pPR * "${ddest}" || die
diff --git a/dev-java/openj9-openjdk-bin/openj9-openjdk-bin-17.0.3.7.0.32.0.ebuild b/dev-java/openj9-openjdk-bin/openj9-openjdk-bin-17.0.3.7.0.32.0.ebuild
index 32b852c..a7783d8 100644
--- a/dev-java/openj9-openjdk-bin/openj9-openjdk-bin-17.0.3.7.0.32.0.ebuild
+++ b/dev-java/openj9-openjdk-bin/openj9-openjdk-bin-17.0.3.7.0.32.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit eapi7-ver java-vm-2 toolchain-funcs
+inherit java-vm-2 toolchain-funcs
abi_uri() {
echo "${2-$1}? (
@@ -32,20 +32,24 @@ KEYWORDS="~amd64 ~arm64 ~ppc64 ~s390"
IUSE="alsa cups debug +gentoo-vm headless-awt selinux source"
RDEPEND="
- media-libs/fontconfig:1.0
- media-libs/freetype:2
>=sys-apps/baselayout-java-0.1.0-r1
- >=sys-libs/glibc-2.2.5:*
- sys-libs/zlib
- alsa? ( media-libs/alsa-lib )
- cups? ( net-print/cups )
- selinux? ( sec-policy/selinux-java )
- !headless-awt? (
- x11-libs/libX11
- x11-libs/libXext
- x11-libs/libXi
- x11-libs/libXrender
- x11-libs/libXtst
+ kernel_linux? (
+ media-libs/fontconfig:1.0
+ media-libs/freetype:2
+ media-libs/harfbuzz
+ elibc_glibc? ( >=sys-libs/glibc-2.2.5:* )
+ elibc_musl? ( sys-libs/musl )
+ sys-libs/zlib
+ alsa? ( media-libs/alsa-lib )
+ cups? ( net-print/cups )
+ selinux? ( sec-policy/selinux-java )
+ !headless-awt? (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXtst
+ )
)"
RESTRICT="preserve-libs splitdebug"
@@ -59,25 +63,39 @@ pkg_pretend() {
fi
}
-do_rm() {
- rm -v $1 || die
- if use debug ; then
- rm -v "${S}-debug-image"/$1 || die
+src_unpack() {
+ default
+ if [[ ${A} == *_mac_* ]] ; then
+ mv -v "${S}/Contents/Home/"* "${S}" || die
+ rm -Rf "${S}/Contents" # drop macOS executable
fi
}
src_install() {
local dest="/opt/${P}"
- local ddest="${ED%/}/${dest#/}"
-
- # Oracle and IcedTea have libjsoundalsa.so depending on
- # libasound.so.2 but AdoptOpenJDK only has libjsound.so. Weird.
- if ! use alsa ; then
- do_rm 'lib/libjsound.*'
- fi
-
- if use headless-awt ; then
- do_rm 'lib/lib*{[jx]awt,splashscreen}*'
+ local ddest="${ED}/${dest#/}"
+
+ # on macOS if they would exist they would be called .dylib, but most
+ # importantly, there are no different providers, so everything
+ # that's shipped works.
+ if [[ ${A} != *_mac_* ]] ; then
+ # Not sure why they bundle this as it's commonly available and they
+ # only do so on x86_64. It's needed by libfontmanager.so. IcedTea
+ # also has an explicit dependency while Oracle seemingly dlopens it.
+ rm -vf lib/libfreetype.so || die
+
+ # prefer system copy # https://bugs.gentoo.org/776676
+ rm -vf lib/libharfbuzz.so || die
+
+ # Oracle and IcedTea have libjsoundalsa.so depending on
+ # libasound.so.2 but AdoptOpenJDK only has libjsound.so. Weird.
+ if ! use alsa ; then
+ rm -v lib/libjsound.* || die
+ fi
+
+ if use headless-awt ; then
+ rm -v lib/lib*{[jx]awt,splashscreen}* || die
+ fi
fi
if ! use source ; then
@@ -85,8 +103,7 @@ src_install() {
fi
rm -v lib/security/cacerts || die
- dosym ../../../../etc/ssl/certs/java/cacerts \
- "${dest}"/lib/security/cacerts
+ dosym -r /etc/ssl/certs/java/cacerts "${dest}"/lib/security/cacerts
dodir "${dest}"
cp -pPR * "${ddest}" || die