summaryrefslogtreecommitdiff
path: root/dev-java
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-11-10 11:03:19 -0500
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-11-10 11:03:19 -0500
commita0d5b7905b4b3ffb2405b7f3b017a2b8da11e689 (patch)
tree72a5b3fa51bf57eec0b61365192d969a6729f2f4 /dev-java
parent559ce92a84852a52f170afab3214b10709a97d13 (diff)
downloadgentoo-overlay-a0d5b7905b4b3ffb2405b7f3b017a2b8da11e689.tar.xz
gentoo-overlay-a0d5b7905b4b3ffb2405b7f3b017a2b8da11e689.zip
dev-java/{,openj9-}openjdk: rm A workaround, unused patch
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/openj9-openjdk/files/openj9-make-jvmti-test-variables-static.patch68
-rw-r--r--dev-java/openj9-openjdk/files/openjdk-src-doubledollar.patch28
-rw-r--r--dev-java/openj9-openjdk/openj9-openjdk-15.0.23.0.ebuild6
-rw-r--r--dev-java/openj9-openjdk/openj9-openjdk-15.9999.ebuild6
-rw-r--r--dev-java/openjdk/files/openjdk-src-doubledollar.patch28
-rw-r--r--dev-java/openjdk/openjdk-15.0.1_p9.ebuild6
6 files changed, 62 insertions, 80 deletions
diff --git a/dev-java/openj9-openjdk/files/openj9-make-jvmti-test-variables-static.patch b/dev-java/openj9-openjdk/files/openj9-make-jvmti-test-variables-static.patch
deleted file mode 100644
index 5d5b8a7..0000000
--- a/dev-java/openj9-openjdk/files/openj9-make-jvmti-test-variables-static.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-From b91f42fc90179585c3e2a9866e93a3168b1ada9d Mon Sep 17 00:00:00 2001
-From: Graham Chapman <graham_chapman@ca.ibm.com>
-Date: Sat, 25 Jul 2020 16:13:13 -0400
-Subject: [PATCH] Make JVMTI test variables static
-
-Two tests declare the same named global non-statically which breaks some
-newer compilers.
-
-Fixes: #10252
-
-[ci skip]
-
-Signed-off-by: Graham Chapman <graham_chapman@ca.ibm.com>
----
- .../src/com/ibm/jvmti/tests/traceSubscription/ts001.c | 4 ++--
- .../jvmtitests/src/com/ibm/jvmti/tests/verboseGC/vgc001.c | 8 ++++----
- 2 files changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/runtime/tests/jvmtitests/src/com/ibm/jvmti/tests/traceSubscription/ts001.c b/runtime/tests/jvmtitests/src/com/ibm/jvmti/tests/traceSubscription/ts001.c
-index 97843fc7c7..2c1e1ae67f 100644
---- a/runtime/tests/jvmtitests/src/com/ibm/jvmti/tests/traceSubscription/ts001.c
-+++ b/runtime/tests/jvmtitests/src/com/ibm/jvmti/tests/traceSubscription/ts001.c
-@@ -1,5 +1,5 @@
- /*******************************************************************************
-- * Copyright (c) 2001, 2018 IBM Corp. and others
-+ * Copyright (c) 2001, 2020 IBM Corp. and others
- *
- * This program and the accompanying materials are made available under
- * the terms of the Eclipse Public License 2.0 which accompanies this
-@@ -35,7 +35,7 @@ static jvmtiExtensionFunction subscribe = NULL;
- static jvmtiExtensionFunction unsubscribe = NULL;
- static jvmtiExtensionFunction flush = NULL;
- static jvmtiExtensionFunction metadata = NULL;
--void *subscriptionID;
-+static void *subscriptionID;
- volatile static jint bufferCount = 0;
- volatile static jint bufferCountFinal = 0;
- volatile static int completed = 0;
-diff --git a/runtime/tests/jvmtitests/src/com/ibm/jvmti/tests/verboseGC/vgc001.c b/runtime/tests/jvmtitests/src/com/ibm/jvmti/tests/verboseGC/vgc001.c
-index 2fda9e8bd7..f1601298af 100644
---- a/runtime/tests/jvmtitests/src/com/ibm/jvmti/tests/verboseGC/vgc001.c
-+++ b/runtime/tests/jvmtitests/src/com/ibm/jvmti/tests/verboseGC/vgc001.c
-@@ -1,5 +1,5 @@
- /*******************************************************************************
-- * Copyright (c) 2001, 2018 IBM Corp. and others
-+ * Copyright (c) 2001, 2020 IBM Corp. and others
- *
- * This program and the accompanying materials are made available under
- * the terms of the Eclipse Public License 2.0 which accompanies this
-@@ -31,15 +31,15 @@ static agentEnv * env;
- static jvmtiExtensionFunction subscribe = NULL;
- static jvmtiExtensionFunction unsubscribe = NULL;
-
--void *subscriptionID;
-+static void *subscriptionID;
- volatile static jint bufferCount = 0;
- volatile static int alarmed = 0;
-
--void *subscriptionID2;
-+static void *subscriptionID2;
- volatile static jint bufferCount2 = 0;
- volatile static int alarmed2 = 0;
-
--void *subscriptionID3;
-+static void *subscriptionID3;
- volatile static jint bufferCount3 = 0;
- volatile static int alarmed3 = 0;
-
diff --git a/dev-java/openj9-openjdk/files/openjdk-src-doubledollar.patch b/dev-java/openj9-openjdk/files/openjdk-src-doubledollar.patch
new file mode 100644
index 0000000..c1497d5
--- /dev/null
+++ b/dev-java/openj9-openjdk/files/openjdk-src-doubledollar.patch
@@ -0,0 +1,28 @@
+From 0601ac847afc86e9010685bb85d82a00a33355b5 Mon Sep 17 00:00:00 2001
+From: erikj <erik.joelsson@oracle.com>
+Date: Mon, 2 Nov 2020 06:18:08 -0800
+Subject: [PATCH] Add DoubleDollar call to protect java class file names with
+ dollar in them
+
+---
+ make/common/JavaCompilation.gmk | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/make/common/JavaCompilation.gmk b/make/common/JavaCompilation.gmk
+index 444ded0fc06..bedb971115b 100644
+--- a/make/common/JavaCompilation.gmk
++++ b/make/common/JavaCompilation.gmk
+@@ -311,9 +311,11 @@ define SetupJavaCompilationBody
+ ifneq ($$($1_KEEP_DUPS), true)
+ # Remove duplicate source files by keeping the first found of each duplicate.
+ # This allows for automatic overrides with custom or platform specific versions
+- # source files.
++ # source files. Need to call DoubleDollar as we have java classes with '$' in
++ # their names.
+ $1_SRCS := $$(strip $$(foreach s, $$($1_SRCS), \
+- $$(eval relative_src := $$(call remove-prefixes, $$($1_SRC), $$(s))) \
++ $$(eval relative_src := $$(call remove-prefixes, $$($1_SRC), \
++ $$(call DoubleDollar, $$(s)))) \
+ $$(if $$($1_$$(relative_src)), \
+ , \
+ $$(eval $1_$$(relative_src) := 1) $$(s))))
diff --git a/dev-java/openj9-openjdk/openj9-openjdk-15.0.23.0.ebuild b/dev-java/openj9-openjdk/openj9-openjdk-15.0.23.0.ebuild
index 96962ee..23ae86f 100644
--- a/dev-java/openj9-openjdk/openj9-openjdk-15.0.23.0.ebuild
+++ b/dev-java/openj9-openjdk/openj9-openjdk-15.0.23.0.ebuild
@@ -144,6 +144,7 @@ src_prepare() {
default
+ eapply "${FILESDIR}/openjdk-src-doubledollar.patch"
eapply -d omr -- "${FILESDIR}/omr-omrstr-iconv-failure-overflow.patch"
eapply -d omr -- "${FILESDIR}/omr-fam.patch"
@@ -233,10 +234,7 @@ src_compile() {
$(usex doc docs '')
$(usex jbootstrap bootcycle-images product-images)
)
- (
- unset A
- emake "${myemakeargs[@]}" -j1 #nowarn
- )
+ emake "${myemakeargs[@]}" -j1 #nowarn
}
src_install() {
diff --git a/dev-java/openj9-openjdk/openj9-openjdk-15.9999.ebuild b/dev-java/openj9-openjdk/openj9-openjdk-15.9999.ebuild
index 01fc9d6..f1ba818 100644
--- a/dev-java/openj9-openjdk/openj9-openjdk-15.9999.ebuild
+++ b/dev-java/openj9-openjdk/openj9-openjdk-15.9999.ebuild
@@ -144,6 +144,7 @@ src_prepare() {
default
+ eapply "${FILESDIR}/openjdk-src-doubledollar.patch"
eapply -d omr -- "${FILESDIR}/omr-omrstr-iconv-failure-overflow.patch"
eapply -d omr -- "${FILESDIR}/omr-fam.patch"
@@ -233,10 +234,7 @@ src_compile() {
$(usex doc docs '')
$(usex jbootstrap bootcycle-images product-images)
)
- (
- unset A
- emake "${myemakeargs[@]}" -j1 #nowarn
- )
+ emake "${myemakeargs[@]}" -j1 #nowarn
}
src_install() {
diff --git a/dev-java/openjdk/files/openjdk-src-doubledollar.patch b/dev-java/openjdk/files/openjdk-src-doubledollar.patch
new file mode 100644
index 0000000..c1497d5
--- /dev/null
+++ b/dev-java/openjdk/files/openjdk-src-doubledollar.patch
@@ -0,0 +1,28 @@
+From 0601ac847afc86e9010685bb85d82a00a33355b5 Mon Sep 17 00:00:00 2001
+From: erikj <erik.joelsson@oracle.com>
+Date: Mon, 2 Nov 2020 06:18:08 -0800
+Subject: [PATCH] Add DoubleDollar call to protect java class file names with
+ dollar in them
+
+---
+ make/common/JavaCompilation.gmk | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/make/common/JavaCompilation.gmk b/make/common/JavaCompilation.gmk
+index 444ded0fc06..bedb971115b 100644
+--- a/make/common/JavaCompilation.gmk
++++ b/make/common/JavaCompilation.gmk
+@@ -311,9 +311,11 @@ define SetupJavaCompilationBody
+ ifneq ($$($1_KEEP_DUPS), true)
+ # Remove duplicate source files by keeping the first found of each duplicate.
+ # This allows for automatic overrides with custom or platform specific versions
+- # source files.
++ # source files. Need to call DoubleDollar as we have java classes with '$' in
++ # their names.
+ $1_SRCS := $$(strip $$(foreach s, $$($1_SRCS), \
+- $$(eval relative_src := $$(call remove-prefixes, $$($1_SRC), $$(s))) \
++ $$(eval relative_src := $$(call remove-prefixes, $$($1_SRC), \
++ $$(call DoubleDollar, $$(s)))) \
+ $$(if $$($1_$$(relative_src)), \
+ , \
+ $$(eval $1_$$(relative_src) := 1) $$(s))))
diff --git a/dev-java/openjdk/openjdk-15.0.1_p9.ebuild b/dev-java/openjdk/openjdk-15.0.1_p9.ebuild
index 5b855a5..16e914f 100644
--- a/dev-java/openjdk/openjdk-15.0.1_p9.ebuild
+++ b/dev-java/openjdk/openjdk-15.0.1_p9.ebuild
@@ -101,6 +101,7 @@ pkg_setup() {
}
src_prepare() {
+ eapply "${FILESDIR}/openjdk-src-doubledollar.patch"
default
chmod +x configure || die
}
@@ -173,10 +174,7 @@ src_compile() {
$(usex doc docs '')
$(usex jbootstrap bootcycle-images product-images)
)
- (
- unset A
- emake "${myemakeargs[@]}" -j1 #nowarn
- )
+ emake "${myemakeargs[@]}" -j1 #nowarn
}
src_install() {