summaryrefslogtreecommitdiff
path: root/dev-libs/highway/highway-0.14.2.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-10-05 20:51:22 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-10-05 20:51:22 -0400
commit81cad988488b776625b1a7c0c3f4ee726ec73d77 (patch)
tree35f1e05eca3f880918e0809dffb8b672e4a0a18d /dev-libs/highway/highway-0.14.2.ebuild
parenteaffdb1a511897182ce9b541b6cf3e370d3f429f (diff)
downloadgentoo-overlay-81cad988488b776625b1a7c0c3f4ee726ec73d77.tar.xz
gentoo-overlay-81cad988488b776625b1a7c0c3f4ee726ec73d77.zip
dev-libs/highway: bump
Diffstat (limited to 'dev-libs/highway/highway-0.14.2.ebuild')
-rw-r--r--dev-libs/highway/highway-0.14.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-libs/highway/highway-0.14.2.ebuild b/dev-libs/highway/highway-0.14.2.ebuild
new file mode 100644
index 0000000..7f21cc2
--- /dev/null
+++ b/dev-libs/highway/highway-0.14.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Performance-portable, length-agnostic SIMD with runtime dispatch"
+HOMEPAGE="https://github.com/google/highway"
+SRC_URI="https://github.com/google/highway/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="test? ( dev-cpp/gtest )"
+RDEPEND=""
+BDEPEND=""
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test ON OFF)
+ -DHWY_SYSTEM_GTEST=ON
+ )
+ cmake_src_configure
+}