summaryrefslogtreecommitdiff
path: root/dev-libs/libdwarf/libdwarf-0.2.0.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-10-20 11:36:10 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-10-20 11:36:10 -0400
commitc3296314ec223d2bbf2925309d1ce553d9dd6bab (patch)
tree4c77ad3d3e2551395eaf8d94df793d8385cbaaac /dev-libs/libdwarf/libdwarf-0.2.0.ebuild
parentfcb4a6798ac8bb721dc018ff0fd4801e419864b4 (diff)
downloadgentoo-overlay-c3296314ec223d2bbf2925309d1ce553d9dd6bab.tar.xz
gentoo-overlay-c3296314ec223d2bbf2925309d1ce553d9dd6bab.zip
dev-libs/libdwarf: bump to 0.2.0
Diffstat (limited to 'dev-libs/libdwarf/libdwarf-0.2.0.ebuild')
-rw-r--r--dev-libs/libdwarf/libdwarf-0.2.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/libdwarf/libdwarf-0.2.0.ebuild b/dev-libs/libdwarf/libdwarf-0.2.0.ebuild
new file mode 100644
index 0000000..39a2c3c
--- /dev/null
+++ b/dev-libs/libdwarf/libdwarf-0.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="The DWARF Debugging Information Format"
+HOMEPAGE="https://www.prevanders.net/dwarf.html"
+SRC_URI="https://www.prevanders.net/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dwarfexample dwarfgen static-libs"
+
+DEPEND="
+ sys-libs/zlib
+ dwarfgen? ( virtual/libelf )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ --includedir="${EPREFIX}/usr/include/${PN}"
+ --enable-shared
+ $(use_enable dwarfexample)
+ $(use_enable dwarfgen)
+ $(use_enable dwarfgen libelf)
+ $(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
+}