summaryrefslogtreecommitdiff
path: root/dev-libs/libdwarf/libdwarf-0.3.0.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-11-17 16:51:37 -0500
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2021-11-17 16:51:37 -0500
commiteb4964f65a2d13bd930da6cdd213713f52b35856 (patch)
tree11f6b8b7033eecd5febcf0283743644df20ce6bc /dev-libs/libdwarf/libdwarf-0.3.0.ebuild
parentf55decff52ace03d2561816f30ec2f103eb21b11 (diff)
downloadgentoo-overlay-eb4964f65a2d13bd930da6cdd213713f52b35856.tar.xz
gentoo-overlay-eb4964f65a2d13bd930da6cdd213713f52b35856.zip
dev-libs/libdwarf: update to 0.3.0
Diffstat (limited to 'dev-libs/libdwarf/libdwarf-0.3.0.ebuild')
-rw-r--r--dev-libs/libdwarf/libdwarf-0.3.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-libs/libdwarf/libdwarf-0.3.0.ebuild b/dev-libs/libdwarf/libdwarf-0.3.0.ebuild
new file mode 100644
index 0000000..39a2c3c
--- /dev/null
+++ b/dev-libs/libdwarf/libdwarf-0.3.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="The DWARF Debugging Information Format"
+HOMEPAGE="https://www.prevanders.net/dwarf.html"
+SRC_URI="https://www.prevanders.net/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dwarfexample dwarfgen static-libs"
+
+DEPEND="
+ sys-libs/zlib
+ dwarfgen? ( virtual/libelf )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myeconfargs=(
+ --includedir="${EPREFIX}/usr/include/${PN}"
+ --enable-shared
+ $(use_enable dwarfexample)
+ $(use_enable dwarfgen)
+ $(use_enable dwarfgen libelf)
+ $(use_enable static-libs static)
+ )
+ econf "${myeconfargs[@]}"
+}