summaryrefslogtreecommitdiff
path: root/dev-libs/rocm-opencl-runtime/files/rocm-opencl-runtime-3.5.0-amdocl64icd.patch
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-08-04 13:48:06 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-08-04 13:48:06 -0400
commitbe9d25964b12d103b4129dbfbc6f4fcffac7fad3 (patch)
treef9ab01131c5f56c206040cf886836aebc084ca25 /dev-libs/rocm-opencl-runtime/files/rocm-opencl-runtime-3.5.0-amdocl64icd.patch
parent09620746b58af6a434003b3b81d6878db551aa30 (diff)
downloadgentoo-overlay-be9d25964b12d103b4129dbfbc6f4fcffac7fad3.tar.xz
gentoo-overlay-be9d25964b12d103b4129dbfbc6f4fcffac7fad3.zip
dev-libs/rocm-opencl-runtime: import
remove unnecessary deps
Diffstat (limited to 'dev-libs/rocm-opencl-runtime/files/rocm-opencl-runtime-3.5.0-amdocl64icd.patch')
-rw-r--r--dev-libs/rocm-opencl-runtime/files/rocm-opencl-runtime-3.5.0-amdocl64icd.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/dev-libs/rocm-opencl-runtime/files/rocm-opencl-runtime-3.5.0-amdocl64icd.patch b/dev-libs/rocm-opencl-runtime/files/rocm-opencl-runtime-3.5.0-amdocl64icd.patch
new file mode 100644
index 0000000..dadf212
--- /dev/null
+++ b/dev-libs/rocm-opencl-runtime/files/rocm-opencl-runtime-3.5.0-amdocl64icd.patch
@@ -0,0 +1,11 @@
+--- a/amdocl/CMakeLists.txt 2020-06-07 14:38:38.827042792 +0200
++++ b/amdocl/CMakeLists.txt 2020-06-07 14:38:27.505042835 +0200
+@@ -109,3 +109,8 @@
+ find_package(Threads REQUIRED)
+
+ target_link_libraries(amdocl64 amdrocclr_static Threads::Threads dl)
++
++file(GENERATE OUTPUT "${CMAKE_BINARY_DIR}/amdocl64.icd" CONTENT "$<TARGET_FILE_NAME:amdocl64>")
++install(FILES "${CMAKE_BINARY_DIR}/amdocl64.icd" DESTINATION "${CMAKE_INSTALL_FULL_SYSCONFDIR}/OpenCL/vendors/")
++
++