summaryrefslogtreecommitdiff
path: root/dev-python/fonttools/fonttools-4.14.0.ebuild
diff options
context:
space:
mode:
authorAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-09-23 08:21:20 -0400
committerAlex Xu (Hello71) <alex_y_xu@yahoo.ca>2020-09-23 08:21:20 -0400
commit3b7cada547e0b701f7491a8d644701e26ce3dd45 (patch)
tree9d4d96ff06094f1a45ba1ad8db2a38344742524b /dev-python/fonttools/fonttools-4.14.0.ebuild
parent8ba71d5d66802c5d08c298ab302a4bdeb2e6f701 (diff)
downloadgentoo-overlay-3b7cada547e0b701f7491a8d644701e26ce3dd45.tar.xz
gentoo-overlay-3b7cada547e0b701f7491a8d644701e26ce3dd45.zip
dev-python/fonttools: bump
Diffstat (limited to 'dev-python/fonttools/fonttools-4.14.0.ebuild')
-rw-r--r--dev-python/fonttools/fonttools-4.14.0.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/fonttools/fonttools-4.14.0.ebuild b/dev-python/fonttools/fonttools-4.14.0.ebuild
deleted file mode 100644
index f15fbef..0000000
--- a/dev-python/fonttools/fonttools-4.14.0.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python{3_6,3_7,3_8} )
-PYTHON_REQ_USE="xml(+)"
-
-inherit distutils-r1 virtualx
-
-DESCRIPTION="Library for manipulating TrueType, OpenType, AFM and Type1 fonts"
-HOMEPAGE="https://github.com/fonttools/fonttools/"
-SRC_URI="https://github.com/fonttools/fonttools/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 sparc x86"
-RESTRICT="!test? ( test )"
-IUSE="test"
-
-RDEPEND=""
-DEPEND="${RDEPEND}
- test? (
- >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
-
- >=dev-python/fs-2.4.9[${PYTHON_USEDEP}]
- app-arch/brotli[python,${PYTHON_USEDEP}]
- app-arch/zopfli
- )"
-
-python_prepare_all() {
- # When dev-python/pytest-shutil is installed, we get weird import errors.
- # This is due to incomplete nesting in the Tests/ tree:
- #
- # Tests/feaLib/__init__.py
- # Tests/ufoLib/__init__.py
- # Tests/svgLib/path/__init__.py
- # Tests/otlLib/__init__.py
- # Tests/varLib/__init__.py
- #
- # This tree requires an __init__.py in Tests/svgLib/ too, bug #701148.
- touch Tests/svgLib/__init__.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # virtualx used when matplotlib is installed causing plot module tests to run
- virtx pytest -vv Tests fontTools
-}